Aller au contenu

Filament ABS

Sam62

Membres
  • Compteur de contenus

    21
  • Inscrit(e) le

  • Dernière visite

Réputation sur la communauté

0 Neutre

À propos de Sam62

  • Rang
    3D Newbie
  1. Bonsoir j'ai réglé mon problème de fonctionnement pour le vfd, maintenant ca marche parfaitement, c'était du à un mauvais réglage de fréquence en 01-03. Par contre je contrôles la vitesse de la broche par le biais d'un convertisseur PWM 0-10V, voici le lien : https://fr.aliexpress.com/item/33050542276.html?spm=a2g0s.9042311.0.0.27426c37eHQPGL Le soucis est que si je rentres la commande M3 S12000, la broche s'allume mais tourne à 24000 tr/mm au lieu de 12000 et j'ai 5V en sortie sur le convertisseur. Il est alimenté en 12V et les drivers des moteurs en 36V avec des DM542. J'aimer
  2. Bon, c'est la cata pour le fonctionnement de la broche. A chaque étape je tombes sur un problème c'est quand même dingue, mais je ne baisserais pas les bras, je le ferais fonctionner cette CNC lol. Lien du VFD : https://fr.aliexpress.com/item/4000761593848.html?spm=a2g0s.9042311.0.0.255b6c37Elg6eg La broche : Donc je lis la notice, je me renseigne sur ce modèle au niveau des paramètres à régler sur le VFD et j'y vais, mais problème :Quand je tourne le potentiomètre du VFD (oui j'ai laissé le contrôle sur le panneau pour les test), le VFD me met une erreur 001 (je posterais en PD
  3. Cc je reviens vers vous pour dire que j'ai réglé mon problème de GRBL5X, tu avais raison ma CNC étant physiquement de 3 axes GRBL était configuré d'origine pour 5 axes, en réglant le config.h en 3 axes ca fonctionne.
  4. Oui au fait un gros merci pour ton aide et tes conseils !!!!!!
  5. Oui bien sur que tu m'as aidé, mais je n'arrives pas à comprendre pourquoi les soft limit ne fonctionnent avec ce grbl5x et que ca marche avec un autre, en plus j'ai vraiment besoin d'un grbl 4 axes. Bon la CNC marche nickel la mais en 3 axes. Pour les directions d'axes, oui tu m'as bien aidé, pour preuve mon gcode fait fusion sous respecte bien l'origine travail ainsi que toute les direction (d'ailleurs si tu peux me dire quel PP 4 axes tu utilises sous fusion). Ha oui pour info, tu me dis que ma petite CNC est plus jolie, super ca fait plaisir. Mais pour l'histoire de cette
  6. Désolé d'interrompre votre débat sur les FDC (je plaisantes) Mais j'ai réglé le problème si on peut, une personne avec qui je suis en contact par mail depuis un bon moment et qui m'a vraiment dans le monde de la CNC (attention je ne suis pas pro mais un tout petit débutant) m'a conseillé d'installer sa version de GRBL (cette version gére le backlash). J'ai donc téléverser cette autre version et la comme par magie tout fonctionne nickel, les soft limit activé la cnc tourne nickel. Le problème dans mon cas viens de la version GRBL5X, car avec une autre ca marche, d'où viens le pr
  7. Petite question qui pourrait paraitre bête, mais je ne m'y connais pas assez pour être sur, j'essaye de réfléchir (pas facile des moments mdr), mais est ce que ca ne pourrait pas venir des FDC qui sont câblé en NC ? Après sur le ramps 1.6 j'ai mis les FDC en fin câblé sur X-, Y- et Z+ (sur la broche S et le -), j'ai essayé de les branché sur les autres aussi c'est à dire X+ Y+ Z- toute les combinaisons possible mais le homing se fait de la même façon, j'ai l'impression que le + et le - n'a pas d'importance. Après je viens de modéliser un petit dessin et gcode en trois axes pour teste
  8. La suite après un homing et un test pour bouger un axe :
  9. Cc, voila quelques qui seront plus clair pour toi avec tous mes réglages GRBL : Fin de course câblé en NC.
  10. Oui j'ai dus modifié mon $23 et le mettre à zéro, du coup les axes se déplacent comme tu me l'as dis (sur ta photo avec les flèches), le homing fonctionne avec $23=0. (mon $27 est à 2). Mes soft limits sont rentrés par rapport à la distance max de chaque axe moins quelques millimètres pour éviter toute collision. 130=380, 131=280, 132=75. Je lances CNCjS et je fais le homing, je me retrouves donc avec des coordonnées "position machine" en X=-2, Y=-2 et Z=-2. Paramètre $20 activé, impossible de faire bouger un axe, j'ai une alarme soft limit.
  11. Je sais très bien que c'est un métier et qui plus est pas facile, mais de simple explication peuvent suffirent pour que je comprennes. (le sens doit être pareil que sur mon écran en l'occurrence Fusion 360, ca j'ai bien compris), enfin bref je mets le sens des axes comme tu me le conseilles et j'essaye de refaire le homing pour voir (le mien est $23=3).
  12. Ok pas de soucis je vais inverser le sens des axes, mais personnellement je préfères l'axe X sur le plus grand coté, donc si tu me dis que ca pose de problème et que je dois juste inversé les axes je vais le faire.
  13. Alors l'ordre des axes est différents des étiquettes, j'ai modifiés ca : Alors a partir de cette photo si je jog en Y+ la tête viens vers moi, si je jog en X+ le portique va vers la gauche et si je jog en Z- la broche descends. Ne te fie pas aux étiquettes sur la machine, elles vont être enlevées.
  14. Pardon mais j'ai oublié de retirer les étiquettes, sur la photo on voit l'étiquette Y mais il faut que j'enlèves c'est le X maintenant. C'exactement ce qui se passe, mais regarde bien sur le screen de CNCjS, j'avais réglé le $27=3 et j'avais mis $130=380 et $131=280, je fais mon homing et je me retrouve avec 377 et 277. SI je mets $27=3, $130=100, $131=50 et que je refais un homing la j'aurais en position machine 97 et 47. Donc si $20=1, je ne peux rien faire après homing, j'ai une alarme.
  15. Autant pour moi, c'est vrai que je ne suis pas rentré dans le détail de la machine - arduino MEGA - Ramps 1.6 + - 4 driver TB6600 - GRBL5X Sur les photos est en position homing, j'ai juste dus inverser les fils du moteur sur le tb6600 pour le Z car je voulais avoir le homing Z en positif en haut, donc la si je jog sans le $20 activé ca marche et mon z descend et c'est en négatif et positif pour remonter. J'ai fais ca car dans dans fusion quand je génères un gcode 4 axe ou 3 axe, le Z est toujours en négatif.
×
×
  • Créer...