Aller au contenu

Filament ABS

Tfou57

Ondulation déplacement en X

Messages recommandés

Bonjour,

Je n'arrive pas à me séparer d'ondulation cyclique dans le sens de l'axe X:

J'ai l'impression de voir au pas de 4mm des ondulations cycliques

Amplitude très faible: Creux bosse : en mettant le réglet sur la tranche pour voir la rectitude je vois à peine le la lumière (jour)

Ces ondulations se sentent très bien au toucher et lorsqu'on voit les ondulations  sur le brillant du PLA

Problème de boitement du guidage court de l'axe X ? Le graissage à l'huile moteur ni fait rien ! 

Déplacement libre à la Main de la tête

L'imprimante a peu d'heures de fonctionnement

Avez-vous des défauts similaire à  60mm/s ?

Certes à 40mm/s les défauts seront atténués !

 

Dans le sens de l'axe Y : ondulations grosso modo 3 fois moindre que sur l'axe X ( les zones hautes)

Axe Z, rien à reprocher sur la régularité des couches !

  TMP à détruire Ondulation pas 4mm.pngà gauche défaut sur déplacement de l'axe X et à droite sur déplacement Y

Le Flash de l'appareil de photo amplifie la vision des défauts

TM à détruire PLA 0,1 Cura.pngTMP 2 à détruire Ondulation pas 4mm.png

Modifié (le) par Tfou57

Partager ce message


Lien à poster
Partager sur d’autres sites

ça serait pas le remplissage  ??? tu imprime contour puis remplissage ou remplissage puis contour, dans le deuxieme cas le contour est legerement poussé par la couche de remplissage.

fait un cube et arrete l'impression a moitier t'en aura le coeur net

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 7 minutes, olivierbart a dit :

ça serait pas le remplissage  ??? tu imprime contour puis remplissage ou remplissage puis contour, dans le deuxieme cas le contour est legerement poussé par la couche de remplissage.

fait un cube et arrete l'impression a moitier t'en aura le coeur net

:D Pas du tout une mauvaise idée , je crois que tu as raison .

Je crois que la solution est d'augmenter la zone de contour.

J'avais sous la main une pièce similaire dont j'ai interrompu l'impression après une hauteur de 5mm

Axe X et Axe Y même problème , les défauts avaient le même pas et ce pas est exactement le pas du remplissage sous forme de losange !

sur la photo :

Paroi horizontale ==>  axe X

Paroi verticale =====> axe y

Cela ce tient comme explication !

TMP à detruire DSCF2518.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

+1  pour le remplissage

essai de faire un test en mettant "épaisseur de la paroi" à 1.2

soit avec une buse de 0.4  = 3 tours, c'est plus long mais ça devrait atténuer les traces

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 11 minutes, pascal_lb a dit :

+1  pour le remplissage

essai de faire un test en mettant "épaisseur de la paroi" à 1.2

soit avec une buse de 0.4  = 3 tours, c'est plus long mais ça devrait atténuer les traces

Dès maintenant , je suis convaincu au vu de photo précédemment publiée.

Les 3 tours , c'est une règle à respecter toujours lorsqu'on veut un aspect extérieur soigné ?

Que peut-on faire en aspect pour les traces de déplacement buse lors du remplissage ?

 

Une autre question à la volée: Quelle précision dimensionnelle peut-on obtenir ?

En général j'ai toujours les cotes plus fortes. Sur  la même pièce j'ai des écart de 0 à +0.25mm

Modifié (le) par Tfou57

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 10 minutes, Tfou57 a dit :

Dès maintenant , je suis convaincu au vu de photo précédemment publiée.

Les 3 tours , c'est une règle à respecter toujours lorsqu'on veut un aspect extérieur soigné ?

non pas forcément, mais ça rend la pièce plus solide et l'aspect plus net

Pour les trace de buse de remplissage tu peux augmenter la rétractation, mais ça le fera toujours un peu

La précision à 0.25 ça fait un peu beaucoup, refait un réglage de tes axes X, Y, Z afin de tomber au plus juste en te servant de ça

https://nathan7.eu/stuff/RepRapCalculator/RepRapCalculator.html#MotorStuffPrecise

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 47 minutes, pascal_lb a dit :

La précision à 0.25 ça fait un peu beaucoup, refait un réglage de tes axes X, Y, Z afin de tomber au plus juste en te servant de ça

https://nathan7.eu/stuff/RepRapCalculator/RepRapCalculator.html#MotorStuffPrecise

Merci pour ces calculateurs,

J'ai une imprimante 3D que depuis 1 mois, j'apprends ...

Pour le réglage des axes X, Y, Z, je dois donc modifier les  valeurs des steeps X , les valeurs des steeps Y et les valeurs des steeps Z ?

D'après ce que j'ai compris:

1) Je me  déplace de 100mm avec les commandes de l'afficheur dans "Axis"

2) Je mesure le déplacement réellement réalisé

3) Je trouvee où le nombre de steep / mm avant calibration ?

3) Je remplis les cases du calculateur qui me donnera un nombre de steeps / mm

Où j'utilise cette valeur  de steeps / mm  par axe ?   Cela se calibre par le Start Code ?

 

Quand on remet en cause le nombre de steeps /mm de l'extruder d'alimentation en filament ?

 similaire sous toutes les cotes en X , une autre erreur possible en Y et encore une autre en Z ?

Par axe , une erreur proportionnelle à la cote (petit erreur pour les petite cote et inversement?

Connaissez-vous un post en français qui traite ce sujet ?

Modifié (le) par Tfou57

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Tfou57 a dit :

Quelle partie du calculateur je dois utiliser pour le réglage des axes X, Y, Z .  :

celui qui s'affiche lorsque tu cliques sur le lien

il y a 3 minutes, Tfou57 a dit :

Cela se calibre par le Start Code ?

non directement dans le fichier configuration.h de marlin à la ligne :

#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 4000, 500 }

soit {x, y, z, extrudeur}

il y a 8 minutes, Tfou57 a dit :

N'est ce pas lié au pas par impulsion de l'extruder d'alimentation en filament ?

non

il y a 8 minutes, Tfou57 a dit :

Je devrais avoir une erreur similaire sous toutes les cotes en X , une autre erreur possible en Y et encore une autre en Z ?

non car les réglages sont indépendants l'un de l'autre

il y a 9 minutes, Tfou57 a dit :

Par axe , une erreur proportionnelle à la cote (petit erreur pour les petite cote et inversement?

non une fois correctement réglé, ça fonctionne pour toutes les cotes

il y a 10 minutes, Tfou57 a dit :

Connaissez-vous un post en français qui traite ce sujet ?

sur ce site il y a beaucoup de post qui traite de ce sujet exemple

et au lieu des faire des règle de trois tu utilises le calculateur

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, pascal_lb a dit :

non directement dans le fichier configuration.h de marlin à la ligne :

#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 4000, 500 }

soit {x, y, z, extrudeur} 

C'est dans le code source du firmware ?

Pour l'Anycubic I3 Méga V1 en firmware V1.01 , je n'ai même pas accès à la lecture de l'EEprom .

Anycubic ne communique que le firmware en hex

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, Tfou57 a dit :

C'est dans le code source du firmware ?

Pour l'Anycubic I3 Méga V1 en firmware V1.01 , je n'ai même pas accès à la lecture de l'EEprom .

Anycubic ne communique que le firmware en hex

oui c'est dans le firmware...

ok alors là je ne peux pas te dire, je n'ai pas d'Anycubic, il y a peut être une astuce mais je ne la connais pas...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 9 minutes, pascal_lb a dit :

oui c'est dans le firmware...

ok alors là je ne peux pas te dire, je n'ai pas d'Anycubic, il y a peut être une astuce mais je ne la connais pas...

C'est dans le firmware lui-même ou dans l'EEprom ?

Dans si je fais la modification officielle  "Dual Endstop" moteurs Z, le firmware  Anycubic permet de lire et de modifier l'EEprom d'après ce que j'ai compris !

Si c'est des valeurs à modifier dans l'EEprom , je pourrais alors calibrer les steeps /mm des 3 axes.

Je dois donc d'abord faire cette modification officielle  "Dual Endstop" pour peut-être effectuer la calibration des axes si les paramètres à modifier sont dans l'EEprom !

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, pascal_lb a dit :

La précision à 0.25 ça fait un peu beaucoup, refait un réglage de tes axes X, Y, Z afin de tomber au plus juste en te servant de ça

https://nathan7.eu/stuff/RepRapCalculator/RepRapCalculator.html#MotorStuffPrecise

J'ai fait aujourd'hui quelques mesures sur les axes en mesurant la position initiale des 3 axes et en les déplaçant ensuite de 130mm par la commande "Axis" présente dans le menu de l'Anycubic I3 Méga

Résultat :     Ecart total entre la commande et le déplacement réel   ( mesures à l'aide d'un pied de profondeur ancien et seulement au 0,1mm)

Ecart sur 130mm en X : 0,0mm                       Ecart sur 130mm en Y : 0,1mm                 Ecart sur 130mm en Z : 0,5mm   soit de l'ordre de 4µ /mn

Un calibrage en Z peut apporter un gain   ? ou Est-ce une précision normale pour une imprimante 3D ?

Mon problème de cotes fortes ne vient pas plutôt du calibrage de l'extrudeur ?

 

Il y a 4 heures, db42 a dit :

Tu peut aussi calibré ton extrudeur car si ton débit est un peu trop élevé ça doit augmenter les dimensions

@pascal_lb et @db42

Quelle est la méthode la plus pratique pour son calibrage. ?

En faisant les recherches sur le forum , j'aboutis à nouveau à:

Le menu de l'Anycubic I3 Méga ne permet pas de faire x pas d'extrudeur, que des avancées  et retour filament non précises en fonction de mon temps de réaction ( marche / arrêt)

Y-a-il une méthode adaptée à l'I3 Méga  quand le firmware  est d'origine ? V1.01 ?

Repetier-host ne me permet pas de lire l'EEprom

Y-a-il d'autres logiciels qui me permettrait encore d'essayer de lire l'EEprom pour confirmer le blocage en lecture de mon firmware ?

Modifié (le) par Tfou57

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Tfou57 a dit :

Y-a-il une méthode adaptée à l'I3 Méga  quand le firmware  est d'origine ? V1.01 ?

Repetier-host ne me permet pas de lire l'EEprom

Y-a-il d'autres logiciels qui me permettrait encore d'essayer de lire l'EEprom pour confirmer le blocage en lecture de mon firmware ?

Nope si l'eeprom n'est pas activée, il n'y a pas de solutions ... (Hélas)

Après je viens de penser un truc si dans ton script de démarrage tu passe la commande M92 ... la valeur sera perdue au prochain redémarrage mais peut être (et même surement ) que la machine utilisera ces valeur jusqu'au prochain redémarrage ...

C'est une solution "dégradée" et pas très pratique mais cela peut faire le job !

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Murdock a dit :

Nope si l'eeprom n'est pas activée, il n'y a pas de solutions ... (Hélas)

Après je viens de penser un truc si dans ton script de démarrage tu passe la commande M92 ... la valeur sera perdue au prochain redémarrage mais peut être (et même surement ) que la machine utilisera ces valeur jusqu'au prochain redémarrage ...

C'est une solution "dégradée" et pas très pratique mais cela peut faire le job !

Avec mon firmware V1.01 , je pourrais sans risque injecter le firmware dual endstop ?   

Pas de risque de ne plus avoir le V1.01 et d'un chargement incorrect du firmware dual endstop ?   Risque d'avoir une imprimante bloquée sans marche arrière possible ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Flasher un micro-contrôleur n'est jamais un acte anodin. Mais j'ai flashé surement largement plus de 500 fois ce genre de composant et je n'ai jamais eu de soucis ...  (Il faut juste éviter de débrancher la prise pendant le flash. lol :P Mais franchement le risque est négligeable ...

Tu pourras toujours revenir en arrière, si tu possèdes le fichier hex de la 1.01. Sinon il faudrait faire un dump (Sauvegarde) du micro-contrôleur. 

Profites-en pour faire la modif dual endstop.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 19 minutes, Murdock a dit :

Sinon il faudrait faire un dump (Sauvegarde) du micro-contrôleur. 

Profites-en pour faire la modif dual endstop.

Je fais comment un Dump par précaution ?

C'est justement en imprimant une de mes versions de support endstops que j'ai vu la différence de cotation entre la demande et la cote imprimée un peu forte

Pour l'instant , je suis sur la bonne voie, le principe de création avec Fusion360 est acquis , la modification un peu plus hésitante !...

Je dois faire des corrections , bug grossier de plusieurs mm sur la première version , je corrige ce bug grossier  et le manque de jeu entre l'endstop et le support à certains endroits  et j'imprime à nouveau en fin d'après midi

Il faut que je trouve encore quelque visserie M3 long 40 qui le manque + ressort ( Casto: Beaucoup de chose , cher  et jamais ce que l'on recherche exactement :pas visserie M3 en long supérieur à 16 et surtout pas en CHC, ... même pas de la tige filetée M3 !...)

Il faut que je fouille dans mon bordel à vis, >:( et les M3 cela se glisse tout au fond du vrac de visserie

Cela va se terminer encore chez AliEpress ( j'aime bien cette boîte ! c'est hyper pratique !

Modifié (le) par Tfou57

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 43 minutes, Tfou57 a dit :

Je fais comment un Dump ?

Pas toujours très simple ...

Je t'ai fais un petit zip avec un petit fichier bat pour te simplifier la procédure.

- Décompresses le.

- Ouvres une invite de commandes de commandes MSDOS. 

- Dans cette invite de commandes va dans le dossier décompressé.

- Tapes "ReadTrigo.bat 3" en remplaçant le  "3" par le numéro du port com de ton imprimante. Valides par entrée.

- Laisses le pc travailler.

- A la fin dans ce dossier tu récupères 2 fichiers pour les garder précieusement. "flsh.hex" (c'est le firmware de ta machine), "eepr.hex"(c'est la sauvegarde de l'eeprom de ta machine).

ReadTrigo.zip

Modifié (le) par Murdock
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Murdock a dit :

Pas toujours très simple ...

Je t'ai fais un petit zip avec un petit fichier bat pour te simplifier la procédure.

- Décompresses le.

- Ouvres une invite de commandes de commandes MSDOS. 

- Dans cette invite de commandes va dans le dossier décompressé.

- Tapes "ReadTrigo.bat 3" en remplaçant le  "3" par le numéro du port com de ton imprimante. Valides par entrée.

- Laisses le pc travailler.

- A la fin dans ce dossier tu récupères 2 fichiers pour les garder précieusement. "flsh.hex" (c'est le firmware de ta machine), "eepr.hex"(c'est la sauvegarde de l'eeprom de ta machine).

ReadTrigo.zip

:D La puissance "Murdock" en Action

Malheureusement , je suis très très loin d'avoir se niveau , excuse pitit problème !

En MSDOS sous Windows  avec le programme sur une clé cela ne fonctionne pas

il faut se mettre en mode sans échec ? , le COM 8  fonctionnera ?

Je suis en Win8.1

J'ai voulu mettre ton répertoire sur le bureau  , mais en DOS , je ne sais pas comment me mettre sur le bureau

C:  <=   :emoji-E412:  => au bureau ? ....

Peux-tu me mettre la commande que je dois la lancer pour le COM8  ( espace ou pas espace entre BAT et 8 ? )

Tmp à détruire -Invite de commandes.png

Par contre en double cliquant dans l'explorateur Windows sur ReadTrigo.bat  --> Fenêtre MSDOS je déroule et puis se ferme ( pas de demande du port COM concerné)

Détection du port COM8 automatique ?

Je vais à la recherche de fichier résultat éventuel ... : pas de fichier  flsh.hex et eepr.hex

Modifié (le) par Tfou57
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×