Aller au contenu

Filament ABS

benoit026

32 bits probleme mks sbase

Messages recommandés

bonjour

sur une anet a8, je viens d'aquérir une mks sbase 1.3 avec écran tft 3.2 afin de remplacer la carte anet v1.

Sur la carte via la sd ,j'ai installer le firmware et le fichier config ,mes voyant clignote bien

sur l écran a ete mis a jour ,mais je n'ai aucune reaction par rapport a l'imprimante quand je fait une action via l'ecran.

merci de votre aide 

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 02/10/2017 at 06:50, benoit026 a dit :

Regler de mm sur le tft rien ne se passe

Bonjour Benoit026,

Je suis dans le cas que toi, j'ai reçu ma carte SBase et mon écran MKS TFT32, j'ai paramétré mes fichiers etc, les baud sont identique et rien ne se passe également.

Comment as-tu pu corriger le problème ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu peux poster tes 2 fichiers config stp ? je vais regarder ;)

Modifié (le) par nico757

Partager ce message


Lien à poster
Partager sur d’autres sites

Modération :  @Yannick63 j'ai déplacé le post pour qu'il soit plus visible

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci @pascal_lb pour le déplacement.

 @nico757 voici les fichiers de configuration que j'utilise actuellement :

Carte MKS SBase : config.txt

Ecran MKS TFT32 : mks_config.txt

Si on peut m'éclaircir les idées, j'ai peut être omis un truc dedans que je ne vois pas.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Yannick63 je viens de penser à un truc, quand tu mets les fichiers du firmware pour l'écran dans ta carte SD tu as ça

Capture8.JPG.8cd4098f62b276a714af4dcb0d237db4.JPG

une fois que tu allumes ton écran le fichier config et le firmware ont l'extension qui change en .cur

mais si tu fais ensuite une modification dans le fichier config.cur lorsque tu redémarres ton écran je ne crois pas qu'elle soit pris en compte... il faut le remettre en .txt pour qu'il soit rechargé et il repasse en .cur

Peut être as tu fait seulement les modifs sur le fichiers .cur (supposition...)

Sur la SD de la SBASE le fichier config lui reste toujours en .txt

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

Et bien en fait, vue que je ne savais pas comment ce passé la prise en compte des modifications ce que je fais depuis le début sur l'écran c'est que à chaque modification pour l'écran je recharger tout les fichiers sur la SD et pour la carte j'ai vue que lui resté en .txt donc modification directe sur la machine avec un reset ensuite pour la prise en compte.

Donc au final j'ai bien toujours été en .txt  la supposition du .cur ne tient pas la route ^^

J'ai envie de faire un test en repartant du début, fichier d'origine et pas en mode delta, juste pour voir si mon problème d'écran est encore présent ou pas. J'espère ne pas avoir un problème de matos !!

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis toujours au même point, je n'arrive pas à démarrer la machine !

Question lol : sur la carte sd de la carte on met bien le fichier config.txt et le firmware.bin  j'ai lu sur ailleur (lien) que une fois que la carte est à jour avec son firmware, ce fichier devient firmware.cur et non .bin  hors moi mon fichier reste en .bin  est ce que ça pourrait venir de là ? que faire ?

Modifié (le) par Yannick63

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 13 minutes, Yannick63 a dit :

sur la carte sd de la carte on met bien le fichier config.txt et le firmware.bin  j'ai lu sur ailleur (lien) que une fois que la carte est à jour avec son firmware, ce fichier devient firmware.cur et non .bin  hors moi mon fichier reste en .bin

on parle bien de la micro sd de la carte SBASE pas du TFT

effectivement une fois que la carte a fait sa mise à jour le fichier firmware.bin est transformé en FIMWARE.CUR

il y a 16 minutes, Yannick63 a dit :

hors moi mon fichier reste en .bin  est ce que ça pourrait venir de là ? que faire ?

oui là c'est pas normal, je suppose que tu as essayé plusieurs micro sd ...

ou alors ton fichier est en lecture seule...

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je parle bien de la carte et non de l'écran. Après plusieurs changements c'est bonnnnn, ça fonctionnement, juste un problème de carte mémoire pfff !

Place à la mise au point maintenant :)

Merci @pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

Très surprenant ton fichier config.txt (sbase). J'ai l'impression qu'il manque des options, comme le baudrate par exemple que je n'ai pas réussi à trouver.
Voila le miens par exemple. Je suis en core_xy donc pas mal de choses changent mais j'ai plus d'option que toi il me semble.

config.txt

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 17 minutes, nico757 a dit :

J'ai l'impression qu'il manque des options, comme le baudrate par exemple que je n'ai pas réussi à trouver.

faut juste mettre des lunettes :D c'est presque à la fin du fichier

uart0.baud_rate                              115200           # Baud rate for the default hardware ( UART ) serial port

ça dépend des versions et je n'ai jamais contrôlé mais je ne sais pas si les versions du site MKS et du site smoothieware sont les mêmes...

perso je n'utile pas la dernière version, va falloir que je pense à la mettre à jour

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 11/02/2018 at 22:54, pascal_lb a dit :

faut juste mettre des lunettes :D c'est presque à la fin du fichier

uart0.baud_rate                              115200           # Baud rate for the default hardware ( UART ) serial port

ça dépend des versions et je n'ai jamais contrôlé mais je ne sais pas si les versions du site MKS et du site smoothieware sont les mêmes...

perso je n'utile pas la dernière version, va falloir que je pense à la mettre à jour

Ah ! Beh dans ce cas là je comprends mieux ! Merci pour tes lunettes @pascal_lb, je sais pas ce que j'ai foutu pour rater la fin du fichier x)

Normalement, les versions du site MKS et du site smoothieware devraient être identique car c'est smoothieware que l'on exécute dessus, mais à vérifier. (Éventuellement la concordance des ports?)

Du coup, tu as résolu ton problème @Yannick63 ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 24 minutes, nico757 a dit :

Normalement, les versions du site MKS et du site smoothieware devraient être identique car c'est smoothieware que l'on exécute dessus

oui mais quand tu regardes la taille et date de mise à jour des 2 fichiers :

MKS : 292 k : nov 2016

Smoothieware : 367 k : jan 2018

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, pascal_lb a dit :

oui mais quand tu regardes la taille et date de mise à jour des 2 fichiers :

MKS : 292 k : nov 2016

Smoothieware : 367 k : jan 2018

Les mises à jour apportent peut-être des nouvelles options, mais restent compatibles avec les fichiers config.txt des anciennes config non ? 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, nico757 a dit :

Les mises à jour apportent peut-être des nouvelles options, mais restent compatibles avec les fichiers config.txt des anciennes config non ?

oui j'ai chargé aujourd'hui le firmware du site smoothieware et j'ai vérifié les 2 fichiers config ligne par ligne, et eux sont identiques

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement , j'ai comparé aussi le fichier MKS et celui de Smoothie, les contenus sont tout les 2 identiques.

Pour la configuration delta, le fichier est à la base le même que celui d'origine mais modifié tout simplement pour l'adapté à la géométrie et cinématique de la machine. Certaines petites choses peuvent disparaître ceux ci dit donc voilà la différence. Ensuite delta MKS et delta Smoothie, la présentation n'est pas du tout la même mais le contenu à peut prés identique, Smoothie est plus complet quand même, alors que MKS a réduit presque au minimum !

J'ai un comportement plus doux et agréable avec Smoothie que avec MKS sans trop aller chercher loin dans les réglages, après je ne sais pas, on peut peut être avoir le même comportement avec les 2. Smoothie m'a l'air plus complet pour une delta.

Pour le firmware je n'ai pas du tout regardé.

Il y a 9 heures, nico757 a dit :

Du coup, tu as résolu ton problème @Yannick63 ?

Yesss :) problème résolu, mon écran dialogue bien avec la carte qui exécute les ordres maintenant. En fait je me suis rendu compte que mon fichier firmware.bin de la carte resté .bin alors qu'il devrait normalement passer en .cur et ça je ne m'en suis pas rendu compte de suite, je cherche dans les config comme un c** ! Pascal m'ayant confirmé ce problème j'ai changé ma carte mémoire, remit exactement la même chose dessus et op bingo ça démarre du premier coup !

Là je suis en trin de me creuser la tête pour les endstops ! J'ai des optiques donc S sur mon signal, le commun sur mon G et mon + sur mon V (5V en changeant le cavalier car je dois être en 5V), mais rien ne se passe. En vérifiant avec le M119 j'ai toujours le même état quelque soit la position de mon capteur !  Hier soir à la va vite j'ai pris un mécanique 2 bornes (hyper simple comme contact lol), connecté entre S et G et bien quand j'appui sur mon mécanique ça éteint mon écran !!! O.o

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×