Aller au contenu

Filament ABS

Chris67

i3 Mega en direct drive

Messages recommandés

Salut à tous

Après pas mal de version et test, me voila avec une Mega en direct drive. Vous allez me dire "mais pourquoi du direct drive, elle imprime bien", c'est vrai mais j'ai eu des soucis avec du filament bois et je me suis battu avec un filament PETG qu'il m' été impossible d'imprimé.

J'ai relancé une impression avec ce PETG et ..... magnifique !!!!, il c'est super bien imprimé, faudrait maintenant que je re test le filament bois.

J'ai mis un extruder Bondtech MG avec une E3DV6 originale, ainsi que le passage en MKS Gen 1.4 avec écran 3.2"

Encore des finitions à faire, comme les led sur la tête, l'emplacement est prévue.

Une dédicace à Murdock qui m'a bien aidé sur la partie firmware MKS ;), merci beaucoup.

 

IMG_20171019_175432.jpg.b8cc308f12900b5b6b0a26adc5a84286.jpgIMG_20171019_175450.jpg.d623978e5ae2e34299a5e61f5c18828f.jpgIMG_20171019_175517.jpg.6bbdb5cbfb303f0efba397ceb766e0e9.jpgIMG_20171019_175556.thumb.jpg.837695db1805f26bfff672f56544eeaf.jpgIMG_20171019_175614.thumb.jpg.24c5c7e3b8d0d9ad30cf97b866255228.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour cela tu as changé tout le hardware electronique...??? je suppose.

Qu'as tu installé avec quoi comme firmware?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, thsrp a dit :

Pour cela tu as changé tout le hardware electronique...??? je suppose.

Qu'as tu installé avec quoi comme firmware?

 

Oui, j'ai tout changé pour avoir un firmware Marlin d'origine, pour la matos, c'est indiqué dans le post :

Il y a 1 heure, Chris67 a dit :

J'ai mis un extruder Bondtech BMG avec une E3DV6 originale, ainsi que le passage en MKS Gen 1.4 avec écran 3.2"

Partager ce message


Lien à poster
Partager sur d’autres sites

mais ou est l'ecran on ne le voit pas ,c'est surtout ça l'intérêt le passage d'un firmware fermé a un firmware ouvert ...Apres que tu es choisi un direct drive, c'est je dirai un choix politique chacun y voit le pour et le contre .... (bien que ce soit une transformation importante) mais que tu es tout  changé à l'intérieur meme de la machine c'est a mon avis beaucoup plus intéressant et passionnant et c'est surtout de cela que j'aimerai que tu nous parles et nous donne des éclaircissements...

Donne nous aussi les details ..auto bed lineaire ? avec quel capteur? qualité de l'impression comparée avec la mega d'origine... tu es le premier a avoir "révolutionné"  la mega I3; meme sur le Facebook internationnal de l'anycubic personne ne l'a fait donc tu comprends qu'on reste un peu sur notre faim...

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est le même écran que  sur la modif que je vais vous proposer. la seul différence c'est que tu vires aussi la trigorilla.

Pour le firmware c'est un marlin 1.5 ou 1.4. Je sais plus lequel. Chris va pouvoir nous dire cela. (Pas le courage de le compiler. lol) :P

Pour l'heure pas d'autobed.

Modifié (le) par Murdock

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 34 minutes, Murdock a dit :

... la seul différence c'est que tu vires aussi la trigorilla.....

Pour laquelle ?

Partager ce message


Lien à poster
Partager sur d’autres sites

MKS GEN 1.4. En fait une trigorilla avec l'uart0 mais avec moins de sorties pilotées pour les ventilos.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 19/10/2017 at 23:14, thsrp a dit :

mais ou est l'ecran on ne le voit pas

Je ne l'ai pas pris en photo car il n'est pas encore intégré, il sera déporté au dessus de caisson

Le 19/10/2017 at 23:14, thsrp a dit :

Donne nous aussi les details ..auto bed lineaire ? avec quel capteur?

Pas de capteur, je ne l'utilise pas.

Il y a 10 heures, Murdock a dit :

Pour le firmware c'est un marlin 1.5 ou 1.4. Je sais plus lequel. Chris va pouvoir nous dire cela. (Pas le courage de le compiler. lol) :P

Marlin 1.4

Il y a 10 heures, Tfou57 a dit :

Pour laquelle ?

C'est indiqué dans le 1er post : MKS Gen 1.4

 

Il y a 7 heures, Murdock a dit :

MKS GEN 1.4. En fait une trigorilla avec l'uart0 mais avec moins de sorties pilotées pour les ventilos.

C'est ça  ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu n'as pas l'auto bed lineair , je ne comprends pas vraiment pourquoi avoir fait tout ce changement, s'il y a bien une chose révolutionnaire que permettent les derniers "marlin" c'est bien cette fonction ...Entre le double  endstop et l'ABL ta machine est vérifiée (et corrigé s'il le faut) automatiquement à chaque print durant le gcode start ... Plus aucun reglage ou maintenance de la machine pendant des semaines voir des mois... tant que tu ne changes pas la buse...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, thsrp a dit :

Si tu n'as pas l'auto bed lineair , je ne comprends pas vraiment pourquoi avoir fait tout ce changement, s'il y a bien une chose révolutionnaire que permettent les derniers "marlin" c'est bien cette fonction ...Entre le double  endstop et l'ABL ta machine est vérifiée (et corrigé s'il le faut) automatiquement à chaque print durant le gcode start ... Plus aucun reglage ou maintenance de la machine pendant des semaines voir des mois... tant que tu ne changes pas la buse...

Il récupère déjà le M600. comme sur ma modif d'ailleurs.

Cette modification est certes un peu extrême du fait que l'on peut avoir la même chose avec la Trigorilla, mais je la trouve néanmoins très intéressante  car cela prouve bien qu'en cas de pénurie de Trigorilla (si cette dernière venait à cramer par exemple) on peut avec certes pas mal de petits changement la remplacer.

Nice job @Chris67 !

Partager ce message


Lien à poster
Partager sur d’autres sites

@Murdock bon ne perd pas de temps et retourne a tes pinceaux...!! que tu puisse nous revenir en pleine forme avec un bel écran bien peaufiné...!!

Bon ceci dit j'ai pas encore reçu le mien...fin de semaine prochaine peut etre??

Partager ce message


Lien à poster
Partager sur d’autres sites

Le plus gros est fait. Je n'ai plus que les portes à peindre et le "relooking" d'un meuble !!!

ouf !!! j'en avais marre !!! 

Je bosse sur le tuto !

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, thsrp a dit :

Murdock bon ne perd pas de temps et retourne a tes pinceaux...!! que tu puisse nous revenir en pleine forme avec un bel écran bien peaufiné...!!

:D tu m'as tué :D:D

 

 

belle modif , mais je vois pas l’intérêt de cette modif pour du bois et du petg , elle s'en sort plutôt très très bien bien deja d'origine

cette modif serais plutôt très utile pour du flex par-contre, la ou elle pèche un peu plus 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est vrai qu'elle s'en sort très bien d'origine, mais avec le PETG que j'avais, ça ne passais pas du tout. Pourtant j'ai tout essayé !!!!

D'origine

P1050875.thumb.JPG.c64eaecc3a449d8558ea15d738c0866c.JPG

Modifié (avec les mêmes réglages, bon ok, la pièce c'est pas la même lol)

IMG_20171022_103138.thumb.jpg.861f486b7c74ee3d1b69deb4b5fe8de1.jpg

Comme suite à mon opération, j'ai du temps à la maison, ça m'a fait passé le temps. Et puis j'aime bien bidouillé 9_9

Prochain test, le flex

Partager ce message


Lien à poster
Partager sur d’autres sites

@Chris67

Pour moi le plus interressant est ton changement de carte et d'écran mais tu nous en dit quasiment rien...

Peux tu nous en faire une petite description, la carte MKS n'a qu'une sortie Z donc il a fallu bricoler dans le firmware je suppose en se servant de la deuxieme sortie extrudeur libre en la transformant en driver de Z ,c'est cela? une fois fait il a fallu lui attribuer un endstop et se servir de "pins" existants sur la carte... ?

D'autre part tu as retiré la "carte fille " qui vient se plugger sur la trigorilla mais cette carte ne sert pas uniquement a piloter l'écran de nos Mega, mais il y transite bon nombre de connections :les endstops, une ou des thermistances (je ne sais plus) et peut être autre chose... comment as tu fait? tu as coupé le multi connecteur qui arrive sur la carte fille et rallonger les cables pour les relier a leur connecteur d'origine..? Tu as du faire un schémas du connecteur avec le brochage et la correspondance des affectations... Peux tu nous le fournir ? Ca évitera de passer des heures pour recenser l'arrivée des endstops et autres le jour ou l'on changera ... Ce serait hyper sympa...

 

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Il a effectivement fallu refaire des câbles pour pouvoir ce brancher sur la MKS.

J'avais tout fait sur le tas en live, je vais voire pour faire un schéma et descriptif.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as refait les cables de bout en bout ? tu les a rallonger en les coupant au ras du connecteur multibroche??? Il y a quoi sur ce connecteur: les endstop ? plus une thermistance et c'est tout ou encore autre chose?? tu n'as rien noté????

Partager ce message


Lien à poster
Partager sur d’autres sites

Y'a quasi tout branché sur la carte fille de la Trigorilla.

 

J'ai juste conserver la carte ci-dessous, c’était plus simple que de refaire tous les câbles en entier.

Je n'ai coupé aucun câble, j'en ai refait.

imageproxy_php.jpg.dbc1a78a5af4900c8948484229a19327.jpg

J'ai juste conservé sur la broche de droite le T0, pour les endstops, j'ai refait des câbles et les ai branché directement sur la MKS (plus propre)

Ça donne ça juste avec la T0

IMG_20171022_131025.thumb.jpg.4236bade3ced06a85f11c73fa4044a74.jpg

 

Les branchements sur la MKS

59ec92241d38f_carteMKS.thumb.jpg.1d415786efc1e8fe15dc2428638d7a5b.jpg

Modifié (le) par Chris67

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci , pour la description, tu t'es servi du E1 pour le transformer en Z2 et tu lui as adjoint un endstop , beaucoup de travail dans le firmware pour arriver a ce résultat??

D'autre part , ma machine est entrai de tourner donc je ne peux l'ouvrir pourquoi sur le connecteur de droite il n'y a plus que le T0  qui avait il en-dessous??? a quoi correspondait les 4 emplacement vides sur ce connecteur???

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×