Aller au contenu

Filament ABS

medmed

Petit souci d'affichage avec le firmware Marlin.

Messages recommandés

celui de la A6, comme je l'ai déjà dis dans ce sujet.......

Quand à Marlin, vu que le 1.1.9 est le dernier de la série Marlin 1.x (ensuite on aura Marlin 2.0) je te conseillerais de na pas trop rêver.
Et je les voit mal implémenter une fonction qui n'est utile que sur UN écran du marché, surtout quand le problème vient de la mauvaise protection de l'écran lui-même, pas d'un bug de Marlin. C'est à Anet de réviser son écran.

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Locouarn a dit :

 le firmware d'origine ne pose aucun problème avec cet écran.

La vraie question que tout le monde esquive, c'est "pourquoi introduire un firmware (Marlin) qui crée des problèmes et ne pas apporter la solution en le corrigeant, tout simplement  ?"

Pourquoi certains disent que ça marche alors que c'est simplement aléatoire ? A mes derniers essais, il s'avère que l'écran ne se brouille que lorsqu'il est placé à son emplacement d'origine... Par contre coller le câble plat contre un moteur ou contre n'importe quelle nappe de câbles ne provoque pas le brouillage !

Ceci est totalement faux . Mon problème est apparu sur  le firmware Marlin mais est aussi  sur le firmware d'origine. 

Une chose a totalement réglé ce problème sur ma Anet . La pose de mosfet. Je ne saurai te dire pourquoi et comment. Mais une chose est sûr, depuis la poses des mosfets je n'ai  plus jamais  eu de problème de caractères bizarres a l’écran.

Modifié (le) par medmed

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, medmed a dit :

Ceci est totalement faux . Mon problème est apparu sur  le firmware Marlin mais est aussi  sur le firmware d'origine. 

Une chose a totalement réglé ce problème sur ma Anet . La pose de mosfet. Je ne saurai te dire pourquoi et comment. Mais une chose est sûr, depuis la poses des mosfets je n'ai  plus jamais  eu de problème de caractères bizarres a l’écran.

Effectivement, j'aurais du écrire "JE n'ai aucun problème de ce genre avec le firmware d'origine" 😉

J'ai fait exactement ce que je reproche aux autres : généraliser à partir de leur unique expérience personnelle ! Mea culpa...

Curieux que l'ajout d'un MOSFET change quelque chose... Mais il n'y a rien de logique avec ce souci. J'ai constaté le problème avec de simples translations, sans aucun chauffage (ni lit, ni buse). Est-ce que cela ne viendrait pas tout simplement de l'alimentation dont de nombreuses variantes existent ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Locouarn, là ou tu te trompes c'est que je ne généralise pas avec MON expérience personnelle, j'ai aidé plusieures personnes à régler ce problème, que ce soit sur ce forum ou sur facebook.
Et c'est un défaut reconnu et référencé.

Partager ce message


Lien à poster
Partager sur d’autres sites

Même si tu as aidé plusieurs personnes, cela reste TON opinion.

Un défaut reconnu et référencé, mais toujours pas résolu... Mais si tu as une solution efficace, j'ai hâte que tu me révèles ton secret ! 🤨

Partager ce message


Lien à poster
Partager sur d’autres sites

Il n'y aura aucune résolution possible tant qu'Anet n'aura pas corrigé la fabrication de l'écran, ce n'est pas aux développeurs de Marlin de compenser la mauvaise qualité du matériel.

Ne confond pas défaut matériel et bug logiciel.
Souviens toi bien que Marlin prend en charge l'écran de l'A8 grâce au développeur de Skynet, initialement les Anets n'étaient PAS supportées. Ce qui sous-entend que Marlin N'A PAS été développé pour l'anet A8.

 

Quand à une solution efficace, il faut protéger l'écran contre les perturbations électromagnétiques, puisque le fabriquant est incapable de le faire lui-même, et pour ça y'a toutes les infos sur le forum.

Ou sinon, tu fais comme moi, tu lui greffes l'écran d'une A6 et tu ne seras PLUS JAMAIS emmerdé.

Modifié (le) par Maeke
  • J'aime 1
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, Maeke a dit :

il faut protéger l'écran contre les perturbations électromagnétiques,  et pour ça y'a toutes les infos sur le forum.

Merci pour cette réponse. J'ai déjà blindé le câble, sans résultat. Je gagnerais du temps à ne pas réinventer la poudre 😄.

Peux tu m'indiquer les sujets qui donnent ces infos car je ne trouve pas...

Merci par avance.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tout dépend comment tu as "blindé" ton câble. Mais si tu veux savoir comment mettre en place une protection efficace, voit avec @Janpolanton.

Assures toi aussi de ne pas avoir de mauvaise soudures et d'avoir une bonne connection, ça peut aussi provoquer des corruptions de l'affichage.
Ce qui avait marché pour moi était une simple torsion en spirale du câble nappe (deux à trois boucles), mais chacun est impacté plus ou moins et ma machine était une de celles avec le moins de défauts d'usine (je n'en ai eu quasiment aucun, juste deux ou trois vis inutilisables).

Donc ce qui à marché pour moi ne marchera pas forcément pour toi, ceci dit, je le répète, le lcd type A6 n'est pas du tout sensible à ce défaut, il est pris en charge pas Marlin, et est beaucoup plus agréable à utiliser.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut tout le monde.

J'ai eu le même souci d'affichage à la suite d'une installation de firmware Marlin (bugfix 2.0.X ) sur SKR mini E3 1.2 .

J'ai résolu le problème en cliquant sur Restore Failsafe dans la configuration de la machine Ender 3

Cette manip efface les vieilles données car il se peut qu'il y ai un conflit au niveau de laffichage avec l'ancien firmware en mémoire.

Voilà j'éspère que ça a aidé.

Partager ce message


Lien à poster
Partager sur d’autres sites

et allez, déterrage d'un sujet fermé depuis deux ans.... Et en plus ton imprimante n'étant pas une Anet avec un écran Anet ta manip ne sert à rien. Les écrans Anet sont spéciaux et les astuces connues pour une creality ne servent à RIEN sur une Anet.

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...