Aller au contenu

Filament ABS

brunos31

Branchement Capteur + Retour expérience

Recommended Posts

Bonjour,

Je me suis lancé dans le montage d'une imprimante 3D, et bien que je me suis amusé avec la partie méca, je déchante un peu avec la partie Electrique. Moi qui soit concepteur méca de base, je pensais que la partie électrique serait le plus simple, je déchante un peu. Je bloque avec un capteur inductif et sa carte. Jusque là j'ai pas eu trop de problème de branchement si ce n'est que de brancher cette carte. Elle est censé évité de souder des résistances au capteur pour facilité la vie, mais pour moi c'est plus compliqué lol.

J'ai vu que le sujet avait été traité ici mais pas sur une ramps 1.4, je voulais savoir si quelqu'un avait déjà branché cette carte et comment ?

Autre chose, je ne sais pas si ça vient de moi ou d'un réglage à faire avec Repetier, mais quand j'allume l'imprimante 3D enfin le truc pour le moment ^^, si je n'ai pas mis les axes au points d'origine, je ne peux pas manuellement déplacer mes axes. Enfin, je le fais que dans un sens.

Donc ma question est de savoir, si il était possible que la machine trouve les points d'origine automatiquement, et ce quelque soit la position initiale ? enfin d'allumage ?

Merci beaucoup pour vos lumières,

Bruno

 

Capture.PNG

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, modéle imprimante, nom de la carte, référence du capteur...???

Sinon pour le homing et le déplacement de tes axes c'est une sécurité logique pour éviter d'envoyer le charriot plus loin que le point0, imagine tu allumes ton imprimantes avec l'axe X en position home et tu demandes à ton imprimante de faire -100 , va y avoir des couinements voir peut étre de la casse, donc c'est mieux de le laisser comme ça, aprés je pense qu'en fouillant un peu dans le Firmware l'option pour le faire doit se trouver quelquepart.

 

EDIT : Au temps pour moi ta carte est une ramps 1.4, par contre la réf de ta carte capteur?

Modifié (le) par Djam

Partager ce message


Lien à poster
Partager sur d’autres sites

y'a des tutos qui en traitent déja et c'est plutot clair les explications, je vois pas ou tu bloques?

la carte se branche comme ça et surtout faut configurer le pin.h de ta carte

capa2.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci, j'avais un doute sur cette installation.

Pour le fichier Pin.h il faut il faut remplacer le 18 en 12

#define Z_MIN_PIN          12 // replacement du port préconfiguré 18 en 12

Hors dans mon fichier j'ai juste ce script, c'est donc le -1 que je dois passer en 12 ?

En fait pas mal de sujet traite avec les anciennes version de marlin et peu avec la mise à jour en 1.1.7 :S Merci de ton aide Djam

 

#ifdef Z_STOP_PIN
  #if Z_HOME_DIR < 0
    #define Z_MIN_PIN Z_STOP_PIN
    #define Z_MAX_PIN -1
  #else
    #define Z_MIN_PIN -1
    #define Z_MAX_PIN Z_STOP_PIN
  #endif

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir et bonne fête de fin d'année tout le monde,

Je reviens vers car je bloque toujours, après avoir modifier le fichier, j'ai un problème de message: "static assertion failed: RIGHT_PROBE_BED_POSITION can't be reached by the Z probe."

D'après les recherches ils disent qu'il faut modifier les valeurs de l'offset du PROBE, hors malgré tous les essai j'ai toujours le même problème...

Voici les valeurs utilisé actuellement:

#define X_PROBE_OFFSET_FROM_EXTRUDER -37.5  // X offset: -left  +right  [of the nozzle]
#define Y_PROBE_OFFSET_FROM_EXTRUDER 6  // Y offset: -front +behind [the nozzle]
#define Z_PROBE_OFFSET_FROM_EXTRUDER -1.5   // Z offset: -below +above  [the nozzle]

Je me posais une autre question, car les valeurs prises sont par rapport à l'extrudeur 1 qui est celui de gauche. Donc je me disais si je devais configurer le décalage par rapport à l'extrudeur 1 ou au milieu des 2 extrudeurs ?

En vous remerciant d'avance pour votre aide.

 

Configuration.h

Ext.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

salut

moi le mien il n'accepte pas les virgules ni les chiffre qui ce termine par autre chose que 5 ou 0

pourquoi je sais pas j'ai jamais chercher lol

#define X_PROBE_OFFSET_FROM_EXTRUDER -37.5 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut en méme temps :

Citation

X and Y offsets must be integers.

Pour le réglages des extrudeur je dirais qu'il faut que tu paramétres par rapport à l'extrudeur 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×