Aller au contenu

Filament ABS

Albatar

axe z qui monte pour autolevelling

Recommended Posts

Bonjour, suite à l'installation de la tête de Z122, j'en ai profité pour remplacer mon capteur inductif fourni avec ma discoeasy par un autre (LJ12A3-4-A/BY)

Après le montage de cette nouvelle tête lorsque j'envoie un autolevelling avec G29 avec pronterface ou que j'effectue un réglage de l'offset avec l'écran, l'axe Z monte mais ne descend pas.

Le capteur s'allume pourtant lorsque je lui présente un objet métallique.

De plus j'arrive à faire descendre l'axe Z avec l'écran, il ne s'agit donc pas d'un problème d'inversion des moteurs

Avez-vous une idée du problème ?

Modifié (le) par Albatar
correction de la commande envoyée
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut !

G28, c'est pas plutôt pour centrer tous les axes, enfin les remettre à leur position initiale ?

Je te dirais d'essayer avec G29 ça devrait régler ton problème ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites

oui pardon g29 effectivement

Mais je pense voir quel est mon soucis je viens de me rendre que le capteur que j'ai recu est un PNP et non pas un NPN comme j'avais commandé

Il y a t'il moyen de faire fonctionner ce capteur ?

Modifié (le) par Albatar

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, ToBtouz a dit :

Je ne saurais te dire, désolé :/

Merci quand même de t’être intéressé au sujet

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Albatar a dit :

oui pardon g29 effectivement

Mais je pense voir quel est mon soucis je viens de me rendre que le capteur que j'ai recu est un PNP et non pas un NPN comme j'avais commandé

Il y a t'il moyen de faire fonctionner ce capteur ?

Apparemment il y aurais moyen ,mais ça a l'aire chiant .

Il faut ajouter un transistor .

pnp.jpg.13e4017bf3f09419e008005b8c74431f.jpg

On en parle ici : https://www.thingiverse.com/thing:1029784/#files

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

ouh là cela devient compliqué et dépasse mes compétences et quitte à racheter quelquechose je vais me racheter un capteur

Merci beaucoup de ta réponse

Partager ce message


Lien à poster
Partager sur d’autres sites

@Albatar

Merci d'utiliser "ma" tête ;-)

Il serait peut être plus simple de modifier le fichier Configuration.h du Marlin (vers les lignes 500) afin d'inverser la logique de ton fin de course?

Je pense à ceci en particulier:

#define Z_MIN_ENDSTOP_INVERTING True ; (au lieu de False?)

Modifié (le) par Z122

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Z122 a dit :

@Albatar

Merci d'utiliser "ma" tête ;-)

Il serait peut être plus simple de modifier le fichier Configuration.h du Marlin (vers les lignes 500) afin d'inverser la logique de ton fin de course?

Je pense à ceci en particulier:

#define Z_MIN_ENDSTOP_INVERTING True ; (au lieu de False?)

Cela ne marchera pas , c'est plus complexe qu'une histoire de NO NF .  Cette  option ne sert juste qu'a ça .  Entre le NPN et le PNP  la logique est inversé niveau polarité  .

Même #define ENDSTOPPULLUP_ZMIN ne changerais rien .

Le transistor doit être la seul solution . Sauf si quelqu'un ici nous fait une révélation sur une autre solution :D

Partager ce message


Lien à poster
Partager sur d’autres sites

@Z122

Effectivement avant de poster j'avais tenté d'inverser le Z_MIN_ENDSTOP_INVERTING mais cela ne fonctionnait pas.

Je suis repassé sur mon ancien capteur et je n'ai plus de problème

Par contre j'ai une question pour toi @Z122 concernant la ventilation.

Le but n'est-il pas de souffler vers la pièce en cours d'impression ?

Là à priori suivant le sens de montage des ventilateurs illustrés sur l'image ci-dessous cela va souffler dans l'autre sens

4424b7599ea4f478454e3c355bffc5cd_preview

Modifié (le) par Albatar

Partager ce message


Lien à poster
Partager sur d’autres sites

@Albatar effectivement les étiquettes ne sont pas censés être visibles, si les ventilos sont montés dans le bon sens. :-)

Je m'en suis rendu compte lors du montage, mais ne l'ai pas corrigé sur la CAO... pour voir si quelqu'un allait me faire la remarque:

Bravo, tu es le 1er à le faire.

Modifié (le) par Z122

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai testé le benchy LEGO (https://www.thingiverse.com/thing:1906745) voici les résultats :

Impression en PLA 0.2

remplissage à 17%

sans support et sans retouches

Impression sur radeau de 2mm pour ce benchy car il n'y a pas de sol plat comme pour le vrai benchy

Vitesse impression : 60 mm/s

Vitesse déplacement : 120 mm/s

IMG_20180103_192223.thumb.jpg.3abdc6d75f407f49f227db256bc282b2.jpg

IMG_20180103_192239.thumb.jpg.6e480b6e88c71d265ff93c5ab505524f.jpgIMG_20180103_192258.thumb.jpg.a613318b389ea56aa449de9e849c07be.jpg

IMG_20180103_192308.thumb.jpg.7e0fb1b1b2b7d907ff6db1f05880f1f3.jpg

IMG_20180103_192319.thumb.jpg.16f48eebb3b9bbac7710c1b772d08ace.jpg

 

Je trouve le résultat plutôt pas mal

Sauf que :

IMG_20180103_192332.thumb.jpg.15c8d49f6ed135fc8a99737a7463616d.jpg

La pièce s'est décroché du plateau vers la fin d'impression

J'ai toujours eut ce problème avec la easy dès que je dépasse une certaine hauteur les petites pièces se décolle du plateau à cause d'un frottement

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@Albatar 

Merci pour ta sollicitation, mais je ne suis pas devin et ne connais pas ta configuration:

Tu utilises un raft... mais est--ce le raft qui se décroche du plateau, ou est-ce le benchy qui se soulève du raft?

Quelle type d’adhésion utilises-tu (sous le raft) :

- blue tape (--> il faut le changer régulièrement),

- buildtack (--> il faut le nettoyer),

- plaque de verre (--> idem + spray 3D Lac),  ......

- plateau chauffant, ...?

 

Si la pièce se décroche du plateau, je vois deux pistes :

- soit un problème d'adhérence sur le plateau (ou sur le raft) n'est pas suffisante pour contenir le warpage/retractation du bas de l'impression,

- ET/OU il y a un blocage d'un axe en Z qui ne monte pas autant qu'il devrait monter...

 

En clair, je n'ai pas de solution miracle pour répondre, il faut que tu fasses probablement des essais :

(1) de mouvement en Z pour vérifier que tout monte sans à coup;

(2) fais des essais sans raft , mais avec et sans jupe?

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 57 minutes, Z122 a dit :

@Albatar 

Merci pour ta sollicitation, mais je ne suis pas devin et ne connais pas ta configuration:

Tu utilises un raft... mais est--ce le raft qui se décroche du plateau, ou est-ce le benchy qui se soulève du raft?

Quelle type d’adhésion utilises-tu (sous le raft) :

- blue tape (--> il faut le changer régulièrement),

- buildtack (--> il faut le nettoyer),

- plaque de verre (--> idem + spray 3D Lac),  ......

- plateau chauffant, ...?

 

Si la pièce se décroche du plateau, je vois deux pistes :

- soit un problème d'adhérence sur le plateau (ou sur le raft) n'est pas suffisante pour contenir le warpage/retractation du bas de l'impression,

- ET/OU il y a un blocage d'un axe en Z qui ne monte pas autant qu'il devrait monter...

 

En clair, je n'ai pas de solution miracle pour répondre, il faut que tu fasses probablement des essais :

(1) de mouvement en Z pour vérifier que tout monte sans à coup;

(2) fais des essais sans raft , mais avec et sans jupe?

Ok merci

Depuis 1 an que j'utilise la disco dès lors que j'imprime des pièces un peu haute sur plateau chauffant en PLA et avec bluetape à une certaine hauteur (jamais la même mais au dela de 3 ou 4 cm) on entend la buse frotter contre l'impression des couches inférieurs et cela finit logiquement par décoller la pièce.

As-tu des suggestions pour des essais du mouvement en Z ? 

Partager ce message


Lien à poster
Partager sur d’autres sites
Ok merci
Depuis 1 an que j'utilise la disco dès lors que j'imprime des pièces un peu haute sur plateau chauffant en PLA et avec bluetape à une certaine hauteur (jamais la même mais au dela de 3 ou 4 cm) on entend la buse frotter contre l'impression des couches inférieurs et cela finit logiquement par décoller la pièce.
As-tu des suggestions pour des essais du mouvement en Z ? 

Je pensais à des mouvements manuellement actionnés sur l'écran ou via un terminal (Pronterface, Octoprint, ou autre,...) afin de parcourir la totalité de la course en Z... Pour voir si et quand ça bloque... Les des principaux soucis sur les discos c'est que les tiges X ont entre 1,5 et 3 mm de jeu horizontalement alors qu'elles devraient pouvoir encaisser et reprendre l'effort de la tension de courroie... Sur ce que tu décris je soupçonne que ce phénomène tord/déforme les tiges Z... Ce qui pourrait expliquer des frictions plus fortes sur le mouvement Z au bout de quelques centimètres de hauteur (...)

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai eu un problème en Z il y a quelques temps. Un des moteurs Z coinçait de temps en temps.

Je vous raconte, ça peut servir...

Je me suis aperçu que des petites longueur de bouts de filament (ceux, tout fins, qui se produisent à la fin de l'impression, quand la tête va se parquer) s'étaient enroulés autour de l"axe du moteur, entre le moteur et le coupleur, et freinaient le moteur. Il n'y a pas beaucoup de place, mais après 1 an d'impressions, il y en avait suffisamment pour coincer.

Facile d'y jeter un œil de temps en temps...

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok merci à tous les 2 de vos réponses

@Z122 je vais attendre ta nouvelle pièce de centrage haut

Je n'ai aucun blocage mais je trouve qu'il y a beaucoup de jeu dans l'axe peut être est-ce lié à cela.

Voici une petite vidéo démontrant le problème

Partager ce message


Lien à poster
Partager sur d’autres sites

Les mienne bouge exactement pareille, et j'ai pas de problèmes .

Par contre , elle  semble plus courte ?

Modifié (le) par jagof

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×