Aller au contenu

Filament ABS

Messages recommandés

Bonjour,

Est ce que vous mettez votre marlin à jour?

Suite à ce problème:

Un gars me disait ceci sur un autre forum:

"Je crois  avoir deja vu ca..

 
 Je me rappelle qu'il faut changer l offset de Z .. a - quelque mm .
Et que ce pb a ete corrigé dans la dernière version de marlin rc4 ou 5 de mémoire"
 
Qu'en pensez vous?
 
Et est ce que le marlin du forum geeetech 
 
 
est maintenu à jour, et comment vérifier la version?
 
diiity

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 41 minutes, diiity a dit :
Et est ce que le marlin du forum geeetech est maintenu à jour

Malheureusement non il faut que tu prennes la dernière version sur github et que reprennes tes réglages dans l'ancienne version de ton configuration.h

je l'avais fait avec la RC8, c'est fastidieux, mais j'avais réussi à la faire fonctionner  

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 52 minutes, diiity a dit :

et tu l'utilises toujours?

non mes 2 imprimantes tournent avec des cartes MKS SBASE et le firmware Smoothieware et j'ai jeté tous les marlins que j'avais modifié

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme l'indique Pascal_lb, l'adaptation d'une version récente de Marlin à nos machine n'est pas bien compliqué avec les bons outils.

Je suis donc passé de la version de base à la 1.1.8. Certe il y a quelques améliorations visibles et pratique pour l'utilisateur comme la réorganisation des menus, le sens de la molette qui change que je trouve plus logique mais c'est pour moi surtout au niveau sécurité que la différence est importante.

En attendant de recevoir un nouveau hotend, je fais avec un mauvais contact au niveau de la chauffe de l'extrudeur. Sur le marlin de base il envoi la puree quoi qu'il arrive par contre avec le 1.1.8, il détecte le problème et coupe la machine par sécurité. Je trouve ca bien plus rassurant.

 

Pour ceux que ca intéresse je joins Marlin 1.1.8 pour une Geeetech Prusa i3 Pro B, avec les réglages de base.

Geee-I3proB_Marlin-1.1.8-20180110.zip

Modifié (le) par hidius

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello @hidius

Comme tu me l'as suggéré, je crois que je vais partir sur des bases saines en adoptant le Marlin dont tu parles ci-dessus.

Mais comme je débute juste ce genre de manipe, quel(s) fichier(s) dois-je piquer dans la config fournie par Geetech pour ma machine pour ne rien perdre de ses spécificités (double extrudeur) ?
Merci de ta patience, tu n'as que 7 messages (à l'heure qu'il est) mais tu sembles être diablement pointu...

 

Edit : esque le "configuration.h" suffit ? (on peut rêver.....)

Modifié (le) par Jean-Claude Garnier

Partager ce message


Lien à poster
Partager sur d’autres sites

Je bosse dans l'informatique et Il me semble tellement évident de mettre a jour le firmware de n'importe quel équipement pour corriger les éventuels "bugs", que c'est la première chose que j'ai fais, avant même de monter la carte sur le chassi.

Oui, tous se trouve dans le configuration.h pour avoir une version identique a celle proposé sur le forum geeetech. Après libre a toi de bidouiller plus profondément.

Tu as quoi comme carte, une GT2560 A+ ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pas pu attendre ta réponse, j'ai pris le firmware de Gitèque, suivi le tutal et "téléversé" en serrant les miches.

Et tu le croirais, ça a marché didon !

Maintenant que tu as répondu, je vais prendre le tien, copier dedans le "configuration.h" spécial à ma pétoire et recommencer.

Elle est pas belle la vie ?

Ma carte c'est bien une GT2560 A+, c'est ça qui est écrit dessus.

Merci encore, tu m'as été d'un grand soutien.

Partager ce message


Lien à poster
Partager sur d’autres sites

Flûte et crotte de bique... C'était trop bô !

Alors j'ai fait comme je disais dans le post du dessus, copié le configuration.h de Gitèque dans TON archive et lancé la compil' :

Citation

exit status 1
#error "You are using an old Configuration.h file, update it before building Marlin."

Caisse qui faut que je fais, Docteur ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Non mais sans déconner, t'es un génie ou bien ?

Y'a même le knob qui tourne dans le bon sens... et ça cause en Gaulois

Merci également à ce foirium pour son exceptionnelle réactivité

Modifié (le) par Jean-Claude Garnier

Partager ce message


Lien à poster
Partager sur d’autres sites

:banana: Je suis parti de ma version et j'ai ajouté un second extrudeur, ce qui je crois est la seule différence entre les deux. Content pour toi ;)

 

Il y a un point ou j'ai un doute, c'est la régulation du hotend.

si tu as un soucis a ce niveau passes tes paramètres vers ceux la : (ou fait un autotune PID)

  #define  DEFAULT_Kp 12.33
  #define  DEFAULT_Ki 0.51
  #define  DEFAULT_Kd 74.50

:10_wink:

Ne pouvant pas te valider le bon fonctionnement complet du firmware, par sécurité, restes a proximité lors de tes premiers tests ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Ça tourne

Le hotend, pour l'instant, a l'air de faire son boulot. Je ne me sers pas encore de la seconde buse pour une raison simple : j'ai pas encore regardé comment on fait pour imprimer en deux couleurs et je sais pas faire !

A la louche et au doigt mouillé, je dirais que par rapport à avant, il doit y avoir un p'tit truc à régler au niveau des accélérations/décélérations de l'axe X : ça tabasse dur à chaque inversion de mouvement.

Sûrement dû au poids de ces deux extrudeurs embarqués, 500 grammes, quand-même.

Vivement que je reçoive ça qu'il faut pour les mettre à l'extérieur....

Maintenant je vais cesser de polluer ce topic, et si j'ai des trucs à dire je les dirai sur mon post, "La Gitèque à JCG"

Partager ce message


Lien à poster
Partager sur d’autres sites

@hidius Bon, encore merci pour les conseils pour la mise à jour du Marlin mais j'ai encore un problème. Dans le nouveau menu il n'est possible de bouger uniquement les axes X et Y mais pas le Z, pourquoi vu que les x et y on sait les bouger facilement à la main sans dérégler alors que le Z serait nécessaire? On ne peut plus mettre en mémoire directement de l'imprimante et le bouton augmente vers la gauche et diminue vers la droite comme avant. Donc j'ai encore foiré...

@Jean-Claude Garnier J'ai du tout de suite diviser par 2 le jerk donc j'ai mis 10 xyjerk pour l' ancien marlin. Par contre Cura 3.1 s'en fout complètement, tu dois modifier manuellement dans Cura ou utiliser Repetier. La V2.0.5 même avec Curaengine utilise les paramètres de la machine

Bon, j'ai vérifié et je n'ai pas mis le Marlin modifié d'Hidius donc je regarderai après l'impression de la grenouille tranchée avec Cura 3.1 qui est extrèmement violent et qui ne tient compte d'aucun paramètre prédéfini. Si je n'avais pas le bouton Fr à tourner pour diminuer la vitesse à 25%, je pense bien que j'aurais foutu en l'air quelque chose. Par contre avec Cura 3.1 plus de bave donc inutile de mettre un bouclier au changement d'extrudeur.

Modifié (le) par zyban

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @hidius j'ai encore besoin de toi. Je suis dans ton configuration.h mais je n'ai qu'un switch normal

Il me suffit de désactiver ceci ou y a-t-il autre chose à faire ou je peux laisser ça comme ça?

#if ENABLED(PARKING_EXTRUDER)
  #define PARKING_EXTRUDER_SOLENOIDS_INVERT           // If enabled, the solenoid is NOT magnetized with applied voltage
  #define PARKING_EXTRUDER_SOLENOIDS_PINS_ACTIVE LOW  // LOW or HIGH pin signal energizes the coil
  #define PARKING_EXTRUDER_SOLENOIDS_DELAY 250        // Delay (ms) for magnetic field. No delay if 0 or not defined.
  #define PARKING_EXTRUDER_PARKING_X { -78, 184 }     // X positions for parking the extruders
  #define PARKING_EXTRUDER_GRAB_DISTANCE 1            // mm to move beyond the parking point to grab the extruder
  #define PARKING_EXTRUDER_SECURITY_RAISE 5           // Z-raise before parking
  #define HOTEND_OFFSET_Z { 0.0, 1.3 }                // Z-offsets of the two hotends. The first must be 0.
#endif

Modifié (le) par zyban

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @zyban,

 

Lorsque tu téléverse marlin, et une fois 'imprimante rebootée, il faut aller dans un des menu et sélectionner "load defaults/restaurer defauts" dans le menu "contrôler" pour que  les nouveaux paramètres soient pris en compte.

Ensuite, je fais un "save" (ligne au dessus)

 

Chez moi, l'axe Z apparaît uniquement dans les menus 0,1 mm et 1 mm pas dans le 10mm.

 

:)

Partager ce message


Lien à poster
Partager sur d’autres sites

@zyban,

J'ai suivi le lien de ce message pour DL le marlin spécifique à mon imprimante.

 

:)

Partager ce message


Lien à poster
Partager sur d’autres sites

@Yo'

Oui mais ici c'est une mise à jour du Marlin 1.1.8 compilé avec la dernière version d'Arduino 1.8.5 si je me souviens bien avec une protection plus sérieuse de la température. Quand ChrisV. écrivait ces lignes, ce Marlin  ci n'existait pas encore et cette version d'arduino non plus il me semble

Modifié (le) par zyban
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×