Aller au contenu

Filament ABS

lemmings

Incidence du niveau (à bulle) par rapport au bed

Messages recommandés

@lemmingsNormalement non, puisque tu as le calibrage automatique du plateau qui compense à la volée pour tous les points du plateau la différence de Z avec le point central (le "grid compensation" dans Smoothieware).

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

A ce sujet, je constate très clairement (malgré la mise à niveau du plateau) que la première couche est nettement plus écrasée d'un coté que des deux autres... 

Je viens de refaire la calibration et je l'ai fait en chauffant le plateau pour être dans les mêmes conditions que lors de l'impression. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as moyen de visualiser la grille et de vérifier qu'elle est bien prise en compte en te connectant avec Repetier Host dessus et en tapant les commandes suivantes :

M375.1

puis :

M503

 

Tu as une photo des différences observées sur la première couche ? A quelle hauteur l'as-tu définie ?

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

le niveau à bulle n'est d'aucune utilité

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 23 heures, lemmings a dit :

A ce sujet, je constate très clairement (malgré la mise à niveau du plateau) que la première couche est nettement plus écrasée d'un coté que des deux autres... 

Je viens de refaire la calibration et je l'ai fait en chauffant le plateau pour être dans les mêmes conditions que lors de l'impression. 

Tiens c'est marrant j'avais le même problème je pensais que cela venais de la planéité de mon miroir, du coup tu nous diras si tu règle ce petit souci

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 07/01/2018 at 19:27, lemmings a dit :

Est-il est important d'être de mettre à niveau le bed ? 

dans une certaine mesure oui. Quand la machine n'est pas à l'horizontale, les guidages, glissières etc travaillent mal et l'usure ne sera pas uniformément répartie sur le plan mécanique.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 21 minutes, nono30 a dit :

dans une certaine mesure oui. Quand la machine n'est pas à l'horizontale, les guidages, glissières etc travaillent mal et l'usure ne sera pas uniformément répartie sur le plan mécanique.

L'argument est intéressant, je n'avais pas prêté attention à cet aspect d'usure, mais tu crois que c'est valable aussi pour une delta ? 

Par ailleurs du coup, sur une delta, comme on a tendance à imprimer au milieu (justement pour éviter les "effets de bords" qui ne sont pas au même niveau que le milieu, du coup l'usure doit être très "géolocalisée" ?

@Pogues et @lemmings : j'ai moi aussi une (légère) distorsion sur le lit, mais j'avoue que je mettais ça sur le compte de la double tête d'extrusion et de son offset par rapport au centre du noyau.

En tous cas, je peux vous garantir que quand la grille de compensation n'est pas activée, c'est largement pire et c'est quasi impossible d'imprimer quelque chose de plus de 4cm de côté ! :o

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, Marlequeen a dit :

L'argument est intéressant, je n'avais pas prêté attention à cet aspect d'usure, mais tu crois que c'est valable aussi pour une delta ? 

bien sur tout mouvement que ce soit un patin, une roulette se doit d'avoir une usure bien répartie. Il y a forcément une incidence à terme sur la qualité d'impression. Après il ne faut pas non plus être plus royaliste que le roi, on ne va pas régler la mise en place au 1/10 eme de mm comme sur une une machine outil car les efforts que supportent la tête et les glissières sont faibles mais autant mettre toute les chances de notre côté :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

En imprimant un support vertical avec des pièces relativement large, j'ai constaté le même phénomène : la première couche plus écrasé d'un côté que de l'autre. J'ai mis quelques photos ci-dessous.

Avant de faire le 4ème (4ème en partant du bas) j'ai refait une calibration pour voir si ça changeait quelque-chose, mais le résultat était le même.

Le phénomène se voit nettement sur les 2 supports qui ont foiré à cause du filament qui a fait un nœud à l'entrée de l'extrudeur (échantillon de PLA eMotion-Tech sans bobine posé en vrac).

En mesurant la hauteur plateau / socle je constate que j'ai 1mm d'écart entre 2 côtés. Mais comme le dit Marlequeen, pour moi c'est compensé par l'autocalibration.

Du coup je me demande vraiment ce qui est à l'origine de ce phénomène ?

Plus surprenant, j'ai constaté la même chose à plus petite échelle sur l'impression de cubes de calibration 20*20.

@+

Math

 

Support_1.jpg

Support_2.jpg

Support_3.jpg

Cubes.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

salut @Math51

 

En voyant tes photos, je me demande quand même si la grille de compensation est prise en compte dans ton cas ? Tu t'es connecté avec Repetier Host pour vérifier (cf commandes listées en haut du topic) ?

Cela me semble particulièrement costaud comme décalage, autant cela peut se voir un peu sur des grandes pièces comme tes supports à bobines, autant sur un cube de 20 cela ne devrait pas être perceptible à ce point ! 

Un petit truc qui permet d'atténuer cet effet est de monter la première couche à 0.24 voire 0.3mm. Je ne descends quasi jamais en dessous de 0.2 pour une première couche, ça évite d'avoir une surface trop "moche" et vraiment pas plate :) 

Après on peut ruser en activant sous Cura ou Slic3r l'anti "elephant foot" pour éviter que la première couche ne "déborde trop" par rapport au reste du print ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

Merci pour ton retour.

J'ai fait le test des commandes. Je ne maitrise pas encore le langage gcode, mais j'ai l'impression que la grille de compensation est bien prise en compte.

18:27:09.246 : N15 M105*19
18:27:09.246 : ok T:19.6 /0.0 @0 B:20.1 /0.0 @0
18:27:09.246 : ok
18:27:11.882 : N16 M375.1*10
18:27:11.882 : 0.0874  0.0375 -0.0125 -0.0625  0.0375  0.0500  0.0126
18:27:11.882 : 0.0875  0.0500  0.0125  0.0125  0.0500  0.0125 -0.0250
18:27:11.882 : -0.0375  0.0000  0.0375  0.0500  0.0625  0.0000 -0.0625
18:27:11.882 : -0.2625 -0.1500 -0.0500  0.0125  0.0125  0.0000  0.0125
18:27:11.882 : -0.4000 -0.2375 -0.0750 -0.0125 -0.0625 -0.0875 -0.1125
18:27:11.898 : -0.4750 -0.3000 -0.1250 -0.0500 -0.0375 -0.1000 -0.1875
18:27:11.898 : -0.5250 -0.3375 -0.1750 -0.0125 -0.0125 -0.0625 -0.1375
18:27:11.898 : ok
18:27:11.898 : ok
18:27:12.303 : N17 M105*17
18:27:12.303 : ok T:19.5 /0.0 @0 B:20.1 /0.0 @0
18:27:12.303 : ok
18:27:15.346 : N18 M503*28
18:27:15.346 : ; config override present: /sd/config-override
18:27:15.346 : ;Steps per unit:
18:27:15.346 : M92 X80.00000 Y80.00000 Z80.00000
18:27:15.346 : ;Acceleration mm/sec^2:
18:27:15.346 : M204 S3000.00000
18:27:15.346 : ;X- Junction Deviation, Z- Z junction deviation, S - Minimum Planner speed mm/sec:
18:27:15.346 : M205 X0.05000 Z-1.00000 S0.00000
18:27:15.346 : ;Max cartesian feedrates in mm/sec:
18:27:15.346 : M203 X400.00000 Y400.00000 Z400.00000
18:27:15.346 : ;Max actuator feedrates in mm/sec:
18:27:15.346 : M203.1 X400.00000 Y400.00000 Z400.00000
18:27:15.346 : ;Optional arm solution specific settings:
18:27:15.346 : M665 L170.0000 R80.7709
18:27:15.346 : ;WCS settings
18:27:15.346 : G54
18:27:15.346 : ;Home offset (mm):
18:27:15.346 : M206 X0.00 Y0.00 Z32.90
18:27:15.346 : ;Trim (mm):
18:27:15.346 : M666 X0.000 Y-0.157 Z-0.172
18:27:15.346 : ;Max Z
18:27:15.346 : M665 Z180.000
18:27:15.346 : ;E Steps per mm:
18:27:15.346 : M92 E163.0000 P57988
18:27:15.346 : ;E Filament diameter:
18:27:15.346 : M200 D0.0000 P57988
18:27:15.362 : ;E retract length, feedrate:
18:27:15.362 : M207 S3.0000 F2700.0000 Z0.0000 Q6000.0000 P57988
18:27:15.362 : ;E retract recover length, feedrate:
18:27:15.362 : M208 S0.0000 F480.0000 P57988
18:27:15.362 : ;E acceleration mm/sec??:
18:27:15.362 : M204 E500.0000 P57988
18:27:15.362 : ;E max feed rate mm/sec:
18:27:15.362 : M203 E40.0000 P57988
18:27:15.362 : ;E Steps per mm:
18:27:15.362 : M92 E163.0000 P39350
18:27:15.362 : ;E Filament diameter:
18:27:15.362 : M200 D0.0000 P39350
18:27:15.362 : ;E retract length, feedrate:
18:27:15.362 : M207 S3.0000 F2700.0000 Z0.0000 Q6000.0000 P39350
18:27:15.362 : ;E retract recover length, feedrate:
18:27:15.362 : M208 S0.0000 F480.0000 P39350
18:27:15.362 : ;E acceleration mm/sec??:
18:27:15.362 : M204 E500.0000 P39350
18:27:15.362 : ;E max feed rate mm/sec:
18:27:15.362 : M203 E40.0000 P39350
18:27:15.362 : ;PID settings:
18:27:15.362 : M301 S0 P41.2000 I2.9030 D146.0000 X255.0000 Y255
18:27:15.362 : ;Max temperature setting:
18:27:15.362 : M143 S0 P300.0000
18:27:15.362 : ;PID settings:
18:27:15.362 : M301 S1 P300.0000 I14.4000 D300.0000 X255.0000 Y255
18:27:15.362 : ;Max temperature setting:
18:27:15.362 : M143 S1 P300.0000
18:27:15.362 : ;Probe feedrates Slow/fast(K)/Return (mm/sec) max_z (mm) height (mm):
18:27:15.362 : M670 S20.00 K100.00 R0.00 Z180.00 H20.00
18:27:15.362 : ;Probe offsets:
18:27:15.362 : M565 X0.00000 Y0.00000 Z0.00000
18:27:15.362 : ;Load saved grid
18:27:15.362 : M375
18:27:15.362 : ok
18:27:15.362 : N19 M105*31
18:27:15.362 : ok
18:27:15.377 : ok T:19.6 /0.0 @0 B:20.2 /0.0 @0
18:27:15.377 : ok
18:27:18.419 : N20 M105*21
18:27:18.419 : ok T:19.6 /0.0 @0 B:20.2 /0.0 @0
18:27:18.419 : ok
18:27:21.477 : N21 M105*20
18:27:21.477 : ok T:19.5 /0.0 @0 B:20.1 /0.0 @0
18:27:21.477 : ok
18:27:24.535 : N22 M105*23

Dans mon profil Cura, le paramètre "hauteur de la couche initiale" est bien à 3mm.

Merci

Math

Partager ce message


Lien à poster
Partager sur d’autres sites

@Math51 Oui, ça a l'air bon !

Par contre étrangement à la lecture de ta grille, ton bed est relativement plat, sauf un des coins (du fond je pense) qui a quasiment 0.5mm de différence avec le reste.

Par contre, clairement en imprimant au centre et vers l'avant du plateau tu ne devrais pas rencontrer un tel décalage sur ton cube, l'offset en Z étant très inférieur à 0.1mm

Par curiosité, tu as ces soucis uniquement avec ce filament ou bien est-ce récurrent ?

Partager ce message


Lien à poster
Partager sur d’autres sites

regarde les petit boules qui se visse qui tiennent les billettes.  

j'en avait une qui n’était pas très bien visée et du coup le parallélisme des billette n’était pas correct.

sa se joue au 10° de millimètre.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Merci pour vos retour.

Il y a 15 heures, Marlequeen a dit :

@Math51 Oui, ça a l'air bon !

Par contre étrangement à la lecture de ta grille, ton bed est relativement plat, sauf un des coins (du fond je pense) qui a quasiment 0.5mm de différence avec le reste.

Par contre, clairement en imprimant au centre et vers l'avant du plateau tu ne devrais pas rencontrer un tel décalage sur ton cube, l'offset en Z étant très inférieur à 0.1mm

Par curiosité, tu as ces soucis uniquement avec ce filament ou bien est-ce récurrent ?

Non ça le fait aussi avec le PLA Spectrum que j'utilise depuis ce week-end après avoir fini mes échantillons eMotion-Tech (cf. photos ci-dessous). En mesurant la hauteur du plateau au pied à coulisse, quand je suis en face de l'écran de contrôle, j'ai presque 1mm d'écart de hauteur entre la l'arrêt de gauche du triangle et l'arrête de droite. Mais ça devrait être pris en compte dans la calibration ...

Il y a 5 heures, sigiel a dit :

regarde les petit boules qui se visse qui tiennent les billettes.  

j'en avait une qui n’était pas très bien visée et du coup le parallélisme des billette n’était pas correct.

sa se joue au 10° de millimètre.

Ok je vais vérifier, mais j'avais pas oser trop forcer sur le serrage des rotules, comme marque dans la notice, pour ne pas foirer les pas de vis dans les chariots en plastiques.

Math

 

cube blanc.jpg

Modifié (le) par Math51

Partager ce message


Lien à poster
Partager sur d’autres sites

Lorsque l'on fait M375.1, la machine nous renvoie une matrice 7x7 soit 49 points au total. Sauf que lorsque l'on effectue l'opération de calibration, il n'y a que 34 points palpés. Normal ? pas normal ?

C'est normal ! Tout les points de la matrice qui sont en dehors du cercle de rayon 65mm, ne sont pas palpés (en dehors de la surface théorique d'impression). Sur l'image ci-dessous, on voit les 15 points non palpés (en rouge).

image.png.b80a56dfd99597513ca2b6265659ac38.png

Les valeurs qui y sont données sont alors des valeurs estimées. Pour reprendre les données de @Math51, les valeurs -0.4750  et -0.5250 ne sont donc pas réelles).

Pour les grandes pièces, je trouve que le paramétrage par défaut n'effectue pas suffisamment de correction sur les extérieur. J'ai un gros décalage en Z sur l'avant de l'imprimante (jusqu'à -0.4) et la calibration prend mal en compte ce défaut de planéité. Il faut imaginer que par défaut, tout ce qui se trouve entre le rayon 65 et le rayon 75 sera imprimé sur un lit non calibré. Et je ne parle pas des données estimées..

En résumé, au centre tout se passe bien , il y a des points de corrections un peu partout. Par contre sur les extérieurs je trouve cela beaucoup top light en terme de précision, d'autant plus quand les données sont estimées...

J'ai donc changé les paramètres suivant:

  • leveling-strategy.delta-grid.radius : passe de 65 à 70
  • leveling-strategy.delta-grid.size :  passe de 7 à 21 (toujours impair !)

J'ai refait une calib, une impression, et c'est bien mieux !

Avant / Après

image.png.7a6fb02874dfe7b819a50449a610ccf0.pngimage.png.e5193d9d5bb26271f561f6b4efb25c1c.png

Je rappelle que tout ce qui est en dehors du cercle est une estimation. La zone rouge en bas à droite est donc irréelle !

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

As tu mesuré le temps de calibration entre la première et la deuxième méthode ?

C'est vachement intéressant comme amélioration de précision (bravo !).

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé non, je n'ai pas regardé le temps. Par contre je peux te dire que pour la grille 21x21 j'ai eu 317 points palpés. Tu comptes 2 secondes par point, ça fait (à la grosse) 10 min.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Alesky Par curiosité, tu peux nous montrer les résultats d'une impression avant/après ?

Passer de 7 à 21 (!!) me parait assez drastique ;) 

Perso je suis montée à 11, et c'est déjà plutôt bon (et long à palper ^ ^) je trouve ?

Le reste étant interpolé entre les points, il faudrait vraiment avoir un plateau "grumeleux" pour qu'il y ait une réelle différence ?

Je me suis aussi posée la question si cela pouvait aussi avoir une incidence sur les capacités de calcul (pas super étendues) du proc, de trop pousser dans le "détail" la grille ?

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×