Aller au contenu

Filament ABS

Nenex

Configuration Marlin 1.1.8 / Anycubic Linear+ de Nenex

Messages recommandés

Bonjour,

J'ai acheté une linear plus ya 3 semaines. Reçu avec un "bras" cassé, j'ai du faire une réparation a la bonne franquette mais dans l’état actuel j'arrive tous de même a faire des prints avec !

Le support ma envoyer deux rods de remplacement :) J'ai acheter un détecteur de filament (Lien amazon.fr), il est brancher sur le pin 11 de la trigorilla et bon point il fait une lumière verte quand il détecte un filament. Il va donc avoir des modif sur marlin et du coup j'en profite pour passer sous Marlin1.1.8 et donc pouvoir profiter des derniers ajouts ect.

 

Voici donc mon firmware, ainsi qu'un tutoriel d'installation semi-complet (encore quelque ajout a faire pour les plus rookie du flashing^_^)

Mon firmware (github) et le changelog de marlin

Support pour le détecteur : https://www.thingiverse.com/thing:2764075

 

Change-log :

03/31 :  - Ajout d'une version autolevel V1 sans tmc

03/18 :  - Ajout d'une version alternative pour les utilisateurs de l'autolevel V1

 

 


 *                                                             -Configuration.h :

                                                                  Connexion avec 250000 bauds
 *                                                               -Autoleveling avec palpeur d'origine

                                                                 -M600 (changement de filament, pas encore régler pour enlever entièrement le filament) a terme ça va enlever le filament comme le   "                                                                 "déchargement" de filament d'une neva.

                                                                 -Détecteur de filament sur servo0 (le débrancher ou ne pas en avoir va juste désactiver la détection et rien changer a vos habitude)
 *                                                               -Fan1 activé
 *                                                               -Configuration_adv.h :   
 *                                                             
 *                                                               -Ajout d'un CUSTOM_MENU Menu Principal>Custom Commands :
 *                                                                 #define USER_DESC_1 "Home & level"         USER_GCODE_1 "G28\nG29"
 *                                                                 #define USER_DESC_2 "Home & stat"          USER_GCODE_2 "G28\nM78"

                                                                   //Avec pronterface par exemple:

                                                                   Stats: Prints: 2, Finished: 2, Failed: 0
                                                                   Stats: Total time: 1h 3m 59s, Longest job: 50m 2s
                                                                   Stats: Filament used: 4.49m


 *                                                                 #define USER_DESC_3 "Home & steppers off"  USER_GCODE_3 "G28\nM84"
 *                                                                 #define USER_DESC_4 "Extruder 15mm de PLA" //chauffe, extrude 15mm de pla et retract 1mm
 *                                                                 #define USER_DESC_5 "Changer de filament"  USER_GCODE_5 "M600"
                                                                   

                                                                    Marlin est configuré pour une Anycubic delta Plus (testé sur une linear plus)

 

 

Le 21/03/2018 at 21:35, Nenex a dit :

Installation TMC2xxx :

744b29f7e6.jpg

Tu débranche le moteur x , ensuite tu débranche le drivers le plus a gauche que tu remplace par le tmc, tu doit le brancher dans le bon sens c'est a dire le réglage du voltage a gauche(comme sur le photo). Quand tu est bien sur qu'il soit bien placé dans sont slot, tu rallume la machine et avec l'aide d'un multimètre et d'un tournevis tu va pouvoir régler ton voltage très précisément a 1.06v. Une fois le voltage réglé, coupe l'imprimante, rebranche le moteur et répète l'opération pour chaque drivers.

Détecteur de filament :

222e77d0a3.jpg

Rien de plus simple soit tu utilise le endstop Y- soit X-, branché comme les autres endstops.

Et maintenant plus que le firmware :) Installe arduino et télécharge sur github la dernière version de mon firmware (si c'est pas déjà le cas). Crée un dossier et décompresse l'archive dedans. Ouvre le fichier "marlin.ino"(V1/Marlin pour les palpeur V1)

a6ba50a1f7.jpg

 

Ensuite petite manip en dessous en photo

image.thumb.png.18e46785a3d380aea4b2a8ba70fdfa28.png

Dans le menu de droite (flèche sous la loupe) cherche et ouvre pins_RAMPS.h

1997bb54e7.png

Fait crtl+f et cherche  FIL_RUNOUT_PIN 3ad66f4078.png

Change 11 suivant le port que ta utilisé pour le detecteur de filament : Y- | 14 ou X- |  3

Dans configuration.h, crtl +F et cherche @section machine. Si tu a pas de tmc remplace les valeurs INVERT_X_DIR  |  INVERT_Y_DIR  |  INVERT_Z_DIR par "true"

3102fcbdcd.png

Toujours au même endroit,  cherche DELTA_HEIGHT et remplace la valeur par ton Z max actuel sur ta kossel. Voila tu peut enregistrer et exporter le firmware (Tu va le retrouver sous marlin.ino). Tu peut aller te faire un café suivant la bête que tu a (pc) ^_^

6f7f1e0040.png

image.png.b031fdbd7aa6ccf8a12940052cadfcae.png

Tu peut maintenant mettre a jour ta machine depuis cura par exemple. Connecte la par usb a ton pc et sur cura dans tes paramètre machine tu va voir "mettre a jour le firmware". La c'est le moment ou tu boit ton café :D Après ton café (si tu ma pris au mot héhé :))tu devrais avoir ta machine sous le nouveau firmware.

Avec la machine toujours connecté au pc et de http://www.pronterface.com/ (par exemple, il en a d'autre mais je vais utilisé celui la dans le tutoriel ): Pour envoyer une commande, suivant l'affichage vous aurais ou non des onglets

a86ace2333.png

Tu peut faire M502 puis M500. Test tes endstops avec G28 et ensuite si TOUS te semble correct, équipe ton imprimante de sont palpeur (d'origine bien-sur, logique mais je préfère prévenir).

Va dans prépare>Delta calibration> Set Delta Height puis Store, ensuite (même menu) Autocalibration > store, custom menu>Home & level.

Maintenant viens l’étape la plus importante ^_^ (bien lire jusqu'a la fin et pas suivre directement le tuto): l'affinage du Delta Height soit le Z max en home(qui est donc votre Zoffset), toujours sur pronterface G28, G1 Z10 F1000, G1 Z2 F500 puis place une feuille sous la buse et fait G1 Z0 F250 et tu test de bouger la feuille ça doit juste frotter un peut.

Dans le cas ou ça semble vouloir descendre trop bas vous devais réduire votre Z max en conséquence et donc inversement si votre buse est trop haute augmenter le Z. Petit exemple mon Z max est 280, une fois a Z0 je vois que ma tête a environ 2mm du bed. Je fait un G28(auto home, ensuite je change mon Z max par 281 et je fait ensuite M500(store). Je retourne a Z0 en suivant toujours la même méthodologie, j'essaye avec 281.1 et je répète jusqu'a que ma feuille  frotte tous juste la buse .

Ne jamais oublier de sauvegarder et surtout penser que ça peut foirer la main sur l'intérup de l'alimentation n'est pas un luxe, fait attention au premier lancement j'ai pas envie d'avoir ton plateau qui viens me hanter la nuit :emoji-E412:

Tips :

c6bcddf070.png

Avec l'imprimante connecté au pc et connecté depuis pronterface, custom menu>Home&Stats

 

Modifié (le) par Nenex

Partager ce message


Lien à poster
Partager sur d’autres sites

Ha mais j'avais pas du tout vu ce post !

Je garde un œil sur le sujet.

Une chose qu'on arrivera pas à corriger sur cette carte avec des firmware c'est que je suis quasi sûr que les condos renvoient du jus en permanence un peu n'importe où.

Je le vois car même tout éteint et débranché, ma carte de relais s'allume (très légèrement) genre toutes les 10 secondes (ça fait comme une respiration très lente). Ca ne s'arrête que si je débranche l'usb entre la Trigo et le Pi.

Je ne sais pas si ça peut jouer mais je me dis que les pertes de mémoire (perte du z) pourraient bien venir de là.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hum je vois, c'est peut être un courant résiduel et la faible consommation des compo fait que ça décharge très lentement. Branche un chargeur type iphone, débranche de le et met ton portable a charger tu verra qu'il charge moins d'une 1sec. Je pense plus a un truc comme ça, après peut être que ça joue sur les amnésie de z offset. Et elle montre plus signe de vie au bout de bcp de temps ? En théorie un port usb envoie du courant c'est peut être lui qui perturbe ? Mais dans mon cas je print en sd ... :/

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 1/19/2018 at 16:25, Nenex a dit :

J'ai acheté une linear plus ya 3 semaines. Reçu avec un "bras" cassé, j'ai du faire une réparation a la bonne franquette mais dans l’état actuel j'arrive tous de même a faire des prints avec

bienvenu au club, 

la mienne en avait 4 qui était pas bien coller.... et en plus vue que j'ai pas fait une ouverture de litige aliexpress il sont pas très sympas en SAV.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @sigiel

Ah oui effectivement tu n'a pas eu de chance ! J'ai vraiment du mal a comprendre leur nouvelle "politique" de packaging : Avant (vu sur l'ancien manuel de montage) tu monter chaque tige toi même et du coup aucun risque que ça pète au transport, alors que maintenant, ok ont doit plus monter les bases, les steppers ect c'est sympa mais franchement soit c'est mal penser soit ils ont fait ça  histoire que ça pète 1 transport sur 2 :/

Sinon pour leur support : Ma i3 avait un ventilateur d'alim qui fessait sauter le fusible. Après plusieurs mail, ils m’ont envoyer une alim de remplacement, j'ai tester avec un autre ventilateur 14v  que j'avais en rabe, changer le fusible et depuis aucun problème avec l'alim. Et pour la kossel, ils ont pas chercher a comprendre,  j'ai eu le droit a non pas une mais deux tiges ! :D.

image.jpg

Modifié (le) par Nenex

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon ! J'ai beaucoup réfléchie sur le fait que la bed est relativement proche de la trigo. J'ai vu ça sur thing : https://www.thingiverse.com/thing:2431556, le mode est sympa mais je voulais plus d'espace entre le bed et la trigo. Le tunnel est trop proche a mon gout des drivers donc je me suis fait quelque pièces "custom" :D!

La flemme est présente, donc oui le passage de câble est bof bof x). J'ai encore les tmc2208 a souder/installer/régler donc .. ^_^

image.jpg?width=480&height=640

image.jpg

Oui ça tien :P

image.jpg

image.jpg?width=480&height=640

Partager ce message


Lien à poster
Partager sur d’autres sites

@Platator Hé hé j'ai toujours voulu tester :P. Pour le moment j'ai pas assez de recule mais déjà ont vois la différence au niveau des vibrations, l'ensemble de la structure bouge ensemble. Faut que j'installe des renforts pour les coins pour rigidifié un peut plus.

Modifié (le) par Nenex

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut ! J'ai bosser sur le marlin ce week-end et ça marche comme il faut^_^ Je vous met le firmware compilé pour l'instant, cette version est pour les "delta +" avec drivers d'origine. Quand j'aurais le temps tous sera sur github pour pouvoir changer ce que vous voulais et compiler a vos besoin.

Après avoir mis le firmware avec cura par exemple, installer le palpeur puis Menu>Prepare>Delta calibrations>Set Delta Height, retourner y et faite "store settings". Dans ce mème menu vous aller voir "Auto configuration" qui semble être un bed leveling mais plus long (5 fois en cercle) et bed leveling n'oubliez pas de "store" pour garder en mémoire :D

 

 Change-log :
 *                                                             -Configuration.h :

                           Connexion avec 250000 bauds
 *                                                               -Autoleveling avec palpeur d'origine

                                                                 -M600 (changement de filament, pas encore régler pour enlever entièrement le filament) a terme ça va enlever le filament comme le   "                                                                 "déchargement" de filament d'une neva.

                                                                 -Détecteur de filament sur servo0 (le débrancher ou ne pas en avoir va juste désactiver la détection et rien changer a vos habitude)
 *                                                               
 *                                                               -Configuration_adv.h :   
 *                                                             
 *                                                               -Ajout d'un CUSTOM_MENU Menu Principal>Custom Commands :
 *                                                                 #define USER_DESC_1 "Home & level"         USER_GCODE_1 "G28\nG29"
 *                                                                 #define USER_DESC_2 "Home & stat"          USER_GCODE_2 "G28\nM78"

                                                                   //Avec pronterface par exemple:

                                                                   Stats: Prints: 2, Finished: 2, Failed: 0
                                                                   Stats: Total time: 1h 3m 59s, Longest job: 50m 2s
                                                                   Stats: Filament used: 4.49m


 *                                                                 #define USER_DESC_3 "Home & steppers off"  USER_GCODE_3 "G28\nM84"
 *                                                                 #define USER_DESC_4 "Extruder 15mm de PLA" //chauffe, extrude 15mm de pla et retract 1mm
 *                                                                 #define USER_DESC_5 "Changer de filament"  USER_GCODE_5 "M600"
                                                                   

                                                                    Et tous le reste est configurer pour une Anycubic delta Plus (testé sur une linear plus)

Marlin_1.1.8_notmc.rar

Modifié (le) par Nenex
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Du coup, avec ce "nouveau" bed levelling, plus besoin d'ajuster le z derrière ou on peut/doit toujours le faire ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Platator Hum j'avais réussie a régler le z offset mais pas depuis que j'ai mis les tmc2208.Quand je change Z-offset dans controle>Motion  ça semble ne pas être pris en compte :/ En théorie ça devais le faire j'ai bien réussie a sortir un benchy avant de d'aller dormir !^_^ Par contre le z offset semble être converser même après avoir couper le jus.

Effectivement ça garde bien les valeurs ^_^ il faut aller dans Menu>Prepare>Delta calibrations> Delta settings et régler delta height (environ 277 est a 0 tes a plus de 1mm du plateau) puis revenir avant et store, faut auto home pour valider le changement. Motion> Zoffset semble pas marche :/

Modifié (le) par Nenex

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon j'ai réussie a régler la delta height ^_^ J'ai sortie un benchy 125% vers 4h du matin bof bof :emoji-E412: (nouveau filament par encore les bon settings).

image.jpg

Les tmc2208 sont régler a 0.8v, les moteurs semble bien fonctionner, c'est un plaisir ! Plus aucun bruit sauf mécanique bien sur :D J'ai mis un noctua 40x40x10 sur la tète c'est beaucoup plus silencieux de ce coter la. Je vais changer le ventilateur de l'alim car même si il s'allume que de temps en temps il est vraiment bruyant :/ Environ 50/55db en impression 70db avec l'alim qui s'active. Surement mettre un noctua, mais me semble que c'est un ventilateur 14v comme sur les mega ? A voir ...

noctua.thumb.jpg.5158a730945edc402d00a2b9bec83250.jpg

Modifié (le) par Nenex
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon j'avais fait un proto de lampe led sur la tete et vu que ça marche bien cette nuit j'ai modéliser une v2,  imprimer aujourd'hui voici le résultat ^_^

tete5.thumb.jpg.bc0921edfbd240c2c41f1c0ac3d2cdbc.jpgtete2.thumb.jpg.748d495a6815c2ed903360f345623d6b.jpg

 

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@Platator ça rend mieux en vrai mon iphone5 fait pas de belle photo :) Imprimer en phosphorescent aussi héhé ça rend bien meme eteint ! Et ce silence avec le noctua + tmc2280 magique ^_^

Tu a tester mon firmware ? ^^

Modifié (le) par Nenex

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Il y a 4 heures, Nenex a dit :

Je vais changer le ventilateur de l'alim car même si il s'allume que de temps en temps il est vraiment bruyant :/ Environ 50/55db en impression 70db avec l'alim qui s'active

Je ne sais pas ce qu'il y a sur ton alim mais le scythe 100x100x12  1000 rpm que l'on met dans nos mega est inaudible

Partager ce message


Lien à poster
Partager sur d’autres sites

@db42 Ok merci :) c'est a peut prêt la même voir la même que ma mega, je vais en commander 1 pour faire la modif sur l'alim de la delta. Pour la mega j'ai un evercooler 14v^_^ Pars contre l'alimentation c''est du 60mm le ventilateur non ?

Modifié (le) par Nenex

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Nenex a dit :

@Platator ça rend mieux en vrai mon iphone5 fait pas de belle photo :) Imprimer en phosphorescent aussi héhé ça rend bien meme eteint ! Et ce silence avec le noctua + tmc2280 magique ^_^

Tu a tester mon firmware ? ^^

Pas le temps en ce moment mais ça me prendra bien un de ces 4 ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×