Aller au contenu

Filament ABS

Lecoyote

Problème GT2560 Rev A+ et LCD

Messages recommandés

Bonjour. J'ai acheté la GT2560 Rev A+ que je voudrais utiliser avec un 3D touch. Problème: quelque soit le marlin injecté, mon ecran LCD ne fonctionne pas (écran noir). Savez vous comment resoudre ca?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

@Lecoyote j'ai déplacé ton post pour qu'il ai une meilleur lisibilité

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Il y a 2 connecteurs qui partent de la carte et qui vont vers le lecteur SD et vers l'afficheur LCD. Les connecteurs sont identiques et il n'y a pas de détrompeur. Alors question toute bête : as-tu bien connecté la bonne nappe sur le bon plot ?

Tu ne donnes aucune information sur l'écran. Ni sur la partie du fichier de configuration que tu as modifiée pour le faire fonctionner.

Par exemple, j'utilise un écran LCD 20x4 et j'ai :

#define ULTRA_LCD   // Character based
//#define DOGLCD      // Full graphics display

Le titre du sujet prête à confusion. Ce n'est pas un problème de 3D-Touch sur GT2560 Rev A+ mais d'écran LCD sur GT2560 Rev A+.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Denis MUSET DEPERO a dit :

Ce n'est pas un problème de 3D-Touch sur GT2560 Rev A+ mais d'écran LCD sur GT2560 Rev A+.

exact, modif effectuée ;)

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

@Denis; non j'ai bien vérifié, les 2 connecteurs ne sont pas intervertis.

L'écran est un LCD 20x4 et j'ai defini #define ULTRA_LCD  dans configuration.h. Aucun marlin ne le fait fonctionner.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Lecoyote tu as essayé de dé commenté la ligne :

#define REPRAP_DISCOUNT_SMART_CONTROLLER

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui Pascal, sans plus de succès... Bizarre, mais je maîtrise encore trop mal Marlin pour en comprendre les subtilités.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca y est problème résolu! Figurez-vous que Geeetech nous a fait la bonne blague d'inverser les pins entre les connecteurs des  cartes GT2560 Rev A et GT2560 Rev A+. En d'autres termes, pour que le LCD et le lecteur de SD fonctionnent, il faut brancher les prises à l'envers (upside down). Donc, un coup de cutter dans les languettes des détrompeurs est nécessaire, puis on branche les 2 connecteurs la tête en bas et tout fonctionne à nouveau. :)

Modifié (le) par Lecoyote
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×