Aller au contenu

Filament ABS

christrodr

Commande G28 X Y Z

Messages recommandés

Bonjour,

J'ai un soucis que je ne comprends pas.

J'ai monté ma smartcub3d ce weekend et je vois par exemple dans le gcode de début un G28 X Y qui devrait me ramener le X et Y a leur position de parking. mais en fait il ne me ramène que le X et pas le Y.

Par contre G28 X ou G28 Y fonctionnent correctement ainsi que G28 seul ramène tout le monde à la maison...

Je suis sous windows 8.1 64bits avec le dernier Repetier et slic3r.

 

Merci

Christian

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, biostrike a dit :

Extrait de ton G-code telecharger sur ton site :

G90 ; Passage coordonnees absolues
G28 X Y Z ; all home 
G1 X100 Y100 F8000 ; 

faudrait que tu modifies les fichiers de ton site du coup ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, biostrike a dit :

Silc3r réinterprète le gcode "slic3r" en gcode machine... ;)

Si je laisse le gcode de depart tel que tu le fournis, le homing ne se fait pas sur X et Y mais seulemt sur X, du coup j'ai changer G28 X Y en 2 ligne G28 X et ensuite G28 Y.

 

C'est pas normal du coup ?

Modifié (le) par christrodr

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est pas normal, ni logique effectivement...  par contre je vois pas pourquoi o.O

Le microswich fonctionne bien ? il est bien branché ? tu as bien fait le test du m119 ?

 

Modifié (le) par biostrike

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, biostrike a dit :

C'est pas normal, ni logique effectivement...  par contre je vois pas pourquoi o.O

Peut être une mise à jour de slic3r qui interprète direct en gcode machine ? (je dis peut être une énormité hein, mais j'essaie de comprendre)

Partager ce message


Lien à poster
Partager sur d’autres sites

non... c'est du standard utilisé par tous.

En Gcode manuelle sous REPETIER il faudrait faire un M119 puis  G28 XY  puis un M119. Et regarder les LOG pour voir si il n'y a pas un truc qui cloche.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 8 minutes, biostrike a dit :

non... c'est du standard utilisé par tous.

En Gcode manuelle sous REPETIER il faudrait faire un M119 puis  G28 XY  puis un M119. Et regarder les LOG pour voir si il n'y a pas un truc qui cloche.

J'vais en avoir des trucs à faire ce soir moi :D

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon j'ai fait :

M119 => tout le monde à OPEN
G28 XY => seulement X vient en butée
M119 => seulement Xmin est passé en TRIGGERED

Du coup c'est vraiment étrange comme comportement.

Christian

Modifié (le) par christrodr

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour revenir au "problème", A priori , c'est pas mécanique, c'est pas électrique... donc probablement "logiciel". 

Si tu veux vraiment creuser le truc, tu peux essayer de re-flasher le Firmware.

Mais bon, comme ça n'empêche en rien à la machine de fonctionner, c'est toi qui voit...  ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me doutais un peu du soucis logiciel...

J'ai un soucis d’écran de temps en temps il me parle Vénusien :D (au moins une fois par jour), tu penses que ça peut venir du logiciel aussi ?

 

Christian

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×