Aller au contenu

Filament ABS

diiity

auto level capteur capacitif

Messages recommandés

Bonjour,

Sur pas I3 pro B acrylique, j'ai mis en place un capteur capacitif. Comme depuis quelques temps j'ai des petits souci d'impression je revois tous mes réglages et notamment l'auto level. J'essaie de refaire le calibrage du Z .

Je n'arrive plus à régler le Z, impossible de passer sous 0

Je voudrais suivre ce tuto pour Anet A8 mais je pense que c'est aussi valable pour la  prusa.

https://3dprint.wiki/reprap/anet/a8/improvement/autobedleveling

Je suis sous marlin 1.1.8

diiity

Partager ce message


Lien à poster
Partager sur d’autres sites
G28 // pour faire un auto home

M851 Z0 // Reset Z0Offset

G1 F3000 X100 Y100 Z0 // pour ammener l'axe Z au point 0. la ou la buse doit toucher le plateau

M211 S0 // desactive protection valeur negative Z

via pronterface on affine la hauteur de la buse avec une feuille
Quand c'est bon la valeur Z du LCD est egal a notre offset en Z (ex : -2.3)

M851 Z-2.3 // on defini l'offset ou "#define Z_PROBE_OFFSET_FROM_EXTRUDER -2.3" dans marlin

M211 S1 // active protection valeur negative Z

M500 // enregistre dans l'eeprom

Faut utiliser pronterface, a ma connaissance c'est le seul a aller sous le 0 malgres la desactivation de la secu

Partager ce message


Lien à poster
Partager sur d’autres sites

l'écart est de 1.5mm, ça je ne l'ai pas touché, par contre j'ai joué avec le potard de la sonde et rien ne va plu, dans quelle position je doit le mettre?

Quand je fais un g28, la sonde se positionne à environ 15mm du bed alors que l'affichage de l'imprimante le situe à 11.5

Partager ce message


Lien à poster
Partager sur d’autres sites

voici le log de repetier

14:50:58.358 : X:69.00 Y:100.00 Z:11.50 E:0.00 Count X:11071 Y:16105 Z:4588
14:53:00.557 : echo:Probe Z Offset z_min:  -15 z_max:  -5
14:54:10.710 : echo:Soft endstops: Arret  Min: X0.00 Y0.00 Z0.00  Max: X200.00 Y200.00 Z180.00

Mais après le Z ne veut toujours pas descendre
 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, diiity a dit :

 par contre j'ai joué avec le potard de la sonde et rien ne va plu, dans quelle position je doit le mettre?

 

tu met physiquement le capteur a une distance ou il doit detecter.

Tu met en buté le potard en non-detection.

tu tournes le potard et des qu'il detecte, c'est bon.

Puis reglage de l'offset en Z

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu fais des M119, tu vois ton capteur changé d'etat en fonction de sa detection ou non-detection. Sans toucher au potar bien sur.

Si oui tu as juste a calibrer l'offset en Z ensuite

 

A partir des logs que tu as balancé au dessus, donnes toi du mou

#define Z_PROBE_OFFSET_RANGE_MIN -20
#define Z_PROBE_OFFSET_RANGE_MAX 20

Partager ce message


Lien à poster
Partager sur d’autres sites

si je mets le potar du capteur en non détection, c'est à dire qu'il ne puisse pas s'allumé, il s'enfonce dans le bed et si je le mets dans l'autre sens donc à s'allumé il capte trop haut

Partager ce message


Lien à poster
Partager sur d’autres sites

>> 1

euh la première chose est de régler la sensibilité de ton capteur et c'est a faire une seule fois

Ton capteur a une plage de detection. Je vais dire un truc au pif genre entre 3 et 5mm. A voir en fonction de ta reference

Tu demontes ton capteur de ta tete histoire de ne pas etre parasité.

Tu met ton capteur devant quelque chose (genre a 4mm dans mon exemple) et tu le regles comme indiqué au dessus.

Ensuite la led du capteur doit s'activer ou se desactiver si il y a quelque chose devant ou pas

 

>> 2

tu valides le fonctionnement de ton capteur sur ta machine

Quand rien n'est devant ton capteur et tu fais un M119 tu dois avoir "open" sur "z_min"

A l'inverse quant tu as quelque chose devant tu dois avoir "TRIGGERED"

 

Valides déjà les points 1 &  2 et apres calibration de l'offset avec la procédure plus haut

Modifié (le) par hidius

Partager ce message


Lien à poster
Partager sur d’autres sites

rien à faire il ne veut pas passer sous 0

15:17:09.680 : X:69.00 Y:100.00 Z:11.50 E:0.00 Count X:11071 Y:16105 Z:4588
15:17:36.609 : echo:Probe Z Offset z_min:  -20 z_max:  -20
15:18:19.150 : echo:Soft endstops: Arret  Min: X0.00 Y0.00 Z0.00  Max: X200.00 Y200.00 Z180.00
 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 11 minutes, diiity a dit :

15:17:36.609 : echo:Probe Z Offset z_min:  -20 z_max:  -20

tu es certain d'avoir mis 20 et non -20 a Z_PROBE_OFFSET_RANGE_MAX ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, hidius a dit :

tu es certain d'avoir mis 20 et non -20 a Z_PROBE_OFFSET_RANGE_MAX ?

exact je me suis trompé

Partager ce message


Lien à poster
Partager sur d’autres sites

Quand je fais le G28 la buse vient au centre du bed le Z descend jusqu'à capter puis remonte à une certaine hauteur, un peu moins de 16mm, sur répetier il indique 0 et sur l'écran de l'imprimante 11.5

Partager ce message


Lien à poster
Partager sur d’autres sites

OK  ton capteur semble fonctionner (donc les points 1 & 2 ca a l'air d'etre bon ?!). on ne touche plus au potar ;)

Maintenant calibration de ton offset

Il y a 1 heure, hidius a dit :

G28 // pour faire un auto home

M851 Z0 // Reset Z0Offset

G1 F3000 X100 Y100 Z0 // pour ammener l'axe Z au point 0. la ou la buse doit toucher le plateau

M211 S0 // desactive protection valeur negative Z

via pronterface on affine la hauteur de la buse avec une feuille
Quand c'est bon la valeur Z du LCD est egal a notre offset en Z (ex : -2.3)

M851 Z-2.3 // on defini l'offset ou "#define Z_PROBE_OFFSET_FROM_EXTRUDER -2.3" dans marlin

M211 S1 // active protection valeur negative Z

M500 // enregistre dans l'eeprom

Faut utiliser pronterface, a ma connaissance c'est le seul a aller sous le 0 malgres la desactivation de la secu

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est cette  ligne là qui me met le capteur à 11.5, je l'ai mis à 0

#define Z_CLEARANCE_DEPLOY_PROBE   10 // Z Clearance for Deploy/Stow          
  

Partager ce message


Lien à poster
Partager sur d’autres sites

non ca remonte juste la tete de 10mm par secu remet le à 10.

CALIBRE TON OFFSET !!! :40_rage:

 

 

et ensuite un

G28

G1 F3000 X100 Y100 Z0

ça va ramener ta buse au centre du plateau a Z0 pour validation

Partager ce message


Lien à poster
Partager sur d’autres sites

non, toujours pas de descente 

il y a 2 minutes, hidius a dit :

CALIBRE TON OFFSET !!! :40_rage:

c'est à dire? c'est bien ce que l'on cherche depuis le début ou j'ai raté quelque chose à moins que tu parles de la sensibilité du capteur, le potard

Partager ce message


Lien à poster
Partager sur d’autres sites

tu déconnes hein ?! :emoji-E412:

Suis cette procedure

Il y a 1 heure, hidius a dit :

G28 // pour faire un auto home

M851 Z0 // Reset Z0Offset

G1 F3000 X100 Y100 Z0 // pour ammener l'axe Z au point 0. la ou la buse doit toucher le plateau

M211 S0 // desactive protection valeur negative Z

via pronterface on affine la hauteur de la buse avec une feuille
Quand c'est bon la valeur Z du LCD est egal a notre offset en Z (ex : -2.3)

M851 Z-2.3 // on defini l'offset ou "#define Z_PROBE_OFFSET_FROM_EXTRUDER -2.3" dans marlin

M211 S1 // active protection valeur negative Z

M500 // enregistre dans l'eeprom

Faut utiliser pronterface, a ma connaissance c'est le seul a aller sous le 0 malgres la desactivation de la secu

Modifié (le) par hidius

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×