Aller au contenu

Filament ABS

Desmojack

Erreur de compilation

Messages recommandés

Hello everybody,

Bon, ça fait 3 plombes que j'essaye de flasher la Tornado et rien à faire.

Quand je clique sur "vérifier", ou" téléverser" dans Arduino, ça me cale un message d'erreur, "erreur de compilation  pour la carte Arduino/Genuino Mega or Mega 2560".

Par ailleurs, Tornado quand elle est connectée apparaît  dans périphériques et imprimantes/non spécifié/FT 232R USB UART, donc tout va bien apparemment pas de problème de driver ou je ne sais quoi.

Clic Droit, propriété/matériel, 2 ports apparaissent USB serial Converter et USB serial port com4 (115200bits/s) et dans la console Arduino, j'ai sélectionné le port Com4

Là, je cale ...  si quelqu'un a une idée et peut me mettre sur la voie, reconnaissance éternelle, tournée générale, cierge(s) à Sainte Rita, etc

...Il est presque 5 heures du mat et  Madame vient de m'engueuler parce que je suis encore dans ma caverne à me prendre la tête avec cette p%§$ d'imprimante ... elle est mignonne, (pas l'imprimante) Madame Desmojack :17_heart_eyes:

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, 

mon petit coup de pouce .... il faut regarder ce qu'il y a au dessus de "erreur de compilation..." (avec l'ascenseur) et tu dois même pouvoir copier le log.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

J'ai donc ce message:

Arduino : 1.8.5 (Windows 7), Carte : "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Users\Rakoum\Downloads\Nouveau dossier (2)\tevo-tornado-firmware\tevo-tornado-firmware\Tornado\Tornado.ino:45:110: fatal error: U8glib.h: No such file or directory

     #include <U8glib.h> // library for graphics LCD by Oli Kraus (https://github.com/olikraus/U8glib_Arduino)

                                                                                                              ^

compilation terminated.

exit status 1
Erreur de compilation pour la carte Arduino/Genuino Mega or Mega 2560

 

Et le rapport détaillé:

board=mega
build.warn_data_percentage=75
console=true
console.auto_clear=true
console.error.file=stderr.txt
console.length=500
console.lines=4
console.output.file=stdout.txt
custom_cpu=mega_atmega2560
editor.antialias=true
editor.auto_close_braces=true
editor.caret.blink=true
editor.code_folding=false
editor.divider.size=2
editor.external=false
editor.font=Monospaced,plain,12
editor.indent=true
editor.invalid=false
editor.keys.alternative_cut_copy_paste=true
editor.keys.home_and_end_beginning_end_of_doc=false
editor.keys.shift_backspace_is_delete=true
editor.languages.current=
editor.linenumbers=false
editor.save_on_verify=true
editor.tabs.expand=true
editor.tabs.size=2
editor.window.height.default=600
editor.window.height.min=290
editor.window.width.default=500
editor.window.width.min=400
export.applet.separate_jar_files=false
export.application.fullscreen=false
export.application.platform=true
export.application.stop=true
export.delete_target_folder=true
gui.scale=auto
last.ide.1.8.5.daterun=1521882866
last.ide.1.8.5.hardwarepath=C:\Program Files (x86)\Arduino\hardware
last.screen.height=800
last.screen.width=1280
last.sketch.count=1
last.sketch.default.location=-8,-8,1296,776,591,6
last.sketch.default.path=C:\Users\Rakoum\Downloads\Nouveau dossier (2)\tevo-tornado-firmware\tevo-tornado-firmware\Tornado\Tornado.ino
last.sketch0.location=-8,-8,1296,776,591,6
last.sketch0.path=C:\Users\Rakoum\Downloads\Nouveau dossier (2)\tevo-tornado-firmware\tevo-tornado-firmware\Tornado\Tornado.ino
platform.auto_file_type_associations=true
preproc.color_datatype=true
preproc.enhanced_casting=true
preproc.imports.list=java.applet.*,java.awt.Dimension,java.awt.Frame,java.awt.event.MouseEvent,java.awt.event.KeyEvent,java.awt.event.FocusEvent,java.awt.Image,java.io.*,java.net.*,java.text.*,java.util.*,java.util.zip.*,java.util.regex.*
preproc.output_parse_tree=false
preproc.save_build_files=false
preproc.substitute_floats=true
preproc.substitute_unicode=true
preproc.web_colors=true
programmer=arduino:avrispmkii
recent.sketches=C:\Users\Rakoum\Downloads\Nouveau dossier (2)\tevo-tornado-firmware\tevo-tornado-firmware\Tornado\Tornado.ino
run.display=1
run.options=
run.options.memory=false
run.options.memory.initial=64
run.options.memory.maximum=256
run.present.bgcolor=#666666
run.present.exclusive=false
run.present.stop.color=#cccccc
serial.databits=8
serial.debug_rate=9600
serial.parity=N
serial.port=COM4
serial.port.file=COM4
serial.port.iserial=null
serial.stopbits=1
sketchbook.path=C:\Users\Rakoum\Documents\Arduino
software=ARDUINO
target_package=arduino
target_platform=avr
update.check=true
update.id=4425045961748329605
upload.using=bootloader
upload.verify=true

 

Apparemment ce " U8glib.h:" pose problème et pas qu"à moi, suffit de chercher dans Google.

Si quelqu'un pouvait me dire où ça cloche, parce qu'Arduino, moi pas connaître.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me sens moins seul tout d'un coup.

Bon, j'essaye de comprendre ce truc, je suis sur une piste , j'ai téléchargé  le zip u8glib_arduino.

Il y a un fichier install, je regarde ça.

Si je trouve je transmets ici .

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pense que ça a marché.

J'explique ma manip si ça peut aider quelqu'un.

Il faut télécharger  le zip "u8glib" sur https://github.com/olikraus/U8glib_Arduino

Après, ouvrir Arduino, cliquer sur l'onglet croquis, inclure une bibliothèque, cliquer sur importer Zip (un truc du genre, je ne me rappelle plus exactement, mais c'est facile à trouver), et cliquer sur le dossier zippé téléchargé auparavant.

Et normalement, c'est bon.

 
  • J'aime 1
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai trouvé aussi !!!!!!!!! PLUS D'ERREUR DE COMPILATION !!! avec Arduino 1.8.5 sur Marlin 1.1.8 !!!

Utilisez le fichier fourni par Derbo Design dans son dernier tuto consacré à Marlin 1.1.8 , CA MARCHE !!!!! ALELLUHIA !!!!

ici le tuto :  

 

je n'ai essayé que la version stock du fichier (Fichier N°1 dans les commentaires de son tuto)  : https://www.youtube.com/redirect?redir_token=7ucGaGPx85HAj3QoXmCoCXe6boF8MTUyMTk3OTg1N0AxNTIxODkzNDU3&event=video_description&v=0ESABiaG0fk&q=https%3A%2F%2Fmega.nz%2F%23!YpgSTI5R!sUCY2VlaCqzqJ4stjNEiJOkhdGsMyvrdq8KC5DnVY1k (mon dieu ce lien )

Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

Cool pour toi Philippe.

Par ici c'est toujours la galère.

Maintenant, la compilation s'exécute nickel, le téléversement arrive à sa fin, la tornado s'éteint, redémarre et c'est là que ça beug, en fait elle n'est pas flashée.

J'ai changé la valeur du step per unit sur Z dans Arduino et quand je vais sur la Tornado dans Control/Motion/Steps/mn, la valeur n'a pas changé.

Ca commence à me les briser menu cette histoire.

Toujours pareil, si quelqu'un a une idée, je suis preneur.

Je ne crée pas autre sujet pour ça

Partager ce message


Lien à poster
Partager sur d’autres sites

je ne connais pas la tornado... sur mon Anet, quand je fais un téléversement et qu'il se termine, l'écran LCD se réinitialise (ou plutot Marlin redémarre) et j'ai un titre du genre Marlin 1.1.8 etc.... et puis l'affichage standard, températures, position.... Si tu as ça c'est que le téléversement doit se faire. Est-ce que tu recompiles Marlin avec Aduino après les modifications ? Je ne sais pas si c'est nécessaire mais moi je le fais systématiquement.

Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

En apparence, tout se fait bien jusqu'au bout, mais quand l'écran se rallume, toujours version 1.1 si j'en crois l'affichage et mes modifs dans Arduino n'apparaissent pas.

En désespoir de cause, je suis entrain de dépouiller la carte et je vais essayer de la flasher sans rien de branché dessus... légèrement pénible cette affaire.

Partager ce message


Lien à poster
Partager sur d’autres sites

La j'avoue que je cale. J'espère pour toi que tu vas t'en sortir. De mon côté ça marche , j'arrive à compiler et à flasher, donc ça c'est réglé mias si tout va bien sans BL-Touch, avec BL-Touch je continue a avoir le comprtement bizare : quand je fais un Home All, la tête d'impression fait le X et le Y mais pour le Z, elle monte au lieu de descendre. Ceci est peu être lié au fait que mon BL Touch fait descendre son palpeur mais le remonte tout de suite comme si il avait touché quelque chose alors qu'il n'a rien touché et se rallume tout de suite en rouge.

Je vais vérifier mes soudures parce que c'est pas trop mon truc :)

Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

@Desmojack... Euh alors si ça peut aider.... 

Sur la Gitèque, y suffit pas de téléverser, y faut aussi à la fin, dans le LCD, trouver une option qui DEVRAIT s'appeler "restore defaults" ou un truc comme ça, et après, réécrire l'EEPROM

Je sais, "restore defaults" ça fait un peu penser à "remettre dans l'état initial", mais c'est pourtant ça (traduction avec les pieds, peut-être)

Je sais pas si c'est pareil sur les Nénettes....

 

("desmo" comme les motos qui perdent les boulons ?????)

Modifié (le) par Jean-Claude Garnier

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, en attendant de trouver mieux, j'ai viré toutes les connections sur la carte, flashé, reconnecté et c'est toujours pareil grrrr.

Merci Jean Claude de te pencher sur mon problème.

Dans le menu, j'ai "store settings" (?), "load settings" (?)," restore failsafe" (?), et" initialize EEprom".

Un peu énervé, j'ai validé les 4 et miracle , mon réglage de steps a été validé.

Du coup, je suis comme une bille, car je ne sais pas lequel des 4 a déclenché le truc (je pencherai pour initialize Eeprom) 9_9, mais facile à déterminer, c'est pas un soucis.

C'est quand même un peu léger de la part de Tevo qu'il n'édite pas un tuto sur leur site expliquant au minimum le paramétrage auquel on a accès par le biais écran/bouton de sélection, ou alors j'ai mal cherché.

En tous cas, grand merci à toi Jean Claude ;)

.... et pour la moto qui perd ses boulons, c'est même pas vrai d'abord... avec du frein filets partout héhé!!!

En tous cas je préfère bricoler la Ducati que la Tornado, là je maîtrise pas trop mal.

Modifié (le) par Desmojack
précisions

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×