Aller au contenu

Filament ABS

gisclace

- autre - Quels composants acheter

Messages recommandés

Bonsoir à tous,

Histoire de ne pas faire de hs dans le topic de @Chris V., j'ouvre un topic ici pour poser mes questions.

Donc, comme dans ce projet sur thingiverse, je souhaite intégrer un Rpi dans le boitier de ma Cr10S, bon, par contre, je suis une bille dans tout ce qui touche à l'électronique et je préfère demander avant de cramer quoi que ce soit.

Pour le relais, je pensais prendre celui-ci : https://www.amazon.fr/gp/product/B06XKST8XC/ref=ox_sc_act_title_1?smid=A1780XYQ9DFQM6&psc=1

Pour le "buck-converter", en cherchant sur le net (vue que pour être honnête, j'ai découvert ce truc la semaine dernière en trouvant le projet sur thingiverse, c'est vous dire mon niveau), j'ai trouvé ce genre de truc : https://www.amazon.fr/riorand-voiture-Alimentation-convertisseur-module/dp/B00G890MIC/ref=sr_1_21?ie=UTF8&qid=1523814955&sr=8-21&keywords=buck+converter+5v

Vous pensez que tout est bon ? sinon vous me conseillez quoi ?

 

Merci :D

Partager ce message


Lien à poster
Partager sur d’autres sites

Yo.

Bon, je m'y suis  collé ce weekend. C'est neat: 

 

A l'origine je pensais utiliser effectivement un Buck converter, après coup il s'avère que, pour  une raison qui m'échappe, j'avais une masse. Donc, en guise de plan B, j'alimente simplement le Pi via une alimentation externe que je sors par le passe-câbles du boîtier de commande. Au final je préfère, le Pi ne tire pas sur l'alim de l'imprimante de cette manière. Même si j'ignore encore pourquoi j'avais une masse avec le buck. Le buck d'ailleurs, si tu tiens quand même à suivre cette voie, est un LM2596S et est trouvable ici : https://www.amazon.fr/gp/product/B072MQYJ93/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

Du coup t'as besoin d'un Pi + alimentation et d'un relais x voies (minimum 2 pour faire les choses bien, une pour la machine et une pour un éventuel éclairage, j'en ai pris un de quatre voies histoire d'être future proof, ne sachant pas vers où j'vais ; j'achète systématiquement celui-ci : https://www.amazon.fr/gp/product/B01BAFLMCI/ref=oh_aui_detailpage_o00_s01?ie=UTF8&psc=1, j'utilise ce modèle depuis ma première imprimante 3D, la Dagoma d'il y a bientôt (déjà) deux ans ; ceci dit celui que t'as posté fera bien le job aussi).

 

Au final t'as juste à pinout le relais sur le Pi avec des dupont (GPIO 17 et 18 chez moi) et à dériver un des deux câbles qui partent vers la mobo sur l'une des deux voies du relais.

Partager ce message


Lien à poster
Partager sur d’autres sites

Thx pour le retour d'expérience.

Bon ça ne me rassure pas quand à la faisabilité en ce qui me concerne de rajouter ce fameux buck, je vais surement m'en passer dans un premier temps.

Finalement t'as joué du dremel !!! GG

Merci pour le relais, dans le doute, je vais commander les mêmes ^_^

Bon bha ma conclusion dans une semaine hein

 

Edit : au passage, n'ayant pas encor ouvert la bête, je n'ai pas vérifié les ventilos, mais du coup, ils ne sont pas en direct sur l'alim ?

Modifié (le) par gisclace

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, gisclace a dit :

Bon ça ne me rassure pas quand à la faisabilité en ce qui me concerne de rajouter ce fameux buck, je vais surement m'en passer dans un premier temps.

A tous les coups j'ai dû mal m'y prendre. Ces temps-ci je dors peu et mal du coup j'ai du mal à focus sur ce que je fais. :D Si le RPi s'alimente correctement avec le buck, il s'avère que dès l'instant où je branche un câble USB dessus et que j'essaie de brancher l'autre extrémité de ce câble sur la board de l'imprimante, cette dernière s'allume. Sans même brancher le connecteur. Juste toucher la partie métallique. Donc dans le doute j'ai débranché ça, je dois revoir ma copie c'est sûr. ;-) 

Pour la Dremel, ce fut ...quick and dirty, ahah ! Heureusement qu'il y a un cache en plastique pour camoufler la misère. :D

Si je garde ce mode de fonctionnement, il me faudra fort probablement redécouper une tranche et modifier le cache du projet original afin de pouvoir passer le ruban de la Pi Cam, parce que là je sors le ruban du casing en le collant à l'un des connecteurs USB, c'est pas joli. 

Modifié (le) par Chris V.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Chris V. a dit :

Si le RPi s'alimente correctement avec le buck, il s'avère que dès l'instant où je branche un câble USB dessus et que j'essaie de brancher l'autre extrémité de ce câble sur la board de l'imprimante, cette dernière s'allume. Sans même brancher le connecteur.

Bonjour,

Je n'ai pas bien suivi la manip de ce que tu cherches à faire mais je pense qu'il faut que tu fasses une isolation galvanique de la sortie du port USB pour éviter les boucles de masse.

En effet, le câble USB qui va de ton Pi vers l'imprimante véhicule du 5V en plus des signaux de commande. Il faut isoler ce 5V (broche 1)

J’essaierais dans un 1er temps de glisser un petit ruban de scotch sur la broche 1 pour l'isoler ou plus radical, couper le fil +5V dans le câble USB.

 

image.png.d8021bad9bd1c5e85041cc78e0d7995f.png

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Janpolanton a dit :

Je n'ai pas bien suivi la manip de ce que tu cherches à faire

Bonjour. :)

Ce que je cherchais à faire ici, en fait, c'était d'alimenter le Pi via l'alimentation de l'imprimante. Sur mes autres setups j'alimentais le Pi de manière indépendante via un adaptateur secteur lui étant propre. Ici, j'alimente le Buck via une sortie 12v de l'alimentation de l'imprimante, et le Buck alimente lui-même le Pi via le GPIO (une fois qu'il a été calibré à 5v, évidemment). S'est donc posé le souci dont je parlais ci-dessus. Souci que je ne rencontre pas si j'alimente le Pi via le connecteur microUSB à l'aide d'un adaptateur secteur "classique". 

Je suis actuellement sur mon lieu de travail, je ne peux donc pas tester ça pour l'instant. Mais je testerai, c'est sûr. :) Je me demande d'ailleurs si ça ne permettrait pas de garder l'écran LCD éteint lorsque la carte l'est également. Car sur chacune de mes imprimantes j'ai disposé d'un setup du genre (Pi/Relais) et j'ai toujours ce léger "défaut" d'avoir l'écran LCD qui reste allumé en permanence. 

Merci du précieux conseil, dans tous les cas. Je testerai ça sous peu et reviendrai vers toi. :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le coup du scotch su le connecteur, je n'y avais pas pensé, moi je coupais le fil directement ...

Merci @pascal_lb pour le liens, seul hic, le délai, c'est trop long, si je le commande, me connaissant je n'aurai pas le courage d'ouvrir à nouveau la bête pour installer ça (d'où celui que j'avais sélectionné sur amazon qui est livrable demain)

@Chris V., tu n'as pas trouvé de moyen d'éviter d'avoir le câble usb qui sort ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 6 minutes, gisclace a dit :

@Chris V., tu n'as pas trouvé de moyen d'éviter d'avoir le câble usb qui sort ?

Pour être honnête, j'ai même pas cherché. J'ai imaginé pivoter la carte principale et le Pi de telle sorte que les connecteurs sortants ne sortent plus mais dans mon cas vu que j'ai aussi un câble Ethernet et la nappe de la Pi Cam qui sortent, ça n'aurait pas eu beaucoup de sens. Ici pour l'instant j'ai installé un câble le plus court que j'ai pu trouver, mais j'ai ce qu'il faut à la maison pour souder mon propre câble, à la longueur désirée, de telle sorte qu'il dépasse vraiment le moins possible. Peut-être même des connecteur coudés pour éviter que ça ne dépasse trop latéralement également. Ce que je ferai fort probablement. :) 

Modifié (le) par Chris V.

Partager ce message


Lien à poster
Partager sur d’autres sites

ok

Pour ma part, je vais essayer de ne pas avoir ce câble qui sort et rentre (je vais surement changer d'avis dès que la bête sera ouverte mais bon ^_^)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×