Aller au contenu

Filament ABS

Lecoyote

A l'aide pour réglage des steps de mon extrudeur!

Messages recommandés

Salut les amis,

Je fais appel à vos connaissances ce soir car je m'arrache les cheveux depuis 2 heures avec un problème assez simple, somme toute:

J'ai décidé de régler mon extrudeur ce soir

                              J'ai donc placé un scotch repère à 150 mm de l'entrée du filament dans l'extrudeur , puis j'ai demandé à Octoprint d'extruder 100 mm. 

Là, stupéfaction: Je mesure la longueur de filament restante entre l'extrudeur et le scotch: il devrait rester logiquement 5 cm, il en reste 10!!

Pas d'affolement, ayant changé mon extrudeur cette semaine, ainsi que mon moteur d'extrudeur, il est sans doute normal que tout soit déréglé.

Un petit tour dans Marlin, où je dois donc modifer la ligne

                     #define  DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 400, 95 } 

Petit calcul rapide:     95 x 150/100 = 142,5

 J'écris donc : 

                     #define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 400, 142.5 }        

Je compile, puis je flashe le Marlin.

Nouveau test du scotch: pas mieux! A quelques mm près, j'obtiens le meme résultat.

Je me dis que la virgule du 142,5 ne passe peut-etre pas. J'arrondis donc à 142 et retente la manipulation.... Meme résultat! 

Quelque chose m'échappe... Mais quoi! J'en appelle à vos connaissances, moi je n'en sais pas beaucoup plus.

Merci de vos conseils.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello @Lecoyote

Juste comme ça...

Quand tu as téléversé, fais "contrôler", puis "restaurer défauts", puis "Initialiser EEPROM" sur ton afficheur....

Des fois y'a besoin de faire ça, notamment pour la distance entre le palpeur et la buse...

Sans garantie, hein....

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Jean_Claude et merci de ton aide,

J'ai bien pensé à faire "restaurer défauts", mais de toutes façons, pour l'EEPROM, j'ai horreur de ce truc, je l'ai donc désactivée dans le Marlin, m'étant fait plusieurs fois avoir en effet avec des réglages EEprom qui prenaient le dessus sur le Marlin.

Dans mon Marlin j'ai donc : 

/#define EEPROM_SETTINGS // Enable for M500 and M501 commands
//#define DISABLE_M503    // Saves ~2700 bytes of PROGMEM. Disable for release!
//#define EEPROM_CHITCHAT   // Give feedback on EEPROM commands. Disable to save PROGMEM.

Modifié (le) par Lecoyote

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai un début de réponse. Il semblerait que le pb vienne d'Octoprint. Je vais dès que possible brancher un ordi sur l'imprimante et essayer avec Pronterface.

Partager ce message


Lien à poster
Partager sur d’autres sites

sinon essaye d extruder cm par cm avec octoprint chez moi la vitesse est trop rapide et fait sauter des pas j ai pas cherché encore comment modifier cette vitesse pour extruder bien plus lentement 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Via Octoprint dans le terminal, par exemple:

G1 E100.00 F500 ; Extrude 100mm à 500 mm/minute (rérérence G-code )

Commande à entrer dans le terminal après avoir mis en chauffe la buse évidemment!

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, merci à tous les 2. J'ai cherché pas mal sur le web et il semble que les 2 méthodes que vous donnez fonctionnent.Des que j'aurai un moment, je m'y colle et je vous dirai...

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×