Aller au contenu

Filament ABS

Psetta

entrer dans le DIY en changeant la carte mère de ma wanhao i3+

Messages recommandés

En voulant régler les moteurs, j'ai flingué la carte mère de ma wanhao i3+.

Plutôt que de recommander la même carte mère, (100€...) et croiser les doigts pour que tout marche comme avant sans aucun réglage, je me demande si je pourrais pas installer ce qui contrôle une imprimante DIY (hypercube par ex). Cela me permettrai de me faire la main et m'équiperai si je venait à transformer ma wanhao en plus grosse imprimante.

Vous l'avez deviné, je ne connais rien à l'électronique, et mes compétence en programmation sont plus que limitées (je me débrouille en R). que pensez vous de cette idée?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut.

 

Je ne connais pas la carte d'origine. Si le format est propriétaire tu vas devoir tout reconfigurer mais tu seras libre de l'optionner.

Si elle tourne sur Marlin ou Smoothie, ca devrait pas être long et assez simple, mais ce sera moins cher que 100 euros. 

 

cdlt

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, Psetta a dit :

Je m'en doutais un peu! Je veux bien comprendre pourquoi

Ta vas au devant de déboires si tu n'as pas les connaissances nécessaires.

La solution la plus sage serait de remettre une carte neuve d'origine.

Tu es seul juge de cette décision.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour avoir changé la carte de ma leapfrog, c'est surtout une question de patiente et de test et beaucoup de lecture.

donc la question c'est plutôt :

-100€ tu pars sur du tout prêt, juste à brancher.

-50€ où tu vas devoir tout te taper, la configuration voir du câblage si c'est des fiches différentes. en serrant aussi les fesses pour avoir les données sur les moteurs (stepp per minute etc)

donc si tu aimes te casser du neurones, lance toi 😁

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ton retour, j'ai finalement acheté une carte mère officielle (100€)

Effectivement le remplacement c'est fait sans problème. Puis les problèmes ont commencés:

  • La langue est réglée sur chinois, et il faut reparamétrer cela à chaque allumage
  • La fonction de niveau ne marche pas à cause d'un problème de home: je me débrouille pour les faire à la main, en utilisant seulement le home du z
  • La chauffe s'est passée normalement, j'ai lancé un print, et la chauffe de la buse s'est arrêtée, et n'est plus jamais repartie
  • Les branchements étant tous bons, le soft ayant des problème, je flash le firmware (carte mère et LCD) sur la base des instructions de wanhao et de ce site. J'ai du utiliser le logiciel Arduino pour flasher la CM. Vu les problèmes, (absence de chauffe de l'extrudeur, freeze) j'ai du tester successivement plusieurs firmware du LCD, et les problèmes ont étés croissants.

J'ai été surpris que des réglages réalisés avec la version customs aient été conservées entre plusieurs flash de versions d'origine. Je me demande s'il ne faudrait pas réaliser un genre d'opération de nettoyage pour repartir sur de bonnes bases?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut 😁

A chaque flash tu doit faire M502, M500 puis M501.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 33 minutes, Nenex a dit :

Salut 😁

A chaque flash tu doit faire M502, M500 puis M501.

Merci pour la réponse, mais je ne la comprends pas. Quand je flash le LCD, je charge les fichier sur une micro sd, j’allume l'imprimante et le nouveau firmware s'installe tout seul.  Peux tu m'en dire plus sur la marche à suivre et me dire si tes recommandations portent sur le flash de la CM (en USB) ou du LCD (en micro sd)?

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur ton site j'ai vu que tu doit flash la CM & l’écran (normalement tu en a déjà un dessus), c'est deux firmware différent (.HEX pour la CM).

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, Nenex a dit :

Sur ton site j'ai vu que tu doit flash la CM & l’écran (normalement tu en a déjà un dessus), c'est deux firmware différent (.HEX pour la CM).

Oui c'est ce que j'ai fait, mais je pense qu'il y a eut trop de flash du LCD, car plus je flashais, plus les problèmes intervenaient tôt ou étaient bloquant. Y'a t'il une sorte de mémoire cache à purger?

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×