Aller au contenu

Filament ABS

alexisju

MicroDelta Rework : contrôle des LED et de l'intensité lumineuse

Messages recommandés

L'option LED sur ma MDR fonctionne par défaut au maximum de son intensité lumineuse.

Trop à mon goût. C'est limite éblouissant et puis surtout, avec Octoprint, ce n'est pas adapté pour les webcam (ça "brûle" l'image).

J'ai lu l'article de eMotion sur l'option LED et les paramétrages possibles , mais je n'arrive rien à en faire (peu importe si je branche les LED sur la prise dédiée ou celles prévues pour la seconde tête).

Et si j'envoie les gcode indiqué dans l'article en lien, ça fait des trucs plutôt bizarre avec Octoprint et l'imprimante (genre, il perd le home -> reset d'urgence / reboot d'Octopi nécessaire !).

D'où ma question : quelles sont vos pistes pour contrôler les LED et/ou diminuer leur intensité?

Partager ce message


Lien à poster
Partager sur d’autres sites

salut 

pour réduire la luminosité de ta LED il te faut une résistance plus grosse 

Partager ce message


Lien à poster
Partager sur d’autres sites

L'idée c'est plutôt d'utiliser les possibilités natives, en branchant les LED sur la sortie de la seconde tête et en ajoutant ces lignes au fichier config.txt :

switch.led.enable                      true          # Activer un module dedie aux LED
switch.led.input_on_command            M355          # Ajouter une commande Gcode pour activer les LED, ici "M355"
switch.led.input_off_command           M356          # Ajouter une commande Gcode pour desactiver les LED, ici "M356"
switch.led.output_pin                  2.7           # attribuer au module la sortie physique du second extudeur
switch.led.output_type                 pwm           # Utiliser la sortie en mode PWM pour réguler la luminosité
switch.led.startup_value               255           # Mettre la puissance des LED au maximum au demarage
switch.fan_extruder.ignore_on_halt     true          # Evite de reactiver maluellement la sortie en cas d'erreur

Normalement, on devrait pouvoir déterminer l'intensité des LED en modifiant la valeur de la ligne :

switch.led.startup_value

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Il y a 12 heures, alexisju a dit :

L'option LED sur ma MDR fonctionne par défaut au maximum de son intensité lumineuse.

Trop à mon goût. C'est limite éblouissant

Oui

J'ai retiré les Leds et j'ai mis une lampe à Leds à coté de l'imprimante. L'éclairage est plus homogène et pas éblouissant.

il y a une heure, alexisju a dit :

utiliser les possibilités natives, en branchant les LED sur la sortie de la seconde tête et en ajoutant ces lignes au fichier config.txt

C'est exactement ça. Utiliser la prise de la thermistance de l'extrudeur 2 pour faire varier l'intensité lumineuse des 2 leds. En théorie ça devrait fonctionner.

Après avoir modifié le fichier config.txt, essaie d'envoyer via Repetier en manuel, les commandes Gcode suivantes :

M355

M356

M355 S128

pour voir la réaction sur ton éclairage.

 

Bon, je viens de le faire, ça fonctionne. Mais même à S10 ça éblouit et en plus ça clignote.

Modifié (le) par trotro

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai refait un nouvelle essai plus concluant.

  • Au démarrage, avec les paramètres ajoutés au fichier de configuration, LED branchées sur le connecteur prévu pour la seconde tête, les LED ne s'allument pas tant que je n'envoie pas une commande gcode explicite via Repetier (p. ex. : M355 S100 ) (via Octoprint, ça ne fonctionnait pas).
  • Lors que l'on entre des valeurs basses (ce que je cherche à obtenir - à défaut je les débranche), les LED scintillent de manière gênante.
  • Les valeurs à partir desquelles les LED ne scintillent plus de manière perceptible, la luminosité est à nouveau trop intense pour passer à la webcam.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, alexisju a dit :

Lors que l'on entre des valeurs basses, les LED scintillent de manière gênante.

c'est le principe du pwm : simuler une variation analogique avec un système tout ou rien. Du coup a des fréquences assez basses on voit le scintillement.

J'ai fait un bricolage perso pour l'éclairage avec 3 leds fixés autour du noyau et branchées sur le pin LED avec une résistance de 2KOhm sur chaque led. Comme le kit led peut se brancher directement sur le pin LED (24V donc), je suppose qu'une résistance de 1KOhm pour l'ensemble devrait suffire

Partager ce message


Lien à poster
Partager sur d’autres sites

@alexisju : essaie de de voir ici. Section hwpwm pwm_period_ms

Modifié (le) par cmatec

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, alexisju a dit :

switch.led.startup_value 255 

pour le PWM essayer de passe la valeur en manuel dans le programme a 25 a la place de 255 cela devrai donner une information direct a l'allumage tu devrai voir une différence sur ta LED et du coup savoir si ton programme est bon ou pas ???

ensuite une R de 1Khom comme @BastienX8 a dit si tu es en 24 volt avec lumiere blanche pour un courant de 20mA cela devrait être bien 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×