Aller au contenu

Filament ABS

alf

Marlin sur geeetech I3

Messages recommandés

bonjour a tous

mon soucis est que ce matin apres problemes config sur imprimante, j'ai installe Marlin 1.1

j'ai perdu  l'affichage de mon ecran lcd qui est alluméavec une ligne sur 2 avec des paves noirs. plus de caracteres

j'ai donc reinstalle Marli mais en 1.0  et idem

ecran identique avec en arriere , sifflement continu

comment retrouver mon ecran

 

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

où as tu télechargé le marlin que tu as installé ?

 

Là, tu as le firmware d'origine, fonctionnel, mais non à jour http://www.geeetech.com/forum/download/file.php?id=2819&sid=e28cf4887f68b5621db90450e74a0de1

 

De mémoire @hidius a créé un profil pour la i3 pro B qui fonctionne avec le dernier marlin.

Par contre, je ne le retrouve pas .

 

🙂

Modifié (le) par Yo'

Partager ce message


Lien à poster
Partager sur d’autres sites

mis arduino 1.8.5 avec marlin v1.0

sifflement continu sur l'ecran LCD et toujurs pas de caracteres

Partager ce message


Lien à poster
Partager sur d’autres sites

tu as quoi comme carte sur ta pro B ?

Partager ce message


Lien à poster
Partager sur d’autres sites

erreur dans fichier SdBaseFile.h 

	struct fpos_t {
	        ^
	In file included from sketch\Marlin.h:10:0,
	                 from sketch\Marlin_main.cpp:30:
	c:\program files (x86)\arduino\hardware\tools\avr\avr\include\stdio.h:950:33: note: 'fpos_t' has a previous declaration here
	 __extension__ typedef long long fpos_t;
	                                 ^
	exit status 1
using typedef-name 'fpos_t' after 'struct'
	

voila erreur compil si arduino1.8.5 et marlin pro b 

en esperant que c

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Voici le Marlin que j'utilise sur mon imprimante.

Il y a juste à le compiler avec la dernière version de Arduino.

 

Il est adapté à mon imprimante (qui n'a plus qu'un extrudeur).

 

5 - Marlin-1.1.x - 1 extrudeur.7z

 

PS : penses à utiliser le bouton "éditer" au lieu de poster plusieurs messages à la suite. 😉

 

🙂

Modifié (le) par Yo'

Partager ce message


Lien à poster
Partager sur d’autres sites

merci encore Yo mais pas bon pour moi

je n'y comrends plus rien

avec ton fichier et arduino 1.8.5 sifflement et moteur x qui bouge pas a pas

j'ai simplement modifié motherboard dans config

je ne sais plus quoi tester

Partager ce message


Lien à poster
Partager sur d’autres sites

Pourquoi modifier quelque chose qui fonctionne ?

On a la même imprimante (vu que ma pro C n'a plus qu'un extrudeur, ce qui en fait une PRO B).

 

Je pense qu'il faut que tu vérifie tes connecteurs (derrière l'ecran et sur la carte) car ce que tu décris ressemble à un faux contact (si c'est le buzzer qui siffle

 

A moins que ça ne soit le driver de ton axe X qui soit HS, si c'est lui qui siffle.

 

🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

ce que je voulais dire que dans ton fichier je n'est modifie que motherboard avant de compiler puisque ma motherboard origine config est board_ramps_14_efb

le sifflement vient du lcd

Partager ce message


Lien à poster
Partager sur d’autres sites

MERCI YO

je ne pensais jamais que le probleme venait du motherbord etant donné que depuis le debut c'etait configuré ainsi

 

merci enormement de ton aide tres precieuse

 

😍😍

Partager ce message


Lien à poster
Partager sur d’autres sites

You're welcome 😉

 

Par contre, certaines valeurs sont spécifiques à mon imprimante (les dimensions du plateau).

Il va falloir les changer si tu veux profiter de la largeur totale de ton plateau.

 

🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

oui j'ai vu et changé certains params comme direction axes ou autres mais j'ai gardé ton nom affiché sur le LCD   YOTech

merci encore

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 18/06/2018 at 13:12, Yo' a dit :

Salut,

 

où as tu télechargé le marlin que tu as installé ?

 

Là, tu as le firmware d'origine, fonctionnel, mais non à jour http://www.geeetech.com/forum/download/file.php?id=2819&sid=e28cf4887f68b5621db90450e74a0de1

 

De mémoire @hidius a créé un profil pour la i3 pro B qui fonctionne avec le dernier marlin.

Par contre, je ne le retrouve pas .

 

🙂

Un peut tard desolé, c'etait ici :

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×