Aller au contenu

Filament ABS

linoco

Fin de filament CR-10S

Messages recommandés

Pouvez-vous me faire savoir comment sa ce passe avec Le détecteur de filament en fin de bobine .

Également en cas de coupure de courant. 

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Le détecteur de fin de filament lorsqu'il est activé (donc il n'y a plus de filament à fournir à l'extrudeur), met en pause ta tête d'impression: en fait la tête reste à la même hauteur d'impression mais se décale en dehors de la zone à imprimer. Tu enlèves le filament (délicatement sans modifier l'axe X) puis tu en remets un nouveau et sur le boitier de contrôle de l'imprimante tu pousse sur le bouton; ça c'est la théorie et ce que j'ai lu du descriptif publicitaire de Creality.

Pour la coupure de courant, tu peux demander  @Bosco2509  ce qu'il en pense 😉  😄 (nan là je rigole). En fait quelques modèles de CR10 sont équipées de cette "protection".

Le plus simple, pour toi, ce serait de tester: tu coupes ton filament et tu vois ce qu'il advient puis tu coupes le courant et lycée de Versailles comme aime à le dire @Jean-Claude Garnier (humoriste notoirement potache 😉 ).

Modifié (le) par fran6p
oups, une faute d'orthographe (copues au lieu de coupes :D

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, fran6p a dit :

.. /.. comme aime à le dire @Jean-Claude Garnier (humoriste notoirement potache )

Encore, encore, c'est trop d'honneur, merci !

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@fran6p c'est que trop d'honneur d'être cité par toi... merci... merci.

Pour en revenir au sujet : @linoco j'ai moi même équipé ma CR-10S (CR-10 d'origine), du détecteur de fin de filament, et j'ai moi même voulu voir ce qu'il se passait.
Quand le détecteur ne détecte plus le filament, sur mon imprimante, tout s'arrête !
Ce que je veut dire par "tout s'arrête", l'écran de contrôle de l'imprimante s'éteint, l'impression de stoppe nette.
Cependant la carte électronique et le boitier, lui même, tourne toujours, car j'ai bien entendu que les ventilos tournaient toujours.
Le plateau (pour le mien en 220V) continu de chauffer normalement.
Par contre la tête, elle s'arrête de chauffer.
Par contre, j'ai noté que la tête... elle s'arrête et reste exactement là où elle s'est arrêté. Ce qui fini par former... une petite boule de matière sur l'impression.
Sur mon Raspberry, Octoprint, j'ai un message du type "Filament Error".
L'impression est juste en "Pause".
Il m'a fallu remettre du filament... demander de continuer l'impression... et l'impression redémarre.

Pour la petite boule de matière... un coup de petite pince coupante... et là voilà disparu.

Pour le fait que la tête s'arrête là où elle s'est arrêté, je me suis renseigné, il faut rajouter une ligne dans les paramètres quand l'impression est suspendu (ou quand il n'y a plus de filament), pour que la tête se soulève et se décalle légèrement. Il faut ensuite (il me semble) faire le code inverse dans les paramètres quand une impression est reprise.
Voilà ce que je sait.
Tu en sait autant que moi désormais.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le détecteur de filament lorsqu'il est connecté à la CM de la CR10 ne fonctionne qu'avec une impression lancée à partir de la carte SD.

De mes lectures et pérégrinationsdiverses et variées du World Wide Web, j'ai cru comprendre qu'il ne fonctionnait pas avec Octoprint. Si l'on souhaite l'utiliser avec Octoprint, il faut qu'il soit connecté sur le Raspberry mais dans ce cas, si on lance l'impression de la carte SD alors il ne fonctionne plus adéquatement (je ne suis pas sûr d'avoir été très clair dans mon explication   😞  ).

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Bosco2509 a dit :

@fran6p c'est que trop d'honneur d'être cité par toi... merci... merci.

Pour en revenir au sujet : @linoco j'ai moi même équipé ma CR-10S (CR-10 d'origine), du détecteur de fin de filament, et j'ai moi même voulu voir ce qu'il se passait.
Quand le détecteur ne détecte plus le filament, sur mon imprimante, tout s'arrête !
Ce que je veut dire par "tout s'arrête", l'écran de contrôle de l'imprimante s'éteint, l'impression de stoppe nette.
Cependant la carte électronique et le boitier, lui même, tourne toujours, car j'ai bien entendu que les ventilos tournaient toujours.
Le plateau (pour le mien en 220V) continu de chauffer normalement.
Par contre la tête, elle s'arrête de chauffer.
Par contre, j'ai noté que la tête... elle s'arrête et reste exactement là où elle s'est arrêté. Ce qui fini par former... une petite boule de matière sur l'impression.
Sur mon Raspberry, Octoprint, j'ai un message du type "Filament Error".
L'impression est juste en "Pause".
Il m'a fallu remettre du filament... demander de continuer l'impression... et l'impression redémarre.

Pour la petite boule de matière... un coup de petite pince coupante... et là voilà disparu.

Pour le fait que la tête s'arrête là où elle s'est arrêté, je me suis renseigné, il faut rajouter une ligne dans les paramètres quand l'impression est suspendu (ou quand il n'y a plus de filament), pour que la tête se soulève et se décalle légèrement. Il faut ensuite (il me semble) faire le code inverse dans les paramètres quand une impression est reprise.
Voilà ce que je sait.
Tu en sait autant que moi désormais.

Bizarre ce que tu dis, Bosco, car chez moi lorsque le détecteur détecte la fin de filament, un écran spécifique s'affiche, le filament est alors rétracté (s'il en reste un peu), et un message t'annonce qu'il faut réinsérer un filament. Ensuite la chauffe reprend et on te demande si tu veux extruder du fil à blanc ou si tu veux reprendre l'impression là où elle s'était arrêtée. Si tu cliques sur le bouton du boitier, l'impression reprend.  

Je te dis ça sur ma CR-10 modifiée en CR-10S moi aussi, avec Marlin 1.1.8.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Lecoyote a dit :

Bizarre ce que tu dis, Bosco, car chez moi lorsque le détecteur détecte la fin de filament, un écran spécifique s'affiche, le filament est alors rétracté (s'il en reste un peu), et un message t'annonce qu'il faut réinsérer un filament. Ensuite la chauffe reprend et on te demande si tu veux extruder du fil à blanc ou si tu veux reprendre l'impression là où elle s'était arrêtée. Si tu cliques sur le bouton du boitier, l'impression reprend.  

Je te dis ça sur ma CR-10 modifiée en CR-10S moi aussi, avec Marlin 1.1.8.

J'ai bien un message qui s'affiche... mais c'est sur Octoprint. L'écran de ma CR-10(S) lui est éteint quand il n'y a plus de filament.
Quand je réinsère le filament... là j'ai le message me demandant si je veut reprendre l'impression là où elle s'est arrêté.
Je n'ai pas Marlin... mais encore le firmware d'origine... cela viens peut être de là...

J'en sait rien... du moment que cela fonctionne, je vais pas tripouiller et chercher à comprendre.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pourtant si. La carte mère que Bosco a achetée (une v2.1) en remplacement de celle d'origine (une CR10 v1) ayant grillée, a un Marlin d'installé sinon comment pourrait-elle faire fonctionner les moteurs, le détecteur, etc.

Par contre comme il a été flashé par Creality ce n'est sans doute pas la dernière version (1.1.8 à ce jour).

Bosco ne précise pas si son impression est lancée à partir de la carte SD ou bien à partir d'Octoprint.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, fran6p a dit :

Pourtant si. La carte mère que Bosco a achetée (une v2.1) en remplacement de celle d'origine (une CR10 v1) ayant grillée, a un Marlin d'installé sinon comment pourrait-elle faire fonctionner les moteurs, le détecteur, etc.

Par contre comme il a été flashé par Creality ce n'est sans doute pas la dernière version (1.1.8 à ce jour).

Bosco ne précise pas si son impression est lancée à partir de la carte SD ou bien à partir d'Octoprint.

Pour des raisons... "Pratique"... je ne peut plus me passer d'Octoprint. Contrôler mon imprimante par mon smartphone... je peut plus m'en passer.
Donc chaque impression est faite par Octoprint.
Oui... c'est pas faux... j'ai pas vérifier la version du firmware. Je l'ai monté... et depuis je l'utilise telle quelle.
Je vérifierai dès que je l'occasion.

Partager ce message


Lien à poster
Partager sur d’autres sites

Vous allez trouver cela bête... mais... j'ai beau chercher... je vois pas comment on fait pour savoir quel est la version du firmware de sa cr-10(S)... 😊
Je me sent bête tout d'un coup.
J'ai trouvé multitude de vidéo qui explique comment flasher pour installer Marlin... mais zéro sur la méthode pour obtenir cette info.
Si certains d'entre-vous connaissent la méthode... je suis preneur.

Edit :
Youpi ! hourra ! J'ai trouvé !
C'est inscrit dans le plugin EEPROM Marlin Plugin.
La version est  (copier coller du texte) : FIRMWARE_NAME:Marlin 1.1.0 From Archive SOURCE_CODE_URL:http:// ... PROTOCOL_VERSION:1.0 MACHINE_TYPE:www.cxsw3d.com EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000

C'est donc Marlin d'installer... mais la version 1.1.0

Oulalala cela date...

J'ai plus qu'à mettre cela à jour visiblement.

Modifié (le) par Bosco2509

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Le gcode M115 donne également la version du firmware.

 

🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

juste une info pour Bosco2509 

je viens de remplacer la carte mère et l'afficheur de ma CR-10 pour upgrade vers CR-10s  (CM v2.1)

avant j'utilisais un Raspberry pour la détection de fin de filament avec le support  https://www.thingiverse.com/thing:2513373

mais le switch utilisé n'est pas compatible avec la nouvelle carte . Pour le montage avec raspberry il s'agit d'un inverseur NO+NC

mais avec la nouvelle carte c'est un NO+voyant donc ce n'est pas le même cablage.

avec le NO+NC le switch génère un cour circuit et l'afficheur s'eteint lorsqu'il n'y a pas de filament . heureusement l'entrée est protégée mais il ne faut pas insister et changer de switch.

donc attention car beaucoup de support fin de filament de thingiverse utilisent des switch NO+NC

bon print

Partager ce message


Lien à poster
Partager sur d’autres sites

 @Bosco2509, le message au dessus s'adresse à toi.

 

🙂

Modifié (le) par Yo'

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Yo' a dit :

 @Bosco2509, le message au dessus s'adresse à toi.

 

🙂

Cela m'est adressé ?!
Désolé je peine à comprendre...

Je suis censé faire quoi au juste ?

Mon détecteur de fin de filament... c'est celui-ci : https://www.grossiste3d.com/capteurs-proximite-fin-de-course/877-detecteur-fin-de-filament-175mm.html

J'ai pas à m'en plaindre... il est branché sur la CM dans le boitier de contrôle...

 

Il y a 3 heures, astromedoc33.5@gmail.com a dit :

Bonjour

juste une info pour Bosco2509 

je viens de remplacer la carte mère et l'afficheur de ma CR-10 pour upgrade vers CR-10s  (CM v2.1)

avant j'utilisais un Raspberry pour la détection de fin de filament avec le support  https://www.thingiverse.com/thing:2513373

mais le switch utilisé n'est pas compatible avec la nouvelle carte . Pour le montage avec raspberry il s'agit d'un inverseur NO+NC

mais avec la nouvelle carte c'est un NO+voyant donc ce n'est pas le même cablage.

avec le NO+NC le switch génère un cour circuit et l'afficheur s'eteint lorsqu'il n'y a pas de filament . heureusement l'entrée est protégée mais il ne faut pas insister et changer de switch.

donc attention car beaucoup de support fin de filament de thingiverse utilisent des switch NO+NC

bon print

Ok... cela j'ai compris... c'est exactement ce qu'il se passe quand il n'y a plus de filament...
L'écran du boitier s'éteint...
La communication entre Raspberry et le boitier est interrompût...

Donc... si je comprend bien... c'est le détecteur de fin de filament qui ne serait pas compatible... est susceptible de provoqué un court circuit ?
OK soit... je comprend que je doit "IMPERATIVEMENT" le changer... si c'est le cas...
OK... mais... dans cette jungle... c'est lequel qu'il faut ?

En faisant un rapide tour... je suis tombé 5 fois sur le même que j'ai... faudrait préciser lequel il faut... merci.

Edit :

C'est bon !
Après une recherche, j'ai trouvé une âme charitable qui m'a donné un lien pour un détecteur de filament correct.

Modifié (le) par Bosco2509

Partager ce message


Lien à poster
Partager sur d’autres sites

Eh bien... on est pas au bout de voir des CM grillés si le détecteur de fin de filament peut provoquer cela.

En faisant un rapide tour sur Youtube, hier soir... beaucoup de possesseurs de CR-10(S), ont justement le même modèle de détecteur de fin de filament, comme le mien...
Et dans la plupart des vidéso... cela cela provoque un arrêt de l'imprimante (écran noir + CM déconnecté)...

Et... accessoirement les boutiques/vendeurs proposant ce détecteur de filament (en indiquant comme compatible)... il serait prudent de les retirer de la vente...
Bref... c'est pas mes oignons.

PS : Au vue du prix de ce capteur de fin de filament... ma CR-10S restera sans pendant un moment... c'est plus de 6x plus chères que les autres (2,38€ au moins chère pour 12,40€ pour le modèle adéquate)... LOL... chercher l'erreur !

Partager ce message


Lien à poster
Partager sur d’autres sites

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×