Aller au contenu

Filament ABS

Antho.breizh

Besoin d'aide avec mon g-code

Messages recommandés

Salut a tous et merci pour votre aide.

 

Imprimante Mendel Prusa I2 avec arduino et ramps 1.4 sous Marlin et logiciel simplify 3D 2.2.

 

Je débute dans le monde de la 3D et je me heurte un problème de g-code.

Simply3D me permet de faire des scripts pour garer mon plateau et ma tête d'impression dans une position donnée a la fin de l'impression.

Voici le code :

M104 S0 ; turn off extruder

M140 S0 ; turn off bed

G28 X0 Y0 ; home X and Y axis home

M84 ; disable motors

 

Dans ce cas mon X et mon Y retourne au point zéro la pas de problème mais j'aimerai que mon Z monte au max de la zone d'impression j'ai essayer divers chose mais je n'ai pas encore trouver comment faire ....  C'est surement pas grand chose a faire mais je sèche ...

Merci de votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est risqué mais ceci devrait fonctionner (avant M84) :

G90 ;pour passer en possition absolue

G0 Z[valeur souhaitée] ;pour remonter la buse

Les risques :

- Le Z que tu paramètres est trop haut => badaboom direct ou au prochaine démarrage si il y a une commande pour remonter la buse histoire de pas chauffer en contact avec un buildtak ou autre. Garde une marge.

- Si la marge est trop importante, et si tu fais une impression qui prend tout le volume, il y a un risque de heurter l'objet car le Z indiqué est peut être plus bas que le sommet de ton objet.

- Vérifie qu'il n'y a pas de G92 Z... avant cette ligne sauf au début pour compenser un offset Z => l'origine Z est modifiée et le Z indiqué bien trop haut, badaboom

Bref à utiliser que si tu sais ce que tu fais.

Modifié (le) par Tircown

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse

Je comprend bien le risque de venir taper l'objet lors de la remonter mais si je me met au max je limite ce risque.

Lors de la préchauffe de l'extrudeur mon Z reste ou il a été arrêter lors de la dernière impression donc dans mon cas tout en haut, puis une fois le plateau et l'extrudeur en température  tous les axes passe par leur home afin de lancer l'impression ... Enfin c'est ce que c'est censé faire .

 

Je test cela et merci . Bon dimanche.

Partager ce message


Lien à poster
Partager sur d’autres sites

Sa marche nickel ... enfin presque

J'aimerai juste savoir si on pouvais d'abord faire monter le Z puis le X et Y en home.

Car actuellement il faut d'abord mettre x et y en home avant de faire monter Z. J'ai essayer de placer le G90 et G0 avant G28 mais les lignes ne sont pas prise en compte ...

Va falloir que je comprenne la logique du g-code ....

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Essaie de placer la commande du Z avant celle du X et du Y dans le gcode. Sinon dans le marlin il faut modifier une ligne qui rend impossible le déplacement du Z tant que le X et le Y ne sont pas en position home. À voir...

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

c'est ce que j'ai fait :

M104 S0 ; turn off extruder

M140 S0 ; turn off bed

G90

G0 Z82 ; z en haut

G28 X0 Y0 ; home X and Y axis home

M84 ; disable motors

 

Mais cela ne marche pas dans cet ordre .... X Y en home mais Z reste en position ....

 

La ça fonctionne :

 

M104 S0 ; turn off extruder

M140 S0 ; turn off bed

G28 X0 Y0 ; home X and Y axis home

G90

G0 Z82 ; z en haut

M84 ; disable motors

 

Je vais regarder dans Marlin c'est ce que je pensai ...

 

Modifié (le) par Antho.breizh
correction ortho

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×