Aller au contenu

Filament ABS

J-Philippe

[Résolu] Geetech I3 Connexion Repetier Host

Messages recommandés

Salut à tous,

Je viens de changer de pc (sous linux mint comme l'ancien) et je réinstalle mes programmes dont Repetier Host (en appimage comme l'ancien). RH fonctionne normalement pour tout ce qui est création et création de gcode. Mais je n'arrive pas à le connecter à La Geetech I3.

Le connecteur étant sur "Connexion série" (comme sur l'ancien pc), j'ai branché le câble usb (essayé sur un usb2 et sur un usb3) et, dans la liste des ports du "réglage imprimante", j'ai vu apparaître deux nouveaux ports après la branchement :

- /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_ANZ20BY6-if00-port0 (que je n'avais pas sur mon ancien pc)
et
-/dev/ttyUSB0 (que j'avais sur l'ancien)

Sur l'ancien pc ça passait (et ça passe toujours, j'ai vérifié) en /dev/ttyUSB0

Mais là, rien à faire. J'ai beau cliquer sur l'icône Connexion de RH, rien à faire, pas de connexion.

Bien entendu j'ai essayé chacun des deux ports détectés. Pour le reste des réglages je suis en vitesse 250000 et protocole Autodectect

Une  idée ?

Modifié (le) par J-Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je n'ai ni une Prusa ni Linux Mint, mais cela me parait être une question de droit sur le device.

Tu tapes ls -l /dev/ttyUSB0 et tu relèves le groupe du device.

Puis tu vérifies que ton utilisateur est déclaré dans ce groupe par la commande : id USER (USER étant le compte avec lequel tu te connectes)

Si le groupe n'est pas dans la liste, tu tapes (par sudo ou étant root) : chmod -a -G GROUP USER (GROUP étant le nom du groupe relevé plus haut)

Si le groupe est dans la liste, il faudra rechercher dans les logs.

JM

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 9 minutes, jmarie3D a dit :

Bonjour,

Je n'ai ni une Prusa ni Linux Mint, mais cela me parait être une question de droit sur le device.

Tu tapes ls -l /dev/ttyUSB0 et tu relèves le groupe du device.

Puis tu vérifies que ton utilisateur est déclaré dans ce groupe par la commande : id USER (USER étant le compte avec lequel tu te connectes)

Si le groupe n'est pas dans la liste, tu tapes (par sudo ou étant root) : chmod -a -G GROUP USER (GROUP étant le nom du groupe relevé plus haut)

Si le groupe est dans la liste, il faudra rechercher dans les logs.

JM

Salut Jean-Marie,

Merci de me répondre. Je ne suis pas trop à l'aise avec tout ça. Je suis preneur de tes conseils pour la suite.

Déjà, tu dois avoir raison sur l'origine du problème vu que, de base, ttyUSB0 n'existe pas dans /dev  !

J'ai donc créé le fichier/device mais là, ce que je comprends, c'est qu'il est dans le groupe root.

srk@srk-fanless:~$ ls -l /dev/ttyUSB0
-rw-r--r-- 1 root root 0 juil. 10 11:10 /dev/ttyUSB0
srk@srk-fanless:~$

Pour le user ça donne ça :

srk@srk-fanless:~$ id srk
uid=1000(srk) gid=1000(srk) groupes=1000(srk),4(adm),7(lp),24(cdrom),27(sudo),30(dip),46(plugdev),115(lpadmin),128(sambashare)
srk@srk-fanless:~$ A

Faut-il que je fasse un chmod -a -G root srk ?

Partager ce message


Lien à poster
Partager sur d’autres sites

En étant connecté avec ton compte srk, tu tapes sudo chmod -a -G root srk

Puis tu te déconnectes et reconnectes pour prendre en compte la modification

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, alors là je deviens dingue !?

srk@srk-fanless:~$ su do chmod -a -G root srk

La commande « su do » n'a pas été trouvée, voulez-vous dire :

  commande « sudo » du deb sudo
  commande « sudo » du deb sudo-ldap

Essayez : sudo apt install <nom du deb>

srk@srk-fanless:~$ sudo chmod -a -G root srk

La commande « sudo » n'a pas été trouvée, voulez-vous dire :

  commande « sudo » du deb sudo
  commande « sudo » du deb sudo-ldap

Essayez : sudo apt install <nom du deb>

srk@srk-fanless:~$ 

Et pourtant sudo est bien installé, je m'en suis servi il y a une heure pour autre chose ...

et
srk@srk-fanless:~$ sudo nano /home/srk/test.txt
fonctionne.

Modifié (le) par J-Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, J-Philippe a dit :

 

srk@srk-fanless:~$ su do chmod -a -G root srk

La commande « su do » n'a pas été trouvée, voulez-vous dire :

 

D'où vient l'espace entre su et do ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut j'utilise une Debian pour contrôler ma Geeetech. je confirme l'elevation de droit nécessaire

 

sudo usermod -aG dialout utilisateur

Remplacer "utilisateur" par le tiens ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Euh, quel espace ? C'est ce que je disais. Je deviens dingue. Je n'ai pas vu d'espace. Mais  pour le coup je viens de rebooter, et de retaper  et ça donne

srk@srk-fanless:~$ sudo chmod -a -G root srk
chmod : option invalide -- 'G'
Saisissez « chmod --help » pour plus d'informations.
srk@srk-fanless:~$

srk@srk-fanless:~$ sudo chmod -a -G root srk
chmod : option invalide -- 'G'
Saisissez « chmod --help » pour plus d'informations.
srk@srk-fanless:~$ 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 14 minutes, hidius a dit :

Salut j'utilise une Debian pour contrôler ma Geeetech. je confirme l'elevation de droit nécessaire

 


sudo usermod -aG dialout utilisateur

Remplacer "utilisateur" par le tiens 😉

Merci hidius (et Jean-MArie). J'ai fait ça. Pas d'erreur à l'exécution.

Pour l'instant je suis coincé, j'ai une impression en cours et je ne veux pas rebrancher la Geeetech avant la fin (j'ai testé, elle aime pas ça... et moi non plus pour le coup 😉 . Mais je viens de voir que le fichier /dev/ttyUSB0 que j'avais créé a disparu. Je pense qu'il n’apparaît que si l'imprimant est connectée. Je verrai ça quand je pourrai la brancher.

Modifié (le) par J-Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu as tapé la commande donnée par hidius, ce ne sera pas bon parce que ton device appartient au groupe root pas dialout.

En effet, le noyau crée le fichier device lors de la connexion du matériel et lui attribue les droits en fonction des règles udev qui sont différentes d'une distribution à l'autre :

dialout sur Debian, uucp sur Archlinux. Ça me semble bizarre que ça soit root sur Mint. Tu devrais te renseigner sur un groupe de discussion spécialisé sur Linux Mint, parce que, là, ça n'a plus rien à voir avec l'impression 3D.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, jmarie3D a dit :

Si tu as tapé la commande donnée par hidius, ce ne sera pas bon parce que ton device appartient au groupe root pas dialout.

En effet, le noyau crée le fichier device lors de la connexion du matériel et lui attribue les droits en fonction des règles udev qui sont différentes d'une distribution à l'autre :

dialout sur Debian, uucp sur Archlinux. Ça me semble bizarre que ça soit root sur Mint. Tu devrais te renseigner sur un groupe de discussion spécialisé sur Linux Mint, parce que, là, ça n'a plus rien à voir avec l'impression 3D.

C'est vrai que c'est plus un problème linux (mint/ubuntu) que 3d. Mais si c'est juste un problème de droits (de toute façon 90% de soucis que j'ai avec linux, c'est une histoire de droits 😉 ), ca ne devrait pas être si sorcier à régler.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je sais, je devais aller sur un forum ubuntu/mint mais je touche presque au but... ! Pitié !

En regardant les différents tty de /dev j'ai remarqué qu'ils sont tous dans le groupe dialout. J'ai donc remplacé dialout par srk (mon user) sur ttyUSB0 et là nickel. Connexion instantanée.

Par contre en débranchant le cable de l'imprimante et en le rebranchant je retombe sur group:dialout. La connexion n'est pas persistante. Donc, je ne vois que deux solutions :
- garder la connexion au débranchement (mais je ne sais pas comment rendre ttyUSB0 persistant)
- ajouter srk au groupe dialout (et je ne sais pas comment faire)

A moins qu'il y ait une troisième solution. A votre avis ?

Edit : réponse

Bon, allez je me réponds en espérant que ça serve si quelqu'un a le même problème. En fin de compte , j'ai créé un fichier /etc/udev/rules.d/10-usbserial dans lequel j'ai mis : KERNEL=="ttyUSB0", GROUP="dialout", MODE="0666"

Puis on relance la lecture des règles sudo udevadm control --reload-rules

Et hop, les permissions sont pour tout le monde. Ce n'est peut-être pas top niveau sécurité mais comme c'est un poste chez moi, je maitrise le risque de brancher un périphérique en ttyUSB0 😉

J'ajoute pour être réglo que j'ai piqué l'idée ici : https://www.ciscomadesimple.be/2013/08/28/acces-refuse-a-devttyusb0-sous-linux-mint-ubuntu/

Modifié (le) par J-Philippe
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×