Aller au contenu

Filament ABS

AlexPRC

Probleme televersement Marlin

Messages recommandés

Bonjour,

J'ai un petit soucis avec ma dagoma discoeasy 200 en ce moment: j'ai installer récemment des tiges trapezoidales au pas de 2. J'essaye donc de flasher le firmware avec Arduino, pour avec un step per unit de 400. J'ai donc télécharger les fichiers sources sur dagoma, branche mon imprimante à mon PC, configure Arduino avec la carte "Arduino Mega or Mega2560 ainsi que le processeur "Mega2560". Le port de l'imprimante se met en COM3 et je compile et televerse ensuite. Tout ce passe sans accroc, mais une fois que je lance l'impression, le step per unit n'as pas changé...

Est ce que quelqu'un à une idée d’où cela pourrait provenir ? Merci d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello

1) Tout d'abord, es-tu bien sûr de ne pas confondre "pitch" et "pas" ??

Le "pitch" c'est la distance entre deux filets. 2mm, pourquoi pas...

Le "pas" c'est la distance que parcourt le mobile entraîné quand la vis fait un tour (souvent 8mm)

Sur les tiges trapézoïdales, il y a souvent plusieurs filets, on voit plusieurs entrées quand on regarde la vis en bout.

2) sur ces cartes, quand le téléversement est terminé, il faut en plus faire, via le LCD, "restaurer défauts" et "initialiser EEPROM (après avoir débranché le câble USB pour que tout soit bien résetté)

Essaye ça, et viens nous dire quoi

Modifié (le) par Jean-Claude Garnier

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse

Je pense que j'ai en effet confondu pitch et pas. Le pas est bien de 8mm. J'ai essayé avec le marlin de dagoma proposé par dagoma pour les tiges trapezoidales avec un step per unit de 800 et j'obtient des pièce deux fois trop haute en Z dois-je en déduire qu'il faut abaisser cette valeur?

Est-ce que cette manipulation est possible sans écran LCD ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Ahah non je ne lui est pas mis d'écran, je n'en voyais pas une tres grande utilité, mais si je suis obligé d'en avoir un pour faire ce genre de manip alors je passerai par la case écran.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pris d'un doute, je suis allé voir : en effet, pas d'écran sur cette machine, au temps pour moi....

Mais alors comment vous faites pour les réglages, toussa toussa ???

Ça se passe tout par la connexion USB ?

Dans ce cas, faudrait demander à @hidius, y connaît ptêt' un code G ou un code M qui ferait la même chose que "restaurer défauts"....

Modifié (le) par Jean-Claude Garnier

Partager ce message


Lien à poster
Partager sur d’autres sites

Il est possible d'installer un écran en option, mais sinon oui on peut régler via USB. Avec les pistes que tu m'as donné j'ai regardé dans l'application qui permet les réglages et j'ai restaurer la machine avant d'envoyer le firmwares et il semblerait que ça marche. Je vais imprimer une petite pièce test et je reviens ici pour dire si ça a bien fonctionné.

Merci encore

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai eu le même problème, il suffit de connecter l'imprimante à Pronterface puis de rentrer ces deux commandes :

  • M92 Z400 pour changer la valeur du Zpas/mm (même si il faut aussi l'avoir changer dans le firmware)
  • M500 pour sauvegarder les modifications

Modifié (le) par ServNer

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×