Aller au contenu

Filament ABS

garcmi

capteur Reprap france

Messages recommandés

Bonjour,

quelqu'un pourrai m'aider pour le montage d'un capteur capacitif  de chez Reprap france avec se carte d'interface pour une MKS Gen 2z compatible Ramp 1.4

Je suis une buse en électronique.

Merci

01d6d6c1d7da5130070936ff3833e7d.png

5e69a53511a106a4de6227e4c34efbad.jpg

hardware connect 1.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Bonjour

 

as tu une entrée 5V en plus de l'entrée 12 V ?

 

car ca serai mieux que tu branche l'entrée endstop du module sur une entrée 5v et ensuite tu réaffecte dans pin.h

sinon ton montage me semble correcte

 

cdlt

Modifié (le) par damdam2959

Partager ce message


Lien à poster
Partager sur d’autres sites

oui, j'ai une sortie 5v dispo (2 5v et 3 12v dispo sur la carte).

je peux aussi monter le palpeur en direct avec des résistance 10 et 15k comme ci dessous, mais j'aurais voulu utiliser cette carte.

capteur.jpg.617c6723c96dc8d1840e3efc0095

j'ai vu aussi que les capteur NPN NO (Normal Open) sur certains forums n'avaient pas besoin de résistances. Ils pouvaient êtres branchés sur 12v, ground et signal en direct.

je doute du coup

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

 

je te conseille donc de brancher ton entrée 12 v du module sur une entrée 12 v de ta carte électronique

entrée endstop du module sur une entrée 5 v de ta carte électronique

 

puis tu réaffecte le pin.h de firmwaire

le module évite justement le bricolage avec les résistances 

 

cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok, merci beaucoup,

je vais faire ça, j’espère que ça profitera à d'autres du coup.car cela doit marcher sur toutes les cartes.

Reste à trouver comment on réaffecte le pin.h mais je vais chercher.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 14 minutes, garcmi a dit :

Ok, merci beaucoup,

je vais faire ça, j’espère que ça profitera à d'autres du coup.car cela doit marcher sur toutes les cartes.

Reste à trouver comment on réaffecte le pin.h mais je vais chercher.

Bonjour

 

c'est très bien de chercher par toi même c'est comme ca qu'on apprends et qu'on se passionne pour l'impression 3D

 

mais si vraiment tu ne trouve dis le moi

 

cdlt

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

je confirme le montage ci dessus

le capteur fonctionne correctement et stoppe le z ou il faut (après calibration)

En le montant sur le endstop Z complet (5v, signal et ground), pas de réaffectation des pins.h (resté en 18 pour moi)

reste plus qu'à régler le marlin pour qu'il fasse un auto level à chaque impression (j'ai du boulot, c'est mon premier marlin, je comprend rien encore et il y a tellement de choses différentes sur le net...)

il est vrai que ça fait plus fiable que 2 résistances et une fois bien branché, pas de risques.

ce montage doit marcher pour toutes les cartes je pense

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 6/1/2016 at 15:09, damdam2959 a dit :
Le 6/1/2016 at 15:09, damdam2959 a dit :

Bonjour

 

c'est très bien de chercher par toi même c'est comme ca qu'on apprends et qu'on se passionne pour l'impression 3D

 

mais si vraiment tu ne trouve dis le moi

 

cdlt

Bonjour

 

c'est très bien de chercher par toi même c'est comme ca qu'on apprends et qu'on se passionne pour l'impression 3D

 

mais si vraiment tu ne trouve dis le moi

 

cdlt

Salut,

j'ai un problème avec mon auto level,

ça marche bien quand je règle à la même hauteur (déclenchement et buse) mais su je met un décalage du palpeur (2mm plus haut), il fait l'auto level au déclenchement du capteur et pas après l'offset Z

j'ai passé le min endstop sur false et renseigné l'offset

 

#define min_software_endstops false // If true, axis won't move to coordinates less than HOME_POS.
#define max_software_endstops true  // If true, axis won't move to coordinates greater than the defined lengths below.

// these are the offsets to the probe relative to the extruder tip (Hotend - Probe)
  // X and Y offsets must be integers
  #define X_PROBE_OFFSET_FROM_EXTRUDER 50
  #define Y_PROBE_OFFSET_FROM_EXTRUDER 0
  #define Z_PROBE_OFFSET_FROM_EXTRUDER -2

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai réglé mon offset capteur / buse dans marlin mais la buse ne descend pas en dessous du déclenchement (en g28 et g29) du capteur, du coup, le home est trop haut.

ça me fait l'auto level trop haut

 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 5 minutes, damdam2959 a dit :

Bonjour 

 

je viens de changer ton config essaye et tiens moi au jus

 

cdlt

Configuration.h

idem, ça s'arrete au déclenchement du capteur et ça vas pas plus bas,

en plus, le g29 bloque au 3eme point (endstop hit z sur l'écran)

ça fait 5 jours que je suis dessus et je comprend pas

 

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour

 

au niveau de l'axe z quand tu le bouge en manuel il va dans le bon sens cad quand tu demande de monter il monte bien ?

 

cdlt

Partager ce message


Lien à poster
Partager sur d’autres sites

oui, tout vas bien sans l'auto level ou si je règle le capteur à la main avec déclenchement à la hauteur de buse bonne(feuille papier)

si je remonte le palpeur et que je renseigne l'offset z, il ne descend pas en dessous du déclenchement...

il y a 3 minutes, damdam2959 a dit :

bonjour

 

au niveau de l'axe z quand tu le bouge en manuel il va dans le bon sens cad quand tu demande de monter il monte bien ?

 

cdlt

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 37 minutes, garcmi a dit :

oui, tout vas bien sans l'auto level ou si je règle le capteur à la main avec déclenchement à la hauteur de buse bonne(feuille papier)

si je remonte le palpeur et que je renseigne l'offset z, il ne descend pas en dessous du déclenchement... tu veux dire qu'il ne descend pas en dessous du déclenchement quand tu lance le print ? ou juste quand tu fais le palpage car quand il fais le palpage c'est normal qu'il ne descend pas au delà du déclenchement du palpage 

 

Modifié (le) par damdam2959

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

 

tu utilise quoi pour gerer ton capteur ton module ou un pont de resistance et comment la tu brancher sur la carte 

 

cdlt

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×