Aller au contenu

Filament ABS

steph97

32 bits Aide endstop optique et capteur d'auto nivellement et MKS SBASE

Messages recommandés

Bonjour, je me suis lancer il y a quelques temps dans la fabrication d'une Hypercube Évolution 300x300x300.

Au niveau de la mécanique je m'en suis pas trop mal sortie, bien rigide, pas de point dur sur les axe et tout a niveau (enfin pour le moment juste le plateau chauffant qui est poser sur des petites vis avec des entretoises. En attendant des vis plus longues pour le mettre sur ressort plus écrou)

Par contre niveau électronique c'est la catastrophe; j'arrive a faire bouger mes axes manuellement et mes ventilo, mais sinon je suis totalement larguer sur toute les lignes du fichier config.

J'ai une MKS SBASE 1.3  + TFT3.2

config.txt

Pour le moment je n'ai pas le plateau chauffant  ni la buse brancher a la carte (c'est l'étape d'après).

Je suis complétement larguer sur les fins de courses et le capteur auto levelelling. Et j’avoue que je commence a avoir envie de tout balancer par le fenêtre, c'est assez frustrant de ne rien comprendre... . AU niveau des recherches j'ai l'impression de tourner en rond car je ne comprend rien. 

Capteur de nivellement

Endstop Optique

je ne sais pas quoi changer dans le fichier config dans le fichier config.

Si quelqu'un veut bien jeter un œil sur le fichier config cela m'aiderai peut être. Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : Si en mode manuel, tu arrives à déplacer tes axes, c'est déjà une bonne chose. Il serait peut être utile que tu nous indiques le logiciel utilisé pour piloter ton hypercube en mode manuel (repetier, pronterface ...). Je te conseille de procéder par étapes : endstop en premier, puis hotend ... et pour finir, ton auto level.

Pour vérifier le bon fonctionnement des endstop, il faut envoyer la commande M119 : opération à répéter pour vérifier l'état ouvert et fermé des capteurs.

Et un indispensable ...

2036969755_mkssbasepinout.jpg.cec7aa4ae01226ddf7c1d26064eaf0e7.jpg

Modifié (le) par cmatec

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Merci de ta réponse, désolé j'ai oublier de le préciser, j'ai installer smoothieware pris sur le site officiel.

J'utilise l'écran tactile pour piloté l'imprimante

Modifié (le) par steph97

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : Repetier host est assez pratique pour mettre au point son imprimante. Il permet entre autre d'envoyer des commandes g-code pour tester les différents éléments et fonctionne parfaitement avec la mks sbase.

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : Attention au câblage de tes endstop (vérifie la position des pin V et signal sur le capteur et sur la mks sbase)

Partager ce message


Lien à poster
Partager sur d’autres sites

@cmatec Oui je me suis rendu compte de cela et j'ai modifié l'emplacement des fils sur les connecteurs afin de faire correspondre s v g. Une fois la carte alimentée tout les endstop on une led rouge et lorsque je met un obstacle elle s'éteint.

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : 😉 Maintenant, il faut connaître l'état des endstop : M119 sous repetier en mode manuel.

Je ne connais pas les hypercube, mais je suppose que pour définir l'origine de ta machine, tu demandes un home to min sur les axes X et Y, et un home to max sur l'axe Z. Peux tu confirmer ? Si cela est le cas, tes endstop sont connectés sur X-, Y- et Z+ sur la mks sbase (cette info m'est indispensable pour modifier ton fichier de conf en conséquence)

Partager ce message


Lien à poster
Partager sur d’autres sites

@cmatec je n'ai pas encore installer repetier vu que je n'étais pas chez moi aujourd'hui, mais je cherche effectivement obtenir un home to min sur tout les axes. J'ai inversé l'axe Z pour que le Z- soit en haut et le Z+ en bas. Donc je souhaites que le le Z- soit au plus porche de la buse

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : peux tu stp détailler le nombre de endstop ?

D'après les infos que tu as donné :

# Endstops
endstops_enable                              true             # the endstop module is enabled by default and can be disabled here
corexy_homing                                true            # set to true if homing on a hbit or corexy
alpha_min_endstop                            1.24^!            # add a ! to invert if endstop is NO connected to ground
alpha_max_endstop                            nc            # NOTE set to nc if this is not installed WAS 1.25^
alpha_homing_direction                       home_to_min      # or set to home_to_max and set alpha_max
alpha_min                                    0                # this gets loaded after homing when home_to_min is set
alpha_max                                    300 # 295             # this gets loaded after homing when home_to_max is set
beta_min_endstop                             1.26^!            #
beta_max_endstop                             nc            #
beta_homing_direction                        home_to_min     #
beta_min                                     0                #
beta_max                                     300 # 295              #
gamma_min_endstop                            1.28^!            #
gamma_max_endstop                            nc            # was 1-29^
gamma_homing_direction                       home_to_min      #
gamma_min                                    0                #
gamma_max                                    300 # 250              #

En fonction du résultat de la commande M119 il te faudra peut être retirer le(s) "!" sur les pins alpha, beta, gamma_min

Les valeurs alpha beta gamma_max sont à ajuster à ta machine : elles correspondent aux déplacements maximums autorisés.

Modifié (le) par cmatec

Partager ce message


Lien à poster
Partager sur d’autres sites

@cmatec J'ai placé 4 endstops x-, x+, y-, y+

Je tape la commande M119 sur Repetier Host et j'ai ça

X_min: 0  Y_min: 0  pins-  (x) P1.24: 0  (y) P1.26: 0    Probe: 0

Comment interpréter cette ligne ??

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : seuls les endstop x_min et y_min sont activés dans ton config. Connecte un endstop sur le z_min (celui qui va régler ta hauteur de première couche). Pour vérifier le bon fonctionnement, obture tes capteurs optiques et renvoie un M119. L'état doit passer à 1.

Les capteurs X+, Y+et Z+ risquent de te mettre le bazar : alpha, beta, gamma_limit_enable   true  sont activés sur les endstop max et min. Passe ces 3 lignes en "false".Les spécialistes tels que @lion02 pourront certainement être plus précis.

Modifié (le) par cmatec

Partager ce message


Lien à poster
Partager sur d’autres sites

J'iai lancé la commande en X- et Y- et j'ai aussi mis "!" sur le pin 1.24

Maintenant j'ai ça:

X_min: 1  Y_min: 1 pins -   (x) P1.24: 1  (y) P1.26: 1    Probe: 0

Partager ce message


Lien à poster
Partager sur d’autres sites

@steph97 : ok, ça roule pour les endstop X- et Y-. Connecte ton Z-  et procède de même. Une fois tes endstop x_min, y_min et z_min opérationnels, sous repetier, il va falloir que tu vérifies le sens de déplacement de tes axes x, y et z. Si le sens est inversé sur un des axes, il faut ajouter un "!"  dans la section stepper module pins

alpha_dir_pin                               0.5  # ! pour inverser le sens

beta_dir_pin                                 0.11 # ! pour inverser le sens

gamma_dir_pin                          0.20 # ! pour inverser le sens

Une fois cela fait, tu peux demander un home sur chaque axe sous repetier (home X, home Y, home Z). Il est conseillé de mettre chaque axe en milieu de course au cas où quelque chose ne se passe pas comme prévu ... arrêt d'urgence à prévoir

Modifié (le) par cmatec

Partager ce message


Lien à poster
Partager sur d’autres sites

idem pour le(s) moteurs d'extrudeur(s)

Modifié (le) par cmatec

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, suites aux divers manipulations que j'ai pu faire et aux difficultés rencontré, je me suis rendu compte que le port 1.24 ne fonctionne pas correctement. Le passage a 1 de hier soir était du au "!" plus de la fatigue de ma part. Je t'ai fais un mauvais retour d'information @cmatec.

Donc Aujourd'hui j'ai remplacé le port 1.24  par 1.25  dans le fichier config et mis le cordon de l'endstop x- sur le port x+ de la carte.

le homing sur les 3 axe se fait correctement. X puis Y puis Z

J'ai aussi monter mon plateau chauffant correctement car j'ai reçu les bonnes vis.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×