Aller au contenu

Filament ABS

Rioma

Décalage de l'axe Z en autoveling

Messages recommandés

Bonjour

J'ai installé un capteur capacitif et activé sur Marlin la fonction de sondage de trois points sur le plateau.

Le dispositif marche correctement mais en fonction "Home all" ou "Home Z" la buse trouve sa position et continue vers une position de repos pour finir sa course à un cm du plateau. Ce qui ne me permet pas de chercher la valeur correcte du décalage en faisant les manipulations sur Pronterface.

Ceci ne me permet pas de connaître le décalage entre le Home Z défini et le Home Z idéal. Dans ces conditions, je peux imprimer mais le réglage reste grossier et je pense qu'il faut approcher la buse de quelques 0,5 mm.

Or je décide de procéder par tâtonnements sur l'interface de l'imprimante, mais quand je veut modifier le décalage, même de 0,5, le message m'indique "To far"

Merci de vos avis

ML

Modifié (le) par mariolitwin

Partager ce message


Lien à poster
Partager sur d’autres sites

Modération : @mariolitwin j'ai déplacé ton post vers la rubrique Anet pour une meilleure visibilité

Partager ce message


Lien à poster
Partager sur d’autres sites

Pourquoi seulement 3 points de palpage ? 

Sur une surface rectangulaire j'en aurai mis au minimum 5, 9 serait parfait de mon point de vue.

Partager ce message


Lien à poster
Partager sur d’autres sites

bon déjà, assures toi d'avoir activé le safe homing dans marlin.

Ensuite pour mettre ta buse au centre du plateau, tapes la ligne G1 X110 Y110 juste après le G28.

Si à ce moment elle ne se met pas au centre du plateau ou si après le G28 ce n'est pas le capteur qui est au-dessus du centre du plateau, c'est que tes offsets X et Y sont à revoir.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Andréa a dit :

Pourquoi seulement 3 points de palpage ? 

Sur une surface rectangulaire j'en aurai mis au minimum 5, 9 serait parfait de mon point de vue.

En effet, ce serait l'idéal, mais d'un côté je n'ai pas encore les connaissances pour faire plus de trois points (il y a une instruction déjà prête sur Marlin) et d'un autre côté, compte tenu qu'à priori mon plateau est plat, je pense que trois points suffissent.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Maeke a dit :

bon déjà, assures toi d'avoir activé le safe homing dans marlin.

Ensuite pour mettre ta buse au centre du plateau, tapes la ligne G1 X110 Y110 juste après le G28.

Si à ce moment elle ne se met pas au centre du plateau ou si après le G28 ce n'est pas le capteur qui est au-dessus du centre du plateau, c'est que tes offsets X et Y sont à revoir.

Le safe homing est actif sur Marlin. La buse va au centre pour chercher le home Z. Au fait c'est le capteur qui va au centre, je m'occuperait du décalage X,Y plus tard quand mon problème de decalage Z sera resolu.

Merci à vous tous pour vos conseils

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, pascal_lb a dit :

Modération : @mariolitwin j'ai déplacé ton post vers la rubrique Anet pour une meilleure visibilité

Je n'arrive toujours pas à trouver le bon endroit pour poster.

Modifié (le) par mariolitwin

Partager ce message


Lien à poster
Partager sur d’autres sites

Est-ce qu mon post initial est clair ?

Je n'arrive pas à indiquer sur l'interface de l'imprimante le décalage Z. Ça me donne le message "To far"

Peut être je pourrais le faire sur le start.gcode ? Quelle serait l'instruction ?

C'est peut-être ça ?

Citation

On peut exécuter à la main :


M206 Z-0.2; Ajuste le Z offset - en mémoire seulement, perdu après reboot
M500; Sauve les paramètres en EEPROM
Modifié (le) par mariolitwin
Completer message

Partager ce message


Lien à poster
Partager sur d’autres sites

nan

la séquence que je conseille pour le décalage Z c'est

M851 Z0; mets le décalage Z à 0
M500; enregistre le changement en eprom
G28; home all
G1 X110 Y110; place la buse au dessus du milieu pour un plateau 220*220

là tu descend la buse jusqu'à pouvoir glisser uniquement une feuille de papier A4 entre le plateau et la buse.

puis tu lis la valeur Z sur le lcd de l'imprimante 3d.

puis:

M851 Z(valeur lue); indique le nouveau décalage Z
M500; enregistre en eprom
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Parfait ! Merci ! Je vais essayer ça.

La seule chose qui me turlupine est qu'après le Home all, la buse se relève. Donc, les mesures que je peux faire en descendant la buse seront faussées.

Je pense que je vais tâtonner par pas de 0.1 mm à partir de la position actuelle qui me donne une impression correcte mais avec une première couche un peu gonflée.

Sinon, je vais chercher quelle est l'instruction qui relève la buse et agir en conséquence.

Modifié (le) par mariolitwin

Partager ce message


Lien à poster
Partager sur d’autres sites

Il suffit de faire un G1 Z0 via la console pour que ta buse redescende.

Envoyé de mon Redmi Note 4 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

la buse qui se relève c'est normal, ça n'empêche pas d'avoir la valeur Z correcte.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci à Maeke et à mikebzh44 pour vos conseils.

Ça marche à merveille et c'est un plaisir de ne pas à régler le plateau régulièrement.

Maintenant je me suis mis à imprimer du nylon et j'ai un problème d'emballement thermique et d'erreur de chauffage (qui apparemment c'est le même), mais avant de vous déranger je me suis documenté partout et je crois avoir trouvé le problème.

A bientôt

ML

 

Partager ce message


Lien à poster
Partager sur d’autres sites

avec le petg, baisses la ventilation sur les premières couches, et vérifies que le bec de ventilation ne souffle pas sur la buse, le bloc ou le plateau.

Et fais un pid autotune pour atténuer les variations de température.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca si le ventilo refroidit la hotend, elle n'arrivera pas à sa consigne de T° (ou trop lentement) et Marlin se mettra en sécurité car il va voir que ça prend trop de temps.

Partager ce message


Lien à poster
Partager sur d’autres sites

emballement est une mauvaise traduction ici, en fait l'erreur peut arriver si la température est trop élevée, pas assez élevée, voire trop lente ou trop rapide à monter.

Bref si à un instant T la température ne correspond pas à la fourchette estimée dans le firmware, tu auras une erreur emballement thermique.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu m'as porté la poisse, j'ai eu un emballement thermique.....

PS en anglais c'est marqué "thermal runaway" si tu regardes dans un dico tu verras que emballement, c'est pas la même chose que runaway.

une meilleure traduction serait perte de contrôle.

 

EDIT: ARRGHHH rebelote! le ventilo était à fond.....

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 58 minutes, Maeke a dit :

Tu m'as porté la poisse, j'ai eu un emballement thermique.....

Je suis désolé, j'aurais dû porter un masque. Je ne savais pas que c'était contagieux.
Peut être on peut faire baisser la température en mettant du Doliprane dans le filament

Modifié (le) par mariolitwin
  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×