Aller au contenu

Filament ABS

flo0014

32 bits Configuration mks sbase sur une Anet a8

Messages recommandés

Bonjour à tous, 

Je me permets de vous de poster un petit message pour solliciter votre aide. 

Après avoir grillé la un driver sur la carte d'origine de mon Anet,  je me suis décidé à acheter une mks sbase + tf32. 

Au niveau de la config tout ce passe à la peu près de bien (grâce au différents topics parcourus sur ce forum qui mon été vraiment utiles, merci à vous tous en passant), sauf deux points, je m'explique:

- Mes fichiers gcode n'apparaissent dans le menu print que si je les mets dans la carte sd du tf32. Dans la sd de la mks, je n'ai aucun fichier apparent. 

- second point, plus embêtant, plus lorsque je lance une impression, celle-ci démarre la où je suis ce trouve la buse sans faire de home au préalable. Je me dis que peu être le début et fin de gcode que j'utilisais jusqu'ici ne sont peut-être pas compatible avec smoothieboard:

Début :

G21 ;
G90 ;
M82 ;
M107 ;
G28 X0 Y0 ;
G28 Z0 ;
G29
G0 X0 Y15 F9000 ;
G0 Z0.15 ;
G92 E0 ;
G1 X60 E10 F500 ;
G92 E0 ;
G1 E-1 F500 ;
G1 X100 F4000 ;
G1 Z0.3 ;
M117 Impression...

FIN:

S0 ;
M140 S0 ;
G91 ;
G1 E-1 F300 ;
G1 Z+0.5 E-5 X-20 Y-20 F9000 ;
G28 X0 Y0 ;
G90 ;
G1 Y190 F9000 ;
M84 ;

N'étant, pas devant mon pc, je posterais aussi mon config.txt demain.

En tout cas merci à vous tous ceux qui ont posté le avant car cela m'a fait plaisir vraiment été de utiles. 😉

Bonne soirée et à très bientôt tous. 

Edit : Au niveau du fichier il me semble que je ne soit pas trop mal. Par contre, demeurre le problême (je pense de gcode ) pour centrer le début d'impression au milleu du plateau. et de lecture des fichiers depuis la sd de la sbase.

config.txt

Modifié (le) par flo0014

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant
Il y a 13 heures, flo0014 a dit :

Mes fichiers gcode n'apparaissent dans le menu print que si je les mets dans la carte sd du tf32. Dans la sd de la mks, je n'ai aucun fichier apparent.

ça c'est normal avec l'écran tft 3.2 tu ne peux pas voir le contenu de la micro SD de la carte

Il y a 13 heures, flo0014 a dit :

second point, plus embêtant, plus lorsque je lance une impression, celle-ci démarre la où je suis ce trouve la buse sans faire de home au préalable

ça c'est étrange car tu as bien

G28 X0 Y0 ;
G28 Z0 ;

tu as quoi comme trancheur ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, @flo0014

Pour une Anet ces lignes dans le config sont étranges.

alpha_steps_per_mm          160        #Pas / mm pour le stepper alpha (X) et la tour
beta_steps_per_mm            160        #Pas / mm pour le stepper bêta (Y) et la tour
gamma_steps_per_mm     160        #Pas / mm pour le stepper gamma (Z) et la tour

elles correspondent à une imprimante delta, pour une imprimante cartésienne on devrait plutôt trouver

alpha_steps_per_mm           80               # Steps per mm for alpha ( X ) stepper
beta_steps_per_mm             80                # Steps per mm for beta ( Y ) stepper
gamma_steps_per_mm      1600            # Steps per mm for gamma ( Z ) stepper

(Les valeurs  80, 80, 1600 sont à modifier en fonction de ton imprimante.)

édit :

ces lignes aussi posent problème :

z_axis_max_speed        30000        # Vitesse maxi en mm/min

gamma_max_rate        30000.0            # Limite de vitesse gamma (Z) en  mm/min

on devrait plutôt trouver :

z_axis_max_speed    300        # Maximum speed in mm/min
gamma_max_rate     300.0    # Maximum rate in mm/min

Le fichier que tu as utilisé comme modèle ne doit pas être le bon, regarde cet exemple

Modifié (le) par trotro

Partager ce message


Lien à poster
Partager sur d’autres sites

d'où l'importance de ne pas reprendre de fichier config d'une autre machine et de se faire son propre fichier...

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement, le fichier d'exemple et que j'ai un pris au départ n'était pas bon. 

J'ai tout refais à partir du bon fichier et c'est beaucoup mieux. J'ai calculé les pas/mm pour xyz, je suis bien. 

Il me reste à faire de même pour l'extrudeur et réussir à centrer mon impression au milieu du plateau dans le slicer.

Merci beaucoup pour vos conseils @trotro et @pascal_lb

Modifié (le) par flo0014

Partager ce message


Lien à poster
Partager sur d’autres sites

Tout est résolu et si ça peut aider, pour centrer l'impression, après plusieurs essais,  j'ai rajouté à la fin de mon "start Gcode": 

G92 X-35 Y-20 

A adapter en fonction de sa machine.

Merci pour le coup de main👍👍👍

Ps: fontionne sous Cura et Slic3r

Modifié (le) par flo0014

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @palouf34,

Oui, je vois une différence l'impression est plus précise (on voit moins les couches). Surtout c'est beaucoup plus fluide moins de sacades durant l'impression, ce qui se voit sur le résultat final.

Et c'est peu être moi mais je trouve que le bruit des moteurs a diminué....

Et mis à part tout ça, la configuration dans un simple fichier c'est quand même carrément pratique👍

Modifié (le) par flo0014
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Et encore si cela peu aider quelqu'un, les moteurs chauffent beaucoup, j'ai une impression en cours mais je pense passer les valeurs de 1.3 actuellement à 0.9 qui semble être la valeur maxi pour les moteurs de la anet a8.

Je test demain...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 7 minutes, flo0014 a dit :

actuellement à 0.9

le principal c'est que tes moteurs ne perdent pas de pas, après si tes moteurs reste dans les 40 / 55° c'est normal... 

Partager ce message


Lien à poster
Partager sur d’autres sites

A 1.3 je ne pouvais pas toucher le moteur tellement il était chaud. A 0.9 il se contente d'être tiède et je ne perd pas de pas apparemment.

Il ne me reste plus qu'à dessiner le boitier qui va acceuillir tout ça proprement, et le tour est joué.😁

Je posterais le lien vers thingiverse, si quelqu'un est intéressé.

En tout cas merci encore.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je suis également intéressé par cette carte mais je suis surpris par la "simplicité" du fichier de config.
En effet, sur ma A8 je suis sur Marlin et les fichiers de configuration sont bien plus complexes (Ex: le linear advance)

Quand est-il de l'optimisation du firmware de cette carte ? la communauté est-elle vraiment aussi active que celle de Marlin ou plus récemment Klipper ?

Merci pour vos réponses.

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...