Aller au contenu

Filament ABS

Nightly

[Kossel Mini] Besoin d'aide, un peu perdu

Messages recommandés

Bonjour, 

il y a peu de temps j'ai acheté une Imprimante 3D (Enfin :D) Mon choix c'est porté sur une Delta. J'ai vu les 2 et je trouvais la Delta plus sympa même si plus complexe à configurer.
J'ai un peu fouillé le web, notamment les forums RepRap : http://forums.reprap.org/ mais c'est beaucoup trop technique et je ne comprend pas tout.

Niveau Electronique c'est une RAMPS 1.4 sur un Arduino Mega 2560.
J'ai trouvé un "bon" manuel pour le montage, mais il n'est pas à jour par rapport aux pièces que l'on peut recevoir : http://blomker.com/Kossel_Mini_Assembly_Guide_V1.0.pdf

Après environ 15h la Kossel Mini était prête a être branchée sur ma belle prise 220v.
J'ai eu pas mal de comportements bizarre. Les moteurs qui vont dans le mauvais sens, l'imprimante qui ne réagi à aucune action.
Je pense les avoirs résolus mais là je Bloque sur une chose, les Endstops.

Je possède ce type de Endstop :

Geeetech_20150717033151.jpg

 

Ils sont différents par rapport à ceux du manuel. J'ai trouvé comment les brancher sur ma RAMPS.
Mais si le carriage touche les endstop il ne s'arrête pas (ce qu'il est sensé faire) il continue. Je dois appuyer sur le bouton d'arrêt pour couper toute alimentation de l'imprimante.

Au niveau du Firmware, j'en ai vu 2, Marlin et Repetier. Pour l'instant j'utilise Repetier, je l'ai plus aimé à cause de son outil de configuration pour delta et du coup l'imprimante faisais mieux ce que je voulais que quand elle était sous Marlin....

Bref j'ai besoin de vous pour ce soucis d'endstop.
J'ai pensé à quelque chose d'assez radical. Retirez l'endstop du circuit imprimé et de le brancher comme indiqué dans le manuel.
C'est la façon dont est branché l'auto Level il à l'air de fonctionner, même si je ne sais pas encore à quoi il sert.

 

Merci pour vos réponses :D

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci à tous pour votre aide, j'ai sur me débrouiller et finalement m’apercevoir que les branchements n'étais pas là où il était indiquer.
Hier j'ai pu imprimer des cubes de tests, ça c'est correctement passé.

J'ai une question, mon cube qui devais faire 20x20x20 fait 22x22x22.
Comment je peux faire en sorte qu'il me fasse les bonnes mesures ?

 

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

lv-esad, ici ca parle de kossel :P donc une delta. on touche pas aux step/mm pour corriger les dimensions , on touche a la longueur des bras, ce qui souvent obligera a refaire la calibration de la machine(delta radius,endstops,etc..).

Un pti lien pour expliquer tout ca : http://minow.blogspot.fr/

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour vos réponses, après encore quelques heures de réglage, elle commence à sortir l'ABS :D

Je vais pouvoir commencer à imprimer quelques pièces pour faire du rangement, les câbles traînent un peu partout :/

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai imprimé quelques pièces de tests. La plus longue pour l'instant a été ce Pikachu en PJ.

Mais ce WE en rentrant quand j'ai voulu refaire une pièce histoire de pauffiner les réglages. La tête de l'extruder est trop haute du coup l'ABS n'accroche pas.
J'utilise MatterControl avec MatterSlice.

Je ne sais pas pourquoi il fait ça ni même si des paramètres ont changé... :/

Quelqu'un peut m'éclairer ?

12687948_10208576431708509_3125469086561734576_n.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon j'ai pas mal d'impressions sympa depuis. Mais toujours en réglage...

J'ai imprimé 4 pièces en ABS pour caler mon lit.

Mais le problème que j'ai c'est que la tête n'est pas parallèle au lit en X ou en Y.
Elle crée une parabole du coup je ne peux créer pour l'instant que de toutes petites pièces..

On m'a dit de régler "l'horizontal Radius" à partir de l'EEProm sur le logiciel mais je n'ai pas l'option avec Marlin.

Mais là je bute sur un autre soucis. L'imprimante n'en fait que à sa tête.

Quelqu'un pourrait me dire comment reset la mémoire de l'Arduino Mega 2560 ?

 

Merki

Partager ce message


Lien à poster
Partager sur d’autres sites

Que veut-tu dire par reset la mémoire de ta carte ?

Quand tu compile un programme sur ta carte, il supprime automatiquement ce qu'il y avait dessus avant. Il te suffit donc de modifier ta version de Malin, et de la recompiler.

Si c'est pas ça, je ne vois pas ce que tu entend par faire un reset de la mémoire de ton arduino.

Partager ce message


Lien à poster
Partager sur d’autres sites

La remettre comme quand elle est arrivée. Complètement vierge.
Impossible à faire ?

J'ai beau recompiler le programme sur la carte, elle fait n'importe quoi...
Pourtant je n'ai rien touché.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu est sur que c'est pas ton programme qui a un problème ?

Sinon, essaye de transférer un programme vide.

Envoyé de mon C6603 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Et bien j'ai chargé un programme vide.

Rechargé mon Firmware, rien.
ça bouge tout doucement. Et quand je dis tout doucement faut regarder quel moteur tourne pour voir que ça bouge.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon très rapidement, j'ai essayé de lui envoyer des commandes. Chauffer le lit, la buse etc... il ne fait rien.

Vous croyez que j'ai cramé la Ramps ou l'arduino ou les deux ?
Si oui par quel carte plus fiable je peux remplacer tout ça ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je donne des nouvelles.

En fait rien n'a cramé. J'ai dl le dernier firmware de Marlin et je l'ai upload sur l'imprimante après avoir remis mes paramètres. Elle se déplaçais correctement.

Mais j'ai voulu changer et tester le Firmware de Repetier.

là je suis confronté à un autre soucis que je n'ai jamais vu, ni même sur les forums.
Le Z est correctement configuré, si je fais un G1 X0 Y0 Z0. L'imprimante arrive bien a ~0.1 de mon bed.
Une feuille de papier passe en dessous en frottant légèrement.

Mais si je lance une impression, elle commence un peu plus au dessus. Je n'a pas pu chopper la mesure exact mais c'est comme si elle commençais en Z3.

Je pensais à un Z offset qui sera en +X, mais non, il est à 0.

Je suis passé de MatterControl à Repetier-Host et il me fais la même chose.
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

Dans ton logiciel, tu as bien la même hauteur de Z que dans ton firmware?

Tu n'as rien dans ton script de départ qui commanderai ce Z+3mm?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai bien les mêmes valeurs partout.
Le script est lié au logiciel ?

Si oui, il n'y en a pas car l'imprimante fonctionnais bien lors de la première tentative de configuration. et ne décalais pas l'axe Z en positif

Partager ce message


Lien à poster
Partager sur d’autres sites

Je l'ai laissé de côté un moment.
Je l'ai reprise ce WE ayant un peu de temps.

J'ai remis Marlin sur l'imprimante qui me donnais de meilleurs résultats..
Du coup j'ai téléchargé la dernière version stable et commencé ma configuration.

J'ai lancé des cubes de tests de différentes tailles.

J'ai toujours mon soucis de la buse parallèle par rapport au lit. J'ai l'impression d'avoir amélioré la chose mais ce n'est pas parfait, du coup ça limite l'impression car à partir d'un moment ça n'accroche plus.
Pour ça j'ai vu qu'il fallait régler le Delta Radius qui est la somme de DELTA_SMOOTH_ROD_OFFSET-DELTA_EFFECTOR_OFFSET-DELTA_CARRIAGE_OFFSET.

L'article que j'ai suivi disais de changer la valeur DELTA_SMOOTH_ROD_OFFSET.
Ce que j'ai fais. Mais c'est pas trop ça, en Y- ou X- l'ABS n'accroche pas alors qu'en Y+ ou X+ c'est niquel.

Partager ce message


Lien à poster
Partager sur d’autres sites

Oh merci. Je vais regarder ça dans la journée :)
 

EDIT : Par contre je dois renseigner quoi dans  Initial tower angular position corrections: ?

Modifié (le) par Nightly

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×