Aller au contenu

Filament ABS

[Dev] AlfaWise U20x-U30 : Marlin 2.x (firmware alternatif)


Messages recommandés

  • Réponses 3,3k
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Topic Officiel du portage Marlin 2-x pour Alfawise U20, U20+ et U30     AVERTISSEMENT : Ce Topic est dédié aux aspects techniques du portage de Marlin sur les AlfaWise, développem

Youpi! Bon en tout cas à l analyseur logique il n’y a plus du tout de gros saut. Je suis passé de 100 à 0.  Mais c’est quand même étrange . Je sais que libmaple initialise les timers en mode auto

Les gars qu'est-ce que vous foutez avec le code ?! Non mais franchement... [Un marlin bondit sur un bateau pneumatique et blesse deux hommes] https://www.20minutes.fr/monde/2524603-2019

Posted Images

@Epsylon3Dois-je dé commenter seulement les 4 lignes sous #if ENABLED(POWER_LOSS_RECOVERY) ?

 

#define POWER_LOSS_RECOVERY
  #if ENABLED(POWER_LOSS_RECOVERY)
    //#define POWER_LOSS_PIN         44 // Pin to detect power loss (optional)
    //#define POWER_LOSS_STATE     HIGH // State of pin indicating power loss
    //#define POWER_LOSS_PURGE_LEN   20 // (mm) Length of filament to purge on resume
    //#define POWER_LOSS_RETRACT_LEN 10 // (mm) Length of filament to retract on fail. Requires backup power.
 
    // Without a POWER_LOSS_PIN the following option helps reduce wear on the SD card,
    // especially with "vase mode" printing. Set too high and vases cannot be continued.
    #define POWER_LOSS_MIN_Z_CHANGE 0.05 // (mm) Minimum Z change before saving power-loss data
 
    //#define DEBUG_POWER_LOSS_RECOVERY // Debug informations on serial output
    //#define SAVE_INFO_INTERVAL_MS 0   // Force SD recov. write interval, on each layer start if 0
  #endif
Lien à poster
Partager sur d’autres sites
il y a 34 minutes, Epsylon3 a dit :

C'est automatique, y'a pas de paramètres ou pin pour ca, c'est une option pour les impressions par carte SD...

Activé ou désactivé dans le menu Config ensuite...

Excuse moi, mais je n'ai pas compris ta réponse. Qu'est-ce qui est automatique stp ?

@Epsylon3Dois-je dé commenter seulement les 4 lignes sous #if ENABLED(POWER_LOSS_RECOVERY) ?

Lien à poster
Partager sur d’autres sites
Il y a 15 heures, falcom a dit :

Bonjour

Est ce que certains d'entre vous ont changer l'écran pour un avec molette?

Perso cette version de marlin avec le tactile , c'est juste imbuvable.

Envoyé de mon Pixel 4a en utilisant Tapatalk
 

Tiens, idée... @falcom il y a une nouvelle interface graphique complète codée par jmz52 qui a refait la partie graphique et aussi change le « touches imbuvables ». Faut juste faire un Google pour trouver dans le forum marlin. Cette interface est inclue dans la release du code et @Epsylon3 en parle ici quelques pages plus tôt. 

Lien à poster
Partager sur d’autres sites

Hello,

sorry for not speaking french. I have an U30 with V08 board. I successfully managed to compile marlin 2.0.7.2 and runs it. But I have a few issues I can't solve by myself.

Eventhough eeprom is activated there is no eeprom.dat written to SD card. However when I save setting with M500 I get no error message. My settings are not saved.

2nd I have installed a BLTouch and it is running OK. But when changing the Z Probe Offset it's not moving like I saw in some guides. I have to set it to some value and then calibrate by moving Z and calculation the right offset.

I attached my config  and config adv.

Hopefully someone can help.

Regards

 

Olaf

 

 

 

Configuration.h Configuration_adv.h

Modifié (le) par OlafKG
Lien à poster
Partager sur d’autres sites

Save twice when you upgrade, when eeprom was reset due to a structure version change. Its no more on SDCard, but in the STM32... M851 doesnt move anything, its just the offset between the probe trigger and the nozzle

Modifié (le) par Epsylon3
Lien à poster
Partager sur d’autres sites
il y a une heure, Epsylon3 a dit :

Save twice when you upgrade, when eeprom was reset due to a structure version change. Its no more on SDCard, but in the STM32... M851 doesnt move anything, its just the offset between the probe trigger and the nozzle

Thank you for the tip, double savings helps. I also managed to Z Probe offset moving by activating Babystepping in the config_adv.h. Now I can adjust Z Probe Offset directly without going back and forth. It's much more accurate adjusting with steps than X.XXmm. 

Lien à poster
Partager sur d’autres sites
  • 2 weeks later...

Je sais pas si quelqu'un va pouvoir me répondre, mais j'ai flashé Marlin sur ma U20, et genre la,je fait un gros print,et ca fait 2 fois qu'il fait un changement de filament alors que j'ai rien demandé..

Vu que c'est un print qui dure 14 heures,j'ai pas forcement envie de devoir remettre mon fil toutes les heures.. 

J'avais vu un message d'une personne qui avait le meme soucis,mais je retrouve plus.. ><

Modifié (le) par krokhackjv
Lien à poster
Partager sur d’autres sites

vérifie l'état de ton connecteur, tu peux le désactiver dans le menu Config. s'il est en mauvais état. A force de bouger la tête le cable peut s'abimer au niveau du connecteur, faudrait pt un petit point de colle thermique.

Mais il y a aussi le bout de plastique qui fait contact dans le capteur de fin de filament... qui peut s'abimer avec le temps

Lien à poster
Partager sur d’autres sites

Et ne pas oublier de sortir le câble du capteur de filament de la gaine où passent les fils des moteurs... @Epsylon3 c’était pas un problème que nous avions rencontré??

Lien à poster
Partager sur d’autres sites

Hi. Sorry for writing in English. I updated from version 2.0.5.3 to the latest version in github and now I can't get my SD card to work.

Did anything change from March to this latest version regarding the SD card?

I´ve been playing with SDIO_CLOCK but with no luck. Also tried different cards and re-formatted in FAT32.

Also have to say, thank you very much for all your work on this firmware!

Lien à poster
Partager sur d’autres sites

Bonjour à tous et meilleurs voeux,

 

Après quelques temps d'utilisation sur ma U30 du firmware Marlin (Marlin-2.0.5.3-longer3D), que j'apprécie beaucoup! (Encore un grand bravo et merci pour ce super taf!!) 

 j'avais envie de faire des tests avec d'autres réglages/options mais impossible de compiler à nouveau avec visual Studio Code.

Lorsque j'e l'ai ouvert, il y avait une mise à jour que j'ai accepté machinalement, pour le ST STM32 qui est passé de la version 8.0.0 (me semble) à 11.0.0 .

Après ça, j'ai modifié ce que je voulais dans le configuration.h et configuration.advh puis lancé la compilation mais erreur...

Voici ce qui est affiché au début, dans le terminal...

Screen-VSCode2.thumb.PNG.8d723dd40b016d9342daecaec132321a.PNG

et à la fin..

Sceen-VSCode.thumb.PNG.e524be084bebc4bf51ee0ddfb5207a70.PNG

 

Mes connaissances sont limitées dans ce domaine et je sais pas trop quoi faire pour résoudre ce problème!

Merci pour l'aide que vous pourrez m'apporter,

Au plaisir de vous lire 😉

Lien à poster
Partager sur d’autres sites
Le 14/01/2021 at 05:59, Epsylon3 a dit :

dans platformio.ini dans la section de l'U30

ajoute ou remplace...

platform          = ststm32@~10.0

ou sinon utilise ma branche dev sur github https://github.com/tpruvot/Marlin/tree/dev (la 2.0.8.0 arrive sous peu)

Merci pour le coup de main!

J'ai essayé de remplacer " platform = ststm32@~10.0" dans platformio.ini mais je rencontre encore un problème ... 

Capture.thumb.PNG.90898760be1b15ce729dbe6b510b530c.PNG

J'ai essayé ta branche dev sur le github et la ça veux bien compiler  🤔 mais j'ai pas encore essayé sur mon U30 pour voir si tout fonctionné correctement.

Pourquoi la branche que j'ai ne veux plus compiler?

Le 14/01/2021 at 05:59, Epsylon3 a dit :

(la 2.0.8.0 arrive sous peu)

D'ici combien de temps environ et il y à quoi comme changements!?

Lien à poster
Partager sur d’autres sites

@Epsylon3 peut être pour toi rien d'exceptionnel 🤣 , je pensais avoir fais une boulette et me retrouver complètement bloqué 😱

Je viens d'aller voir à quoi correspond M995, c'est pour l'étalonnage de l'écran tactile (j'ai pu voir que ça beugué sur mon U30 d'ailleurs)

Ma version ne compile plus car je n'ai pas l'intégration M995 c'est ça!?

Désolé si pour toi ce sont des questions très bête mais je veux juste comprendre et apprendre 🤗

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr


×
×
  • Créer...