Aller au contenu

Filament ABS

Lecoyote

Extrudeur clône Bondtech

Messages recommandés

Salut les amis,

J'ai fait l'acquisition de 2 extrudeurs BMG (clônes des Bondtech) de la marque Trianglelab, pour remplacer mes titans.

Ces extrudeurs me paraissent pas mal pour le prix et en effet plus coupleux que des titans.

Néanmoins, pour charger/décharger le filament, il faut en passer par un script (nanuellement, ce serait trop long). 

J'utilise donc les scripts fournis par Bondtech.

Ce qui me pose problème, c'est le script de déchargement du filament: 

G21 ;Let the printer know you are following this point with metric values
G90 ;Let the printer know you are using absolute positioning
M109 S200.000 ;Heat hotend to 200C for PLA ‘S245.000’ for ABS
G90 E0 ;Reset the position of the extruder
G1 E10 F100 ; Extrude a short distance before unloading to avoid blob forming
G90 E0 ;Reset the position of the extruder
G1 E-700 F2000 ;Retract 700 mm of filament at 2000 mm/minute speed, change 700 to the lenght of your bowdentube + 100 mm.
G90 E0 ;Reset the position of the extruder
M117 REMOVE FILAMENT NOW ;Display message on LCD-display to remove the filament

Malgré la précaution qui est prise d'extruder quelques millimètres (pour faire fondre les bouchons au bout du filament) avant de rétracter l'ensemble du fil, l'extrémité du fil reste systématiquement bloqué dans l'extrudeur à la fin de la procédure, ce qui fait qu'il faut tout démonter pour sortir le filament coincé (ou tirer comme un âne au risque de tout casser).  J'ai essayé de modifier le script en augmentant la longueur de filament extrudée, en chauffant plus ou en retractant plus vite, rien n'y fait!

Auriez-vous une solution?

Merci à vous

 

Modifié (le) par Lecoyote

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur un bondtech j'ouvre systématiquement le bras en dévissant la vis pour les déchargements et rechargements… Cela doit prendre 3 ou 4 secondes…. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu défais la vis, tu perds ton réglage. D'autre part, ça ne résoud pas le problème du bouchon de fin de filament qui coince au passage du Bondtech.

Partager ce message


Lien à poster
Partager sur d’autres sites

une fois le bras ouvert le bouchon, si il y a, passe tout seul…!  Quel réglage ??? Sur Bondtech on visse a fond la vis et on dévisse d'environ 3 tours pour 95% des filaments ça fonctionne sans problème … Apres pour des filaments tres spéciaux cela peut être un peu plus serré ou un peu moins cela se fait au feeling et a l'expérience… Le bondtech est de loin le meilleur extrudeur il avale tout , c'est un vrai buldozer!!

Modifié (le) par thsrp

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah merci pour ces indications sur le réglage, qui me seront très utiles. Le bouchon sur le mien ne passe pas, même levier ouvert. J'ai dû déjà plusieurs fois démonter tout pour sortir le pignon et dégager le bouchon à l'aide d'un pic... Mais il est vrai qu'il s'agit d'un copie de Bondtech, et pas de l'original... Ceci explique peut être cela...

Partager ce message


Lien à poster
Partager sur d’autres sites

De tres tres rare fois selon le type de filament je peux avoir une petite boursouflure sur l'extremeité du filament qui s'est formée lors du déchargement du filament … Bras ouvert un simple petit coup sec fait que le "bouchon" sort tout seul ...donc je ne peux t'en dire plus… J'ai un original en effet et je ne peux te dire si cela vient de ça… ??? ça me parait byzarre car le clone de triangle lab semble tres bien fait

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

J'ai un Bondtech et j'utilise la fonction M600 du Marlin. Aucun soucis avec le filament qui rentre et sort sans soucis. Je n'ouvre le bras que rarement pour souffler dedans.

 

cdlt

Modifié (le) par Jcc

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci @Jcc, je manque de tps ces jours-ci mais je vais essayer M600 ce week end et je vous dirai si c'est mieux.

Il faut dire que pour compliquer les choses, je me suis lancé dans des essais avec du PTU également. Pas facile à trouver le bon réglage pour entraîner le PTU sans écraser le filament et sans qu'il ne s'enroule non plus autour du pignon.... Le secret semble être cependant dans le choix de la vitesse d'extrusion.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Jcc a dit :

Bonsoir,

 

J'ai un Bondtech et j'utilise la fonction M600 du Marlin. Aucun soucis avec le filament qui rentre et sort sans soucis. Je n'ouvre le bras que rarement pour souffler dedans.

 

cdlt

??? le M600 n'est qu'une fonction pour le changement de filament à une certaine hauteur de layer pour faire du multicouleur… avec la buse qui va se parquer  le Z qui remonte un peu pour ne pas faire de marques et le filament qui au rechargement purge un peu le filament … donc bien compliqué pour un simple changement de filament… et ne fait pas mieux qu'un chargement automatiser par gcode ainsi qu'un téléchargement . Perso sur Octoprint j'ai un créer un bouton qui charge le filament et un bouton qui décharge (dans les 2cas la hot end chauffe avant de démarrer le chargement ou le déchargement… ).

De plus le principal problème du M600 c'est qu'il n'est recoonnu que par une petite quantité de printeuses et il me semble que sur les CR10 il n'est pas reconnu par le firmware stock il faudra donc flasher avec un firmware evolutif pour CR10 et je ne sais que dans les firmwares évolutifs que l'on trouve sur le net pour CR10 la fonction M600 soit déclarée.. !! A voir…. De toute façon c'est se faire chie… (!) pour pas grand chose !! et si bouchon il y a c'est pas lui qui le fera passer dans le bondtech…!!!!!😀 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Magnifique, je suis convaincu par ton argumentaire ..... d'une fonction que tu ne connais pas.

 

Le M600 est la fonction de changement de filament en général. Il peut être utilisé à tout moment, y compris imprimante au repos. Sous Marlin, les commandes associées M701/M702 permettent les seuls chargement ou déchargement. C'est activable sur toutes les imprimantes qui tournent sous Marlin et Klipper et Smoothie. Je ne sais pas sur la CR10.

 

Bref, l'intérêt était, sous Marlin en tout cas, la double accélération au début du retrait  pour éviter ton problème de pointe du filament.

 

 

Bonne continuation.

Modifié (le) par Jcc

Partager ce message


Lien à poster
Partager sur d’autres sites

Houlà, les gars, pas la peine de s'énerver... Je vais essayer ce week-end. Reste à savoir si la CR10 accepte le M600 ou pas, mais ca ressemble fort en tout cas à la routine utilisée par le détecteur de fin de filament, non?  Au pire, on doit pouvoir faire un script qui fonctionne, de toute façon... Je crois en effet que la solution réside dans une rétractation suffisamment rapide pour éviter le bouchon...

Modifié (le) par Lecoyote

Partager ce message


Lien à poster
Partager sur d’autres sites

La CR10 n'accepte pas le M600. Il faut pour que ça puisse fonctionner sur une CR10 stock:

  1. installer un bootloader sur la carte Melzi avec processeur Atmel 1284
  2. une fois ce chargeur de démarrage chargé,  préparer un Marlin aux petits oignons (en dé-commentant la ligne concernant cette commande M600). Tenir compte que le processeur étant un 1284, il a deux fois moins de mémoire qu'un 2560 donc il faudra sacrifier certaines options sinon le téléversement échouera.

Sur une CR10S équipée du détecteur de fin de filament, c'est effectivement ce gcode M600 qui est utilisé.

Concernant les commandes M701 et M702 dont parle @jcc, c'est du code expérimental / partiellement implémenté (dans un fork le bq-marlin) dont je soupçonne fort qu'il ne fonctionnera pas sur nos machines (quelqu’un veut faire le test pour vérifier ?).

As-tu essayé avant de rétracter le filament d'en extruder deux/trois millimètres lentement et immédiatement ensuite de le rétracter très rapidement (le plus vite possible sur ta CR10S) sur une distance d'au moins 40/50mm (buse de 7mm + corps de chauffe de 10mm + heatbreak de 30mm).

Tu peux aussi (mais ça a un coût) remplacer ton PTFE classique par du Capricorn (diamètre interne de 1,9mm), le filament "ramolli" aura un diamètre plus petit 😉 .

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, fran6p a dit :

 

Il y a 4 heures, fran6p a dit :

As-tu essayé avant de rétracter le filament d'en extruder deux/trois millimètres lentement et immédiatement ensuite de le rétracter très rapidement (le plus vite possible sur ta CR10S) sur une distance d'au moins 40/50mm (buse de 7mm + corps de chauffe de 10mm + heatbreak de 30mm).

 

Oui, c'est exactement ce que j'essaye de faire. Par contre je ne sais pas jusqu'à quelle vitesse je peux aller en rétractation.

Il y a 4 heures, fran6p a dit :

Tu peux aussi (mais ça a un coût) remplacer ton PTFE classique par du Capricorn (diamètre interne de 1,9mm), le filament "ramolli" aura un diamètre plus petit 😉 .

Génial, comme idée! Je n'y avais même pas pensé, alors que j'ai un mètre de tube Capricorn qui traîne dans un tiroir. Par contre, ce que je n'aime pas dans le Capricorn, c'est qu'il est opaque... Avec mon double extrudeur, j'aime bien pouvoir contrôler visuellement la montée ou le retrait du filament dans les tubes, lors des changements incessants de couleur.

Modifié (le) par Lecoyote

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, fran6p a dit :

 

Concernant les commandes M701 et M702 dont parle @jcc, c'est du code expérimental / partiellement implémenté (dans un fork le bq-marlin) dont je soupçonne fort qu'il ne fonctionnera pas sur nos machines (quelqu’un veut faire le test pour vérifier ?).

 

Salut,

 

Exact, M701 implanté uniquement sur la 2.0 de Marlin. Désolé.

 

cdlt 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/11/2018 at 19:21, Lecoyote a dit :

Ah merci pour ces indications sur le réglage, qui me seront très utiles. Le bouchon sur le mien ne passe pas, même levier ouvert. J'ai dû déjà plusieurs fois démonter tout pour sortir le pignon et dégager le bouchon à l'aide d'un pic... Mais il est vrai qu'il s'agit d'un copie de Bondtech, et pas de l'original... Ceci explique peut être cela...

J'ai un Bondtech original et j'ai exactement le même problème. Le fil ne ressort jamais. Pour pallier à ça, je rétracte via Octopi (ça va plus vite) un peu plus court que la longueur de mon PTFE, je le déclipse et coupe le bout du filament avent de rétracter les derniers centimètres. Pas besoin d'ouvrir le bras et défaire le réglage.

Je pense que la petite boursouflure viens peut-être de la qualité de la tête. J'ai toujours la tête Creality originale avec des buses bon marché, j'ai bon espoir que le problème disparaisse une fois que j'aurais monté une E3D. Ou pas...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, moi je suis déjà sous E3D... mais là aussi il s'agit d'un clône, donc je ne sais pas trop la qualité de la buse.

J'ai entendu parler d'un gars sur le groupe Facebook qui a carrément foré un trou plus gros pour permettre le passage du bouchon, mais à mon avis ça doit nuire à la précision de l'extrudeur.

Je recherche une solution et actuellement j'ai inversé le montage de mon extrudeur (pour des raisons pratiques). Sait on jamais... peut être que ca va y changer quelque chose? Autre piste, j'ai un deuxième extrudeur identique que je n'ai pas encore testé. Je suis curieux de voir s'il a le même problème ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

J'ai un extrudeur Bondtech et une E3D Lite, le tout original. J'ai aussi eu ce problème de petit bouchon au retrait de filament PLA.

En extrudant 15 mm avant le retrait du filament ce problème se produit beaucoup moins souvent.

Pour le retrait du filament sur la µdelta ( 400mm de bowden), j'utilise un gcode de ce format :

G1 E15 F200
G1 E-25 F200
G1 E-460 F3000

PS : lorsque le filament reste coincé, je débranche le PTFE de sortie et je pousse le filament pour faire ressortir le bouchon et je coupe.

Partager ce message


Lien à poster
Partager sur d’autres sites

Intéressant car tu rétractes les 25 premiers mm lentement, puis le reste plus vite. Je pensais au contraire qu'il fallait rétracter le tout très rapidement?

Modifié (le) par Lecoyote

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, Lecoyote a dit :

Je pensais au contraire qu'il fallait rétracter le tout très rapidement?

J'ai aussi essayé cette méthode en baissant la température pour nettoyer la buse. J'avais des bouchons une fois sur 2.

En fait, les conduits entrée sortie du Bondtech sont très étroits. Le filament est guidé précisément jusqu'à la roue dentée. Il fonctionne bien avec du filament TPU ; mais il ne faut pas qu'il y ait un gonflement du filament au retrait ; ça bloque.

D'ailleurs les entrée sortie sont identiques. C'est pour cela que sur la CR10, l'entrée est la sortie  et la sortie l'entrée 😁.

Modifié (le) par trotro

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Trotro a la solution. C'est celle mise en place par Marlin dans le M600. Un retrait court et vif, comme lors d'un print.  Une pause, que la pointe durcisse puis le retrait complet du fil.

Dans la vidéo que j'ai posté, vous entendez clairement le premier rétract.

C'est pour cela que j'avais proposé cette solution.

Le heartbreak doit aussi y être pour quelque chose. Moi, je suis en Full métal. Je dois passer bientôt en bore 4.1, je vous dirai si cela provoque des soucis.

cdlt

Modifié (le) par Jcc

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×