Aller au contenu

Filament ABS

Yo'

Passage de ma GeeeTech en double alim (GT2560 en 24V, bed et buse en 12V)

Messages recommandés

Hello,

 

J'ai récemment reçu mon alim 24V et j'en ai profité pour l'installer.

Je vais expliquer ce que j'ai fait et ce dont je me suis aperçu au niveau de la GT2560.

 

J'ai tout d’abord supprimé le pont entre les 2 circuits de la carte qui, à mon avis, est responsable de ce début d'incendie.

20181121_090616.thumb.jpg.bfb567026f9d8c267f296225dbd1078c.jpg

Sur les plans, visibles sur ce message, la GT2560 possède 2 circuits bien distincts.

  • 1 pour le lit chauffant (protégé par un fusible 10A)
  • 1 pour le reste (protégé par un fusible 15A)

A l'origine, chaque câble d'alimentation est protégé par le fusible installé sur la carte.

A cause de ce pont, et en cas de mauvaise connexion sur l'un des 2 câbles, jusqu'a 25 Ampères (somme des 2 fusibles) vont passer par cette seule broche et là, ça crame.

 

Autre point que j'ai remarqué sur les plans : le 7812 qui permet d'avoir les ventilos alimenté en 12V que la carte soit alimentée en 12V ou en 24.

Je me suis toujours demandé comment ce 7812 était intégré dans le circuit en 24V et exclu du circuit en 12V (à cause de la chute de tension qu'il provoque si il est alimenté en 12V).

La réponse est : il ne l'est pas.

Lorsque la carte est alimentée en 12V, les ventilateurs sont alimenté avec une tension inférieure à 12V (probablement 10,5V - 11V).

Je m'en suis aperçu lorsque j'ai branché mes ventilos qui tournent à vitesse constante sur mon alim 12V.

Le 40 mm de l'E3DV6 s'est transformé en turbine.

 

J'y ai donc installé un potentiomètre pour régler ce ventilo (vu qu'avant ça marchais avec moins de bruit, autant continuer comme ça).

20181121_103148.thumb.jpg.9e9fc0509ad2dcd31da31639bf15ddec.jpg

Voici une photo de mon imprimante avec en premier plan l'alim 24V, au dessus le potar du ventilo de l'E3DV6, à gauche, avec le gros ventilo, mon boîtier pour la GT2560.

Au fond, on peut voir l'alim 12V ainsi qu'un des mosfet (avec les câbles jaune).

 

Concernant le 7812, il y a un autre point à souligner.

Il est prévu pour délivrer 500mA et donc à peu près suffisant pour alimenter 3 ventilos, mais lors de mes recherches, j'ai lu qu'il chauffait beaucoup et qu'il cramait.

Lors de mes essais, avec un seul ventilo, effectivement, la température montait vite (et mon doigt en est marqué).

J'y ai donc rajouté un dissipateur piqué sur un A4988.

7812.thumb.jpeg.183dcdfe9ffeec25c55649a2ea94f856.jpeg

Avec ça, carte non ventilée, la température se stabilise à 52 °C lorsque juste un seul ventilo est branché.

 

J'ai aussi testé les 2 pins sur lesquelles on peut mettre un cavalier (juste au dessus du driver E1).

ça sert à alimenter les ventilo en 5V au lieu de 12V.

 

 

Coté drivers, c'est bien simple, je n'ai rien eu à régler.

Les Vref n'ont pas bougé par rapport au 12V.

Les TMC2208 sont devenus inaudible et le glissement des IGUS sur les axes lisses est devenu bruyant.

Par contre, les moteurs pilotés par les A4988 (les moteurs de l'axe Z dans mon cas) sont devenus plus bruyants mais il sont également plus vifs et ont l'air d'être plus coupleux.

J'ai fait un Home sur le Z, et lorsque l'imprimante redescend tout doucement pour se placer précisément, j'entends les pas du moteurs, que je n'entendais pas avant.

 

Niveau puissance, j'ai pris l'option radin écolo en ne changeant pas quelque chose qui fonctionne.

J'ai donc mis 2 mosfet (1 pour le lit chauffant, 1 pour la résistance chauffante de la buse).

Les 2 mosfet sont pilotés en 24V par la GT2560 et ils sont alimentés par l'alim 12V.

D'ailleurs, afin de donner un peu coup de boost à mes éléments chauffants, j'ai réglé l'alim à 13,6V (presque à fond).

Résultat : 1m15 pour passer de 22°C à 70°C.

 

Il ne me reste plus qu'à faire des impressions pour voir si il y a un changement.

 

🙂

Modifié (le) par Yo'
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

vraiment du bon boulot !!

c'est malin ça m'a donné envie de tout passer en 24v 😉

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, pascal_lb a dit :

vraiment du bon boulot !!

Merci !

 

Dans mon message, je n'ai pas précisé que seul le ventilo piloté en PWM est branché sur la GT2560.

Les 2 autres sont branchés en direct sur l'alim.

                                                                   |--> Je viens juste de m'apercevoir que j'ai zappé le fusible.

 

🙂

Modifié (le) par Yo'

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Yo' a dit :

je n'ai pas précisé que seul le ventilo piloté en PWM est branché sur la GT2560

en 12 ou 24v ?

il y a une heure, Yo' a dit :

Les 2 autres sont branchés en direct sur l'alim.

sur l'alim 12v je suppose ?

tu l'as pris ou ton alim ?

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 25 minutes, pascal_lb a dit :

en 12 ou 24v ?

Le ventilo est en 12V

 

il y a 25 minutes, pascal_lb a dit :

sur l'alim 12v je suppose ?

tu suppose bien.

J'avais acheté un ventilo en 24V mais au final, je n'ai changé aucun ventilo.

 

il y a 25 minutes, pascal_lb a dit :

tu l'as pris ou ton alim ?

https://www.amazon.fr/gp/product/B00U8MYQO6/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Je n'ai pas encore imprimé avec, mais je suppose que 10A doivent suffire.

 

🙂

Modifié (le) par Yo'

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, Yo' a dit :

je suppose que 10A doivent suffire.

Je m'auto réponds.

J'ai mesuré la consommation électrique du circuit "commande" de la carte.

Elle dépasse à peine 1 Ampère (en cours d'impression avec ventilateur de buse à fond).

Ajouté à ça la faible consommation du mosfet qui est sur le circuit "puissance", avec 10 Ampère, je suis très largement large.

 

Je suis également surpris du coup de fouet que le passage au 13.6 V a mis à la résistance de chauffe de la buse.

Avant, j'étais obligé de monter la vitesse du ventilateur par palier, répartit sur 5 couches, le temps que la buse puisse remonter en température afin de ne pas me prendre un "THERMAL RUNAWAY".

Là, elle perd 5°C et en quelques secondes, elle revient à sa température de consigne.

 

Le passage au 24V, c'est que du benef !

 

🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

 

Voici une impression après le passage au 24V.

La pièce est plutôt pas mal malgré quelques défauts que je n'arrive pas à cerner.

Comme toujours, la photo fait ressortir les défauts.

20181123_123059.thumb.jpg.fd66644d1742ee656d961123b82dcea0.jpg

20181123_123111.thumb.jpg.4b485aea0b452234d78da50360419460.jpg

Avec une vue plus réelle, j'obtiens ça :

20181123_123204.thumb.jpg.1a29bc5b153ed0fefc214626aa675631.jpg

Le principal, c'est que la pièce fasse le job (STL made by @pascal_lb)

20181123_124140.thumb.jpg.2bba6286e84b168a5053f9db967726f7.jpg

 

🙂

Modifié (le) par Yo'

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

il y a 54 minutes, doby02 a dit :

Mise a part la montée plus rapide de la chauffe

Je précise : plateau en 12V alimenté en 13.6 V.

J'ai posté une vidéo ici.

 

il y a 56 minutes, doby02 a dit :

effet sur les moteurs? 

A priori, plus de couple et de bruit sur les moteurs pilotés par les A4988 et plus de silence sur les moteurs pilotés par les TMC2208 sur les basses vitesses.

 

il y a 59 minutes, doby02 a dit :

tu as vu d'autres amélioration du au passage en 24v?

Les ventilos (12V) soufflent plus fort, mais c'est du à la (mauvaise) conception de la GT2560 lorsqu'elle est alimentée en 12V.

 

🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Concernant la pont dans le connecteur d'alimentation, c'est sur le schéma de la gt2560a+. Techniquement je suis pas sur que ce soit un bon choix mais c'est une "feature"

Question : comment on cable les mosfet externe ? directement sur le sortie du heatbed de la carte et en laissant travailler les optocoupleur du Mosfet externe ou avant les mosfet interne ?

Capture d’écran du 2018-12-01 08-26-17.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @nitocris,

 

Peux tu poster un lien pour DL les plans de la REVA+ ?

 

Il y a 1 heure, nitocris a dit :

directement sur le sortie du heatbed de la carte

Tout à fait.

Tu débranche ton bed, et tu branche la commande du mosfet à la place.

 

🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

En directe du forum de geeetech 😉 (mais j'ai mis un moment à mettre la main dessus) :

http://www.geeetech.com/wiki/images/d/d3/Hardware_GT2560_RevA%2B.pdf

 

Hardware_GT2560_RevA+.pdf

Modifié (le) par nitocris
orthographe
  • J'aime 1
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×