Aller au contenu

Filament ABS

Wana

Installation Mks sbase 1.3 sur l'alfawise u20 ?

Messages recommandés

Ok je vais suivre ton conseil je vais les brancher en 1.30 et 1.31

Merci beaucoup pour ton aide

maintenant il me reste à choisir entre smoothieware et marlin tu utilise lequel des 2 et pourquoi ?

Partager ce message


Lien à poster
Partager sur d’autres sites

me voila sur l’étape de flashage du firmware je pensais que ça allait être le coté plus simple visiblement il me faut modifier le fichier config et là... j'aurais du garder ma carte mère d'origine 😨

qui a t'il a modifier et que faut il rajouter pour le capteur de filament sur les pins 1.30 et 1.31 ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Wana a dit :

Ok je vais suivre ton conseil je vais les brancher en 1.30 et 1.31

non dans le dernier exemple tu branches uniquement sur 1.30 et la masse

Il y a 1 heure, Wana a dit :

maintenant il me reste à choisir entre smoothieware et marlin tu utilise lequel des 2 et pourquoi ?

perso je préfère smoothieware plus simple à mon gout et plus facile à régler par le fichier config.txt

si tu choisis marlin il faut prendre la version 2

il y a 31 minutes, Wana a dit :

il me faut modifier le fichier config et là... j'aurais du garder ma carte mère d'origine 😨

et oui ça ne se fait pas comme ça... regarde dans la section https://www.lesimprimantes3d.fr/forum/127-électronique/ il y a plein de renseignement sur smoothieware

 

il y a 33 minutes, Wana a dit :

que faut il rajouter pour le capteur de filament sur les pins 1.30

ça

switch.pause.enable                true                     # Enable this module
switch.pause.input_pin             1.30^                    # Pin where pause button is connected
switch.pause.output_on_command     suspend                  # Suspend command
switch.pause.output_off_command    resume                   # Resume command
switch.pause.input_pin_behavior    toggle                   # This pin toggles between it's on and off states each time it is pressed and released

after_suspend_gcode                  G91_G0E-5_G0Z10_G90_G0X-50Y-50        # Gcode to run after suspend, retract then get head out of way
before_resume_gcode                  G91_G1E1_G90                          # Gcode to run after temp is reached but before resume - do a prime

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, pascal_lb a dit :

non dans le dernier exemple tu branches uniquement sur 1.30 et la masse

perso je préfère smoothieware plus simple à mon gout et plus facile à régler par le fichier config.txt

si tu choisis marlin il faut prendre la version 2

et oui ça ne se fait pas comme ça... regarde dans la section https://www.lesimprimantes3d.fr/forum/127-électronique/ il y a plein de renseignement sur smoothieware

 

ça

switch.pause.enable                true                     # Enable this module
switch.pause.input_pin             1.30^                    # Pin where pause button is connected
switch.pause.output_on_command     suspend                  # Suspend command
switch.pause.output_off_command    resume                   # Resume command
switch.pause.input_pin_behavior    toggle                   # This pin toggles between it's on and off states each time it is pressed and released

after_suspend_gcode                  G91_G0E-5_G0Z10_G90_G0X-50Y-50        # Gcode to run after suspend, retract then get head out of way
before_resume_gcode                  G91_G1E1_G90                          # Gcode to run after temp is reached but before resume - do a prime 

Merci pour le lien j'avais jeté un œil mais la plupart des posts ne concernent pas les connecteurs l'alfawise ^^

j'ai tout branché modifier le fichier config (je ne savais pas ou ajouter ton code du coup je l'ai mis à la fin)

flashé la cm et l’écran, et là lorsque je souhaite bouger un axe rien ne se passe ??? 😒

j'ai la net impression que l’écran tft n’envoie pas la commande sur la cm lorsque je lance une préchauffe il ne se passe rien ni sur le bed ni sur l'extrudeur ?

j'ai joint mon fichier config au cas ou

config.txt

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, Wana a dit :

mais la plupart des posts ne concernent pas les connecteurs l'alfawise ^^

exact, mais c'était plus pour que tu apprennes à faire des modifs et paramétrer smoothieware que pour le détecteur de filament

Il y a 12 heures, Wana a dit :

je ne savais pas ou ajouter ton code du coup je l'ai mis à la fin

là ça n'a pas d'importance, mais il faut que tu enlèves les ? dans ces lignes

switch.pause.enable?                true                     # Enable this module
switch.pause.input_pin            1.30^                    # Pin where pause button is connected

Il y a 12 heures, Wana a dit :

flashé la cm et l’écran, et là lorsque je souhaite bouger un axe rien ne se passe ??? 😒

alors dans le fichier de configuration de ton écran tu dois avoir les lignes comme ci dessous

#mainboard firmware setting(marlin:1; repetier:2; smoothie:3)
>cfg_firmware_type:3

#machine setting (Normal:1; Delta:2)
>cfg_machine_type:1

#baud rate (9600:1; 57600:2; 115200:3; 250000:4)
>cfg_baud_rate:3

 

et dans le fichier config de la carte tu dois avoir cette ligne (j'ai contrôlé elle y est 😉 )

uart0.baud_rate                              115200           # Baud rate for the default hardware serial port

 

Attention le fichier config de la carte une fois modifié est rechargé à chaque démarrage de la carte il reste en txt

Par contre le fichier mks_config.txt de l'écran lorsque tu le modifies tu dois effacer la carte SD (de l'écran), recharger tous les fichiers (fichiers bin, répertoires mks_font et mks_pic) ainsi que le fichier mks_config.txt modifié et au redémarrage de l'écran il va à nouveau réinstaller tous les fichiers...

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 37 minutes, Nafoot a dit :

je viens de tomber la.dessus, ça peux peut-être aider!

oui et non… car ci dessus on parlait de la MKS SBASE 32bits avec smoothieware et dans cette article c'est la MKS GEN L 8bits avec marlin

mais c'est sympa de nous avoir fait découvrir cet article

Modifié (le) par pascal_lb
  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, pascal_lb a dit :
Citation

exact, mais c'était plus pour que tu apprennes à faire des modifs et paramétrer smoothieware que pour le détecteur de filament

en effet j'ai appris mais je me suis surtout emmêlé les neurones 😵

Citation

là ça n'a pas d'importance, mais il faut que tu enlèves les ? dans ces lignes

switch.pause.enable?                true                     # Enable this module
switch.pause.input_pin            1.30^                    # Pin where pause button is connected

merci pour l'info je ne les avais pas enlevés ^^

Citation

alors dans le fichier de configuration de ton écran tu dois avoir les lignes comme ci dessous

#mainboard firmware setting(marlin:1; repetier:2; smoothie:3)
>cfg_firmware_type:3

#machine setting (Normal:1; Delta:2)
>cfg_machine_type:1

#baud rate (9600:1; 57600:2; 115200:3; 250000:4)
>cfg_baud_rate:3

et dans le fichier config de la carte tu dois avoir cette ligne (j'ai contrôlé elle y est 😉 )

uart0.baud_rate                              115200           # Baud rate for the default hardware serial port


 

 

 

en fait mon fichier était bien paramétré par contre je ne l'avait pas renommé 😯

ensuite j'ai perdu une bonne parti de l'apm.... j'avais un soucis d'inversion sur mon moteur Y j'avais mis un espace sur mon !

je remerci Jonathan "Aximaker" qui l'a vu de suite

du coup tout fonctionne correctement Pascal je te remercie aussi infiniment pour ta patience et ton aide 😉

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 21 minutes, Wana a dit :

du coup tout fonctionne correctement Pascal je te remercie aussi infiniment pour ta patience et ton aide

Super ! n'oubli pas de nous dire si ça valait le coup de faire ce changement... 😉 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, pascal_lb a dit :

Super ! n'oubli pas de nous dire si ça valait le coup de faire ce changement... 😉 

Alors je n'ai pas eu le temps d'affiner les réglages sur cura j'utilise le profil pour l'alfawise U20

j'imprime actuellement le support pour l’écran et franchement je n'ai jamais eu des parois externe aussi régulières c'est super propre 👍

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Wana a dit :

franchement je n'ai jamais eu des parois externe aussi régulières c'est super propre 👍

ça c'est malin de me dire ça maintenant j'ai envie de changer ma carte 😄 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, pascal_lb a dit :

ça c'est malin de me dire ça maintenant j'ai envie de changer ma carte 😄 

à mon avis tu peux y aller les yeux fermés en plus tu t'y connais donc que du bonus 😉

pour le moment je ne regrette pas on verra dans le temps mais c'est bcp mieux qu'avec la cm de l'alfawise

Partager ce message


Lien à poster
Partager sur d’autres sites

Le print est en cours difficile de prendre un image correct (filament gris avec l'MKS)

2eme img (filament blanc avec cm alfawise)

ces 2 impressions sont faites avec la même buse soit du 0.8 avec une hauteur de couches identique soit 0.5 ce ne sont pas les même pieces

 

20181206_210211.jpg

20181206_210247.jpg

Modifié (le) par Wana

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Tout le monde

j'aimerais savoir comment procede t'on au calibrage de l'axe Z ?

faut'il modifier la valeur "gamma_steps_per_mm " ?

le fait de descendre l’ampérage d'un moteur pas à pas a priori cela impacterait la vitesse est ce que cela impact aussi le Nb de pas ?

je m'explique... j'ai des moteurs Nema 17 avec pour ampérage  maxi 1.7A sur mon config.tx j'avais saisi la valeur de 1.5A en "gamma_current" lors de petites impressions j'avais un rendu assez médiocre et en plus mon moteur chauffait énormément en tâtonnant j'ai descendu cette valeur à 0.8A sur mon axe Z et là j'obtiens un meilleur rendu des impressions par contre j'ai un gros écart au niveau de la hauteur de ma pièce ( je précise que j'avais aussi un écart avant la modif de l’ampérage un peu moins important) donc celle-ci fait 18.96 au lieu de 20mm

mes 6/7 premières couches sont écrasées sachant que mon leveling est plus que parfait, ma feuille passe à l'aise entre le plateau et la buse (buse 0.2) y compris au centre la ou la pièce est imprimé

en modifiant la valeur "gamma_steps_per_mm" cela réduit les couches écrasées et je gagne en hauteur mais... maintenant ma piece a tendance à warper dans les angles ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 33 minutes, Wana a dit :

j'aimerais savoir comment procede t'on au calibrage de l'axe Z ?

comme tous les axes, après avoir fait ton cube de 20x20x20 regarde là pour les mesures après au niveau du fichier config, c'est sur ces lignes là

alpha_steps_per_mm                           78.7402               # Steps per mm for alpha stepper
beta_steps_per_mm                            78.7402               # Steps per mm for beta stepper
gamma_steps_per_mm                           400             # Steps per mm for gamma stepper

 

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 29 minutes, pascal_lb a dit :

comme tous les axes, regarde là

Merci pour le lien pascal je suppose que pour smoothie la ligne a modifier c'est bien : "gamma_steps_per_mm"  ?

quand est 'il de l'amperage ?

EDIT: il me manquait du texte sur ta première réponse du coup tu as répondu à ma question manque juste l’ampérage ?

Modifié (le) par Wana

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Wana a dit :

j'ai des moteurs Nema 17 avec pour ampérage  maxi 1.7A sur mon config.tx j'avais saisi la valeur de 1.5A en "gamma_current"

si tu as mis 0.8 et que tout fonctionne bien et que tu ne perds pas de  pas alors laisse comme ça

Il y a 2 heures, Wana a dit :

en plus mon moteur chauffait énormément

de ce coté là c'est assez relatif car les moteurs peuvent chauffer à 50/60° sans problème

Il y a 2 heures, Wana a dit :

la ligne a modifier c'est bien : "gamma_steps_per_mm"  ?

oui c'est bien ça

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, inconnul a dit :

Je suis curieux.

c'est normal 😉

Il y a 9 heures, inconnul a dit :

Parce que c"est un firmware proprietaire ?

oui c'est une des raisons, par exemple pas de possibilité d'ajouter un BLTOUCH ou autres détecteurs, pas de possibilité d'ajouter un 2éme extrudeur et pas de possibilité de modifier certains réglages ou de "personnaliser" sa machine, après il faut tester et comparer peut être que la Longer3D est mieux que la MKS SBASE....

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...