Aller au contenu

Filament ABS

Philippe Chaumont

Réglage PID BED de l'Anet A8

Messages recommandés

Bonjour,

comme le titre l'indique, j'essaie de régler le PID du BED de mon Anet A8 sous Marlin 1.1.8.

quand je rentre la commande M303 E1 Cx S60  (où x est le nombre de cylcles) j'ai un message d'erreur : PID Autotune failed! Bad extruder number

j'ai aussi essayé M303 E-1 Cx S60 qui ne marche pas non plus. Sachant que l'extrudeur c'est E0 il ne me reste plus grandes possibilités 🙂

en suivant des recommandations sur github (https://github.com/MarlinFirmware/Marlin/issues/8942 ) j'ai mis WATCH_BED_TEMP_PERIOD à 126  et reflashé ma nenette (moins de 127 qu'ils disent) sans aucun effet (d'autre que des sueurs froides jusqu'à ce qu'elle m'affiche un Marlin 1.1.8 triomphant sur l'écran LCD 🙂 ). donc le bug n'est pas celui-là, même si il semble effectivement que la commande M303 soit beuguée pour la nenette A8.

Quelqu'un a une idée ? Est-ce que Marlin 1.1.9 règle le problème ? Si oui est-ce qu'on peut flasher Marlin 1.1.9 avec Arduino 1.8.5 ?

Bon maintenant pourquoi je m'emm.. à essayer de régler le PID, et bien parce que j'ai eu un THERMAL warning; Après vérification, mon BED réglé à 60 oscille de 58 à 62 et donc frôle d'un peu près 
 les limites de tolérance. Donc je me dis que mon PID ne fonctionne plus de manière optimale. Je me dis aussi que je ne sais pas pourquoi le réglage aurait dû changer, est-ce que je dois m'inquiéter sur le fonctionnement de la carte, de la sonde de température, de la qualité du courant EDF ? Là aussi un retour d'expérience serait bienvenu.

Merci d'avance,

Philippe

Modifié (le) par Philippe Chaumont

Partager ce message


Lien à poster
Partager sur d’autres sites

bon j'ai trouvé pourquoi je ne peux pas régler le PID du BED : par défaut sur mes config.h de MARLIN 1.1.8 et aussi 1.1.9, le PID du BED n'est pas activé.

 @jmarie3D  tu as enabled le PIDTEMPBED  (autour de la ligne 420 de config.h) comme le fait Le GüeroLoco dans sa vidéo ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 8 minutes, Philippe Chaumont a dit :

par défaut sur mes config.h de MARLIN 1.1.8 et aussi 1.1.9, le PID du BED n'est pas activé.

Oui, sur les Anet, le PID du bed n'est pas activé par défaut.

il y a 5 minutes, Philippe Chaumont a dit :

tu as enabled le PIDTEMPBED 

Oui, bien sûr, c'est une condition sinequanone.

Pour info, je l'ai fait avec Marlin 1.1.9 et l'IDE Arduino 1.8.7.

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 15 minutes, jmarie3D a dit :

Oui, sur les Anet, le PID du bed n'est pas activé par défaut.

quand j'active le PID du BED, je reçois ce message d'erreur à la compilation par Arduino

exit status 1
#error "To use BED_LIMIT_SWITCHING you must disable PIDTEMPBED."

tu as disabled le BED_LIMIT_SWITCHING ? et si oui (ce que je suppose), c'est dans quel fichier de configuration ?

 

J'ai trouvé ke BED_LIMIT_SWITCHING , il est juste en dessous 🙂  donc on est d'accord que tu as mis la ligne en commentaire ?

Modifié (le) par Philippe Chaumont

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est juste en dessous
 

#define PIDTEMPBED

//#define BED_LIMIT_SWITCHING

Mais je ne me souviens pas d'avoir modifié cette ligne...

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, jmarie3D a dit :

C'est juste en dessous
 


#define PIDTEMPBED

//#define BED_LIMIT_SWITCHING

Mais je ne me souviens pas d'avoir modifié cette ligne...

oui je viens de m'en rendre compte. Arduino me donne une erreur si je met pas la ligne en commentaire... Et il m'en donne une autre si je mets la ligne en commentaire parce qu'alors mon fichier compilé est trop gros pour être flashé sur la carte 🙂 

Donc je sais pas comment tu as fait 🙂 à moins que MARLIN 1.1.9 soit plus petite que MARLIN 1.1.8 ?

 

Bon, sinon je vais changer l'hysteresis du BED et mettre 7 au lieu de 5, je verrai bien. merci en tout cas pour tes réponses.

Partager ce message


Lien à poster
Partager sur d’autres sites

De toute façon, je ne penses pas que ton problème vienne du PID.

Vérifies plutôt ton matériel ( thermistance, ventilateur...)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 7 minutes, jmarie3D a dit :

De toute façon, je ne penses pas que ton problème vienne du PID.

Vérifies plutôt ton matériel ( thermistance, ventilateur...)

oui la thermistance est peut être en train de lâcher... en tout cas c'est le symptôme de quelque chose mais je ne sais pas quoi.. moi qui ait une pièce à imprimer qui demande 16h, je crois que je vais attendre d'en savoir plus 🙂 

Partager ce message


Lien à poster
Partager sur d’autres sites

Fin provisoire 🙂 

J'ai installé le dernier Arduino (1.8.8) avec lequel j'ai recompilé MARLIN 1.1.8.

Avec

//#define PIDTEMPBED

#define BED_LIMIT_SWITCHING

Toutes choses égale par ailleurs, je suis passé de 124988 octets avec Arduino 1.8.5 à 124855 octets avec Arduino 1.8.8. donc il y a bien un gain de place.

 

Du coup j'ai réessayé avec 

#define PIDTEMPBED

//#define BED_LIMIT_SWITCHING

et là ou Arduino 1.8.5 me déclarait qu'il n'y a avait pas assez de place, Arduino 1.8.8 compile le croquis avec 126166 octets (sur 126976 🙂 soit 99%)

Du coup j'ai flashé par nenette et j'ai effectivement pu régler le PID du BED. Essai de chauffage du BED à 60, ça bouge pas du tout.

Bon, ça ne me rassure pas sur le fait que le chauffage du BED me semble avoir un problème. D'ailleurs les constantes du PID me semblent très élevées :

P 525.84

I 76.42

D 904.63

Je m'attends donc à avoir des problèmes bientôt 🙂 

Merci encore à @jmarie3D pour son coup de main 👍

Partager ce message


Lien à poster
Partager sur d’autres sites

suite du feuilleton, de nouveau un thermal runaway et non seulement nenette fait grève mais en plus mon alim 30VA déclare forfait aussi en se coupant (elle est dotée d'un disjoncteur thermique). Et cette fois-ci c'est mon extrudeur qui joue des tours...

Bref il n'y a pas de solution software à un problème de hardware, comme d'habitude 🙂 .

 

Au fait, mes deux circuits BED et EXTRUDEUR sont protégés chacun par un MOSFET. est-ce que ces bestioles peuvent lâcher ou je ferai mieux de me concentrer sur le chauffage lui-même ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×