Aller au contenu

Filament ABS

FreddRob

Autoleveling

Messages recommandés

Bonjour,

J'ai un autre petit souci avec mon imprimante 3d. Pour faire de l'autoleveling j'ai installé un capteur capacitif sur mon imprimante. Tout semble bien fonctionner sauf que les résultats différent pratiquement à chaque calcul de l'autolel si bien des fois, ma tête d'impression va être positionnée un peu trop ou un peu trop bas.

Je me demande en fait si la façon de faire de l'autoleveling avec ce type de capteur est une bonne idée puisque ces capteur s ont une tolérance assez élevée.

mon imprimante tournant sous repetierFirmware, j'utilise la commande G28 x y pour me positionner à l'origine et la commande G32 S2 pour effectuer l'autoleveling.

Avez-vous rencontré ce même type de problème?

 

Ma configuration:

- équivalent prusa i3 rework V1, megatronic v3, repetier fimrware 0.92.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

J'ai exactement le même problème a chaque impresion de doit soit remonter soit descendre l'offset de 0.05 mm je suis encore en train de voir pour régler ce problèmes

cdlt

Partager ce message


Lien à poster
Partager sur d’autres sites

En fait je pense juste que ce n'est pas le bon type de capteur pour cette fonction. L'idéal je pense serait d'avoir un contour métallique tout autour du plateau, ou une petite plaque métallique à chaque coin du plateau, un peu surélevée sur le plateau pour que la tête de l'extrudeur ne touche pas le plateau au moment du sondage (dans le cas d'une mesure 4 points ou à trois endroits sur les bords du plateau pour une mesure 3 points), d'avoir une petite sonde métallique au niveau de l'extrudeur. Le but étant de mesurer la résistance à 0 ou une tension Vcc quand la sonde métallique touche la petite plaque. C'est l'équivalent du détecteur capacitif ou inductif mais sans erreur.
On pourrait relier chaque plaque métallique au Vcc ou 12 volts  du plateau et la sonde sur une entrée de la carte contrôleur (l'entrée du capteur actuel, à travers un pont diviseur de tension si 12 volts).

Pour chaque point de mesure il faut une sonde donc, au max 4 sondes sur l'extrudeur, toutes reliées à la même entrée sur le contrôleur.

Bien évidemment quelqu'un sur internet doit déjà présenté cette solution mais je n'ai pas cherché.

Cordialement,

FreddRob

Partager ce message


Lien à poster
Partager sur d’autres sites

Il semble pourtant que l'autoleveling avec sonde capacitive fonctionne sans problème une fois le positionnement de celui fait correctement, .quelque soit le matériaux du bed

Modifié (le) par Misterblue

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est ce que je pensais... en fait, l'idéal est de ne pas refaire l'autoleveling à chaque fois mais mon plateau peut légèrement bouger quand je veux décoller une pièce imprimée donc faussé le résultat du calcul précédent. De plus, cela n'explique pas pourquoi pour deux mesures dans le même environnement je vais avoir ma hauteur de tête pour la première couche nickelle pour une mesure et pour l'autre la première couche un peu écrasée, voir beaucoup... A part la tolérance associée au capteur, je ne vois pas...

De plus, j'utilise la commande G32 S2, il me semblait que le S2 permettait de stocker en mémoire le résultat or, il semble que ce ne soit pas le cas... Je rappelle que j'utilise le firmware de répétier...

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

j'ai le même problème avec la  sonde capacitive.... Les valeurs changent à chaque mesure...

j'ai un dénivelé de 0.19 MGM entre deux points opposés. L'auto bled n'en tient pas compte ! 

Si je me règle au point le plus bas, la buse grave le plateau sur le point opposé ! Et je n'arrive pas

a régler ce problème .

 

Frances83

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 26 janvier 2016 at 17:40, FreddRob a dit :

C'est ce que je pensais... en fait, l'idéal est de ne pas refaire l'autoleveling à chaque fois mais mon plateau peut légèrement bouger quand je veux décoller une pièce imprimée donc faussé le résultat du calcul précédent. De plus, cela n'explique pas pourquoi pour deux mesures dans le même environnement je vais avoir ma hauteur de tête pour la première couche nickelle pour une mesure et pour l'autre la première couche un peu écrasée, voir beaucoup... A part la tolérance associée au capteur, je ne vois pas...

De plus, j'utilise la commande G32 S2, il me semblait que le S2 permettait de stocker en mémoire le résultat or, il semble que ce ne soit pas le cas... Je rappelle que j'utilise le firmware de répétier...

 

Pour la mise en mémoire de l'offset buse/ capteur la commande M500 suffit !

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×