Aller au contenu

Filament ABS

madeo54

32 bits Configuration MKS Sbase et TFT35

Messages recommandés

Bonjour,

j’ai commencé à installer ma MKS Sbase et un écran MKS TFT35, mais

je n’arrive pas à le configurer.

J’ai copié les fichiers sur ma carte SD et lorsque je le rallume pour rebouter la carte mère, l’écran bip et s’allume mais ne communique pas avec la carte mère.

Lorsque j’appuie sur les flèches de déplacement X,Y,Z rien ne bouge !

L’un de vous aurait-il un fichier config avec ce genre d’écran pour comparaison ?

Merci de votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, madeo54 a dit :

L’un de vous aurait-il un fichier config avec ce genre d’écran pour comparaison ?

il n'y a rien à mettre de particulier dans le fichier config de la carte mère, à part cette ligne à vérifier et voir sir c'est la bonne valeur 

uart0.baud_rate                              115200           # Baud rate for the default hardware ( UART ) serial port

après as tu chargé le firmware de l'écran ?

peux tu mettre une photo du branchement de ton écran de ta carte mère

Je t'invite à regarder les nombreux post sur la sbase dans la rubrique électronique ou nous sommes

Partager ce message


Lien à poster
Partager sur d’autres sites

J’ai fini par charger le firmware et la mise à jour est faite avec une SD neuve !!

Le TFT est connecté sur l’aux,

Une question : les moteurs fonctionnent bien sous Pronterface mais rien ne se passe quand je veux faire la même chose avec l’écran.

Quelle ligne faut-il activer ou désactiver dans la config ?

Partager ce message


Lien à poster
Partager sur d’autres sites

peux tu mettre en fichier joint ici, ton fichier de ta carte sbase et de ton écran

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, madeo54 a dit :

en P.J le config de la carte et l'écran

dans le fichier config de l'écran tu dois mettre 3 à cette ligne car là tu as 4 et c'est pas bon

#baud rate (9600:1; 57600:2; 115200:3; 250000:4)
>cfg_baud_rate:4

par contre tu as quoi comme écran un TFT 3.5 ou un TFT 3.2 ?

par contre lorsque tu recharges le firmware de l'écran il faut effacer tous les fichiers de la carte SD remettre les bons (modifiés) sur la SD et refaire l'installation, si tu modifies les fichiers sur la carte SD sans refaire une installation de l'écran les nouveaux paramètres ne seront pas pris en compte… ça c'est pour l'écran

Pour la carte SBASE là tu peux modifier le fichier config.txt sans tout recharger, tu as juste à redémarrer la carte et les modifications sont enregistrées

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour tuxdata

J’ai installé le fichier et j’ai redémarré et je n’arrive à rien…

je n’arrive pas à trouver d’où cela peut venir...

pourrais-tu m’envoyer une copie de ton fichier de la carte mère pour que je puisse comparer ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 10 minutes, madeo54 a dit :

J’ai installé le fichier et j’ai redémarré et je n’arrive à rien…

as tu bien suivi la procédure pour mettre à jour le fichier config de l'écran ?

Le ‎22‎/‎12‎/‎2018 at 15:55, pascal_lb a dit :

par contre lorsque tu recharges le firmware de l'écran il faut effacer tous les fichiers de la carte SD remettre les bons (modifiés) sur la SD et refaire l'installation, si tu modifies les fichiers sur la carte SD sans refaire une installation de l'écran les nouveaux paramètres ne seront pas pris en compte… ça c'est pour l'écran

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, madeo54 a dit :

j'ai formaté les deux cartes et réinstallé les fichiers en P.J

non ce n'est pas les fichiers .CUR qu'il faut mettre c'est les fichiers comme ci-dessous

fichiers.JPG.0dec0bc2fa24e967e2d1bb500f2d179d.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 18 minutes, madeo54 a dit :

et je suis au même point...ai-je loupé une manip??

oui et non 😉

dans ton fichier mks_config.txt la ligne ci-dessous est configuré pour Marlin, il faut mettre 3 à la place de 1

#mainboard firmware setting(marlin:1; repetier:2; smoothie:3)
>cfg_firmware_type:1

sur cette ligne laisse 3 (English) tu sélectionneras français avec l'écran par la suite

#This configuration is valid when "cfg_multiple_language" is disabled.
>cfg_language_type:6

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai modifié le fichier mks_config.txt , j'ai une amélioration

Avec pronterface les moteurs tournent, mais pas avec le TFT !

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, madeo54 a dit :

mais pas avec le TFT !

arrives tu à faire bouger quelque chose avec le TFT, un moteur, mettre en chauffe ou autre

la mise à jour de l'écran se fait elle au démarrage ?

après l'installation des 2 cartes :

tes fichiers sur la SD de l'écran deviennent ils .cur ?

sur la micro SD de la Sbase est ce le fichier firmware à bien l'extension .cur ?

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour l'instant je n'ai branché que les moteurs et rien ne bouge avec le TFT.

La mise à jour est faite au démarrage elle écrase les anciens fichiers et réinstalle la mise à jour.

La SD du TFT :

bak_font

bak_pic

mks wifi.bin

config.cur

MKSTFT35.CUR

La SD Carte mère :

MKS_config.txt

FIRMWARE.CUR

Partager ce message


Lien à poster
Partager sur d’autres sites

ok c'est bon, peux tu nous remettre tes 2 fichiers config ici et nous mettre une photo  de tes branchements

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×