Aller au contenu

Filament ABS

vieur

Offset axe Z ender 3

Messages recommandés

Bonjour,

Suite à l'arrivée de mon nouveau filament, je me suis mis dans l'idée de régler/calibrer/vérifier mes axes.

J'ai fait une pièce pour fixer un pied de profondeur et commencé à mesurer les déplacement de l'axe Z en fonction de la consigne.

Quel que soit le déplacement demandé (en partant à chaque fois de la position home Z=0 et en lançant un déplacement via Cura), il me manque 0,24 mm d'élévation.

Je ne comprend pas pourquoi ce résultat. Comme si un "offset" de 0,2 mm était présent.

J'ai bien essayé de toucher à l'offset présent sur le "pupitre" de l'imprimante mais ça ne change rien quelle qu soit la valeur entrée.

 

Si quelqu'un peut m'expliquer la logique (ou pas) de ce décalage ce serait cool.

Si quelqu'un sait comment mettre un offset (gcode??) je suis preneur.

 

Merci à vous 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Moi je règle mon offset via la cde M851 Z- ta valeur soit 0.24 en prenant en compte ton epaisseurcde couche

M500 pour mettre en mémoire et M851 pour verifier ta valeur

Je preconise une main sur l'arrêt d'urgence au cas ou

lion02

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse, je vais tester et vous ferai un retour

Quand tu dis M851 pour vérifier, c'est à dire? Je débute ...

j'ai encore du mal à piger quel gcode s'utilise pour quelle marque, firmware ,slicer...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, vieur a dit :

Merci

Tu peux aussi cliquer sur le cœur au bas des posts qui permet aussi de remercier (il possède d'autres fonctionnalités aussi 😉 ). Ça permet d'indiquer son "opinion" sans forcément devoir compléter par écrit un post. 

barre_icones_forum_explications.png.220b13e2e226da1129875cf7680eea69.png

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon,  j'ai essayé, mais ça ne change rien.

J'envoie la commande ici (je sait pas si c'est bien comme ça) suivi du M500 :

image.png.3c20050259c3d121e890e2a4c95bbb7f.png

Autre truc que je ne comprend pas c'est que j'ai dans l'écran un offset Z=0.50 et je ne peut pas le mettre à 0 !

 

 

image.png

Modifié (le) par vieur

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans marlin il faut que ces deux lignes soient activées pour le M500, peut etre une piste

#define EEPROM_SETTINGS
#define EEPROM_CHITCHAT

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors, là je suis pas rendu.

Je comprend que Marlin est "l'appli" qui tourne sur la carte mère. Mais comment on y a accès autrement que par les boutons de l'imprimante?

Pour l'instant j'ai cherché dans Cura mais je suis pas sûr qu'on ait accès à Marlin par le slicer? Il faut un logiciel?

C'est confus malgré mes recherches.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne connais pas l'ender 3 mais je pense  que d'autres membres pourront d'aider. 

Pour marlin il faut utiliser arduino et televerser dans ta carte mais il faut déjà avoir ta version qui est sur ton ender 3

Ne te lance pas dans cette manipulation si tu ne maitrise pas.

lion02

  • +1 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement, je ne maîtrise pas assez et j'ai pas trop envie de planter l'imprimante. Je n'ai pas encore trouvé la version sur mon ender 3.

SI quelqu'un à une autre idée pour modifier mon offset ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour faire suite, j'ai fait d'autres mesures (beaucoup) et j'ai quelques observations :

1- Mon décalage, n'est pas vraiment permanent. En fait, il est présent lorsqu'on part du home; mais lorsque on est un peu plus haut, les décalages sont plus faibles (variables mais assez souvent <0.1 mm d'erreur)

2- En faisant un bilan en filtrant les mesures "ne partant pas du home", on remarque que les écarts par rapport à la consigne sont plus importants pour les déplacement importants 

Consigne (mm) Moyenne de % d'erreur Moyenne des ecarts (mm)
-100 -0,094285714 0,094285714
-50 -0,21 0,105
-10 -0,6 0,06
0,1 -47 -0,047
1 -9,857142857 -0,098571429
10 -1,36875 -0,136875
50 -0,45 -0,225
100 -0,24 -0,24
     

3- Il y a quelque temps, j'avais fait un cube de calibration de 20mm et il me manquait 0,13 mm en Z 

Solutions envisagées :

  1. Ajustement du bed pour partir exactement à la distance théorique (de Cura) dès la première couche
  2. Correction des step/mm peut aider je pense

je vais tester... si vous avez un avis...

Modifié (le) par vieur

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai encore fait pas mal de mesures et je ne comprend pas pourquoi mes mesures sur l'axe Z sont ainsi

Est-ce que Marlin "écrase" les déplacements en Z pour compenser l'écart Buse/Bed initial (fameux 0,1mm ) ?

Je m'explique, lorsque lance des pas de 0.1 mm en Z, les premiers pas mesurés au comparateur sont "écrasés" ce qui fait que mes pièces ne sont pas assez hautes  en fin de print ! 

Ci-dessous mes relevés :

image.png.e9a916642977046c4d3f500130fdbf91.png

On voit clairement plusieurs choses :

  1. La courbe bleue en dessous de la orange fin de print => Ma hauteur de pièce finale est inférieure à celle attendue et c'est embêtant.
  2. La courbe bleue commence à 0.1 =>  Ça c'est volontaire pour compenser ma perte de hauteur en fin de print (distance Bed/buse = 0.1 mm en home)
  3. La première partie de la courbe bleue n'est pas droite jusqu'à 0,8 mm environ  => les pas sont en fait inférieurs. Marlin écrase?? Pourquoi tant et où?
  4. La seconde partie de courbe (à partir de 0,8 mm) est parallèle à ma consigne => là tout est conforme

J'ai testé d'augmenter la distance initiale Bed/buse jusqu’à 0,2 mm mais ça devient galère, il faut augmenter le flow de l'extruder sachant que pour compenser mon écart, il me faut 0,1 actuels + 0,2 manquants en fin de print = 0,3 mm en distance Bed/Buse. Je ne suis pas sûr que ce soit la bonne voie...

J'aimerai que lorsque je demande 0.1 mm, la buse aille à 0.1 du bed ! Si des réglages sont nécessaires, Cura peut s'en occuper je pense...

J'ai téléchargé le Firmware de l'Ender 3 mais pas (encore) trouvé la partie gestion des déplacements.

Avez-vous connaissance de mon problème?

Existe-t-il une solution pour que j'ai les hauteurs souhaitées en fin de print?

 

Merci d'avance

Partager ce message


Lien à poster
Partager sur d’autres sites

@vieur

Ta tige filetée trapézoïdale ne serait-elle pas contrainte ? Si le moteur est freiné cela pourrait expliquer ces déplacements erratiques.

Sinon, concernant le Marlin installé par Creality, on peut le récupérer soit:

- sur leur Github

- soit directement sur sur leur site (dernière version mise à jour le 08122018 pour l'Ender3).

La carte mère des Ender 3 ne possède pas de chargeur de démarrage, il faudra procéder au préalable à son installation en t'aidant par exemple du site Ender3 francophone

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @fran6p 

Oh p**** je viens de m’apercevoir, grâce à ton commentaire que mon moteur d'axe Z est mal fixé...  Quel c**** et dire que j'ai fait pleins de mesures pour essayer de comprendre!

Le moteur remonte en début de mouvement puis une fois ce jeu comblé, tout est oK... Je refixe tout ça et ça devrait pas faire de mal.

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme quoi, je dis pas toujours des co***ries (même si ça m'arrive de le faire 😉  ).

Content d'avoir pu aider (ce qui est la raison d'être principale de ce forum) 😄 .

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour.

Je reviens vers vous car malgré mes "liberations" de l'axe z (fixations moteur, réglage excentriques,  alignement écrou laiton) j'ai encore le même phénomène.  Mes 2 premiers pas ne sont pas de 0.1 mais 0.05  et apres le premier mm environ c'est conforme. (Quelle que soit la position de départ et ça le fait aussi en descendant).

Plusieurs questions

J'ai toujours ce offset de 0.5 sur z dans les paramètres à l'écran.  Avez vous ça aussi?

Avez vous déjà regardé si ça fait la même chose sur vos ender3?

J'aurai voulu modifier la séquence gcode de démarrage et désactiver le endstop temporairement. Ça ne marche pas est-ce connu?

Merci pour votre aide 

Modifié (le) par vieur

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 23/01/2019 at 07:15, vieur a dit :

Ça ne marche pas est-ce connu?

Le firmware implanté par Creality n'a pas activé cette option. Si tu veux pouvoir le faire (descendre en dessous du zéro après un "home" en désactivant les "endstops"), il faudra procéder à un flashage de Marlin (et au préalable installer un chargeur de démarrage sur la carte mère qui en est dépourvue).

N'ayant pas de Ender3 je n'ai pas cet offset" sur l'écran 😉 .

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour les infos, j'ai pas encore le temps de me pencher sur le flashage.

En attendant j'ai modifié le Gcode de démarrage avec un G92 Z0.2 quand ma tête est à Z0.4. C'est plus dangereux en cas de homming du Z mais ça à l'air de marcher... a voir sur mes prochains prints. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...