Aller au contenu

Filament ABS

Bosco2509

[Aide] Mes débuts avec Scanner 3D Ciclop

Messages recommandés

Salut la compagnie !

Eh oui... pour une fois... c'est moi qui viens vous solliciter.
J'ai acheter... un Scanner 3D Ciclop BIqU (original et non copie), d'occasion.
Je l'ai reçu ce matin.
Gros avantage... il m'a été expédié monté... bon ok... je l'avoue... je l'ai démonté pour le remonté, cas il y a 2-3 trucs qui clochait (et/ou qui était branquignole) et mal monté par son ancien propriétaire.
J'ai suivi... vidéo de montage... jusque là... je m'en tire pas trop mal...
J'ai suivi l'étape de la calibration... et après... 3 puis 4 puis 5 puis 6 puis 7 puis 8 puis 9 puis 10e tentative ! Oui j'y suis enfin arrivé à comprendre le procédé de calibration.
Eh... je débute je vous rappel.
Là... je règle la luminosité... je règle la caméra... et je lance mes premiers scans...
Et après quelques scans... complètement vide... de tout point...
J'obtient alors enfin des scans avec des "nuages de points".

Et voià le premier :

178355245_Capturedcran(233).thumb.png.b214bea2de0285d9a71f667ed0355ede.png

Je ne désespère pas... et je lance un second scan :

1194050325_Capturedcran(236).thumb.png.d0fceccd98a8f0b1a936975a850c131f.png

Eh ! Je débute je vous rappel... même si ce scan est... BROUILLON... j'entre-aperçois mon modèle.
Et là je me dit à moi même : Bon... c'est drôle un moment mais... c'est quoi le problème ? 🤨

Du coup... je viens vers vous... et je sollicite vos connaissances et votre maitrise à m'expliquer ce que j'ai fait de mal et je vous en remercie d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant
il y a 6 minutes, cylon a dit :

lumière ! 

Je suppose que tu veut dire : Plus de lumière !

J'y ai pensé... surtout que visiblement, cela semble assez sensible à la luminosité ambiante...
Je vais voir ce que je peut faire de ce côté là...

Partager ce message


Lien à poster
Partager sur d’autres sites

exacte ! j'en ai fabriqué 1 avec un kinect, j'avais quelques soucis de points aussi, et avec une bonne lumière... bah j'en suis à mon 4 ème buste... c'est nickel !  voilà ce que j'obtiens avec mon ptit machin à 30 euros

IMG_20180610_150042.jpg

Modifié (le) par cylon

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui quand même ! 😮

Là... je m'en rend compte que la lumière est "indispensable".
Je suis dans un pièce aménagé en bureau... et il y fait généralement sombre.
Et là... avec la nuit qui est tombé... je n'arrive plus à rien...
Donc... je vais mettre en "suspend" le scanner... et attendre demain.

Mais sinon... je vais bosser pour lui faire une ramper led lumineuse... cela devrait aider à qu'il y voit plus clair...

Partager ce message


Lien à poster
Partager sur d’autres sites

@Bosco2509, pour ce genre de procédé, oui de la lumière il en faut, et pas qu'un peu.
Au boulot on installe des systèmes de vision pour du contrôle dimensionnel, d'aspect ou relecture de codes barres et consorts. Dans le principe c'est un peu la même que le scan 3d.
Les caméras sont toujours associées à des leds de fortes puissances, genres que tu regardes pas en face.
C'est nécessaire pour que la caméra capte un maximum de détails.
Si tu regardes les systèmes de motion capture, il y a aussi un éclairage de couleur froide assez puissant et un fond noir.

Envoyé de mon ONEPLUS A6003 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

 OK ok ! Je note tout cela pour m'en souvenir ! 👍
J'adore apprendre de nouvelles choses... surtout quand celles-ce me sont utiles.
Encore merci pour tout ces précieux conseils !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon... là... j'en perd mon latin... 🤨

J'ai pris du ruban led... une alimentation pour ce dernier... je met tout cela sur le scanner...
Puis je recalibre mon scanner...
Puis je tente un premier scan...
Puis un second...
Et ainsi de suite... mais au bout de 10 tentatives... voilà ce que j'obtient (quelque soit le modèle) :

2050375307_Capturedcran(237).png.be80df433685675ebd93ec6300903b17.png

A chacune de mes tentatives... j'obtient un... "Cone Inversé" (la pointe vers le bas)... en lieu et place du modèle.
C'est à n'y rien y comprendre...

Donc... si quelqu'un peut m'expliquer pourquoi je passe d'un nuage approximatif où le modèle ressortait que très sensiblement... à un truc qui ne ressemble mêm pas au modèle... je suis preneur ! 🤔

Cela provient-il des leds ?
Pas assez puissante ?
Trop de reflets ?
Bref... je pige pas...

Modifié (le) par Bosco2509

Partager ce message


Lien à poster
Partager sur d’autres sites

juste comme ça, t'a un semblant de focal sur ton scanner ? tu peu faire une photos des capteurs ? ça me paraîs bizarre que ça parte en éclaté comme ça 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 5 minutes, cylon a dit :

juste comme ça, t'a un semblant de focal sur ton scanner ? tu peu faire une photos des capteurs ? ça me paraîs bizarre que ça parte en éclaté comme ça 

Oui... si c'est des lasers qu'on parle.
Ils ont ce qui s'apparente à une lentille qu'on peut tourner et régler, voir photos ci-dessous :

IMG_20190205_121202.thumb.jpg.a6ab028e2d01b95560820e244f850bb2.jpg

IMG_20190205_121228.thumb.jpg.3f1c5f7c47fcd8cf897ee08c693c399a.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi j'aurais fait l'inverse. Mettre dans le noir afin de ne capte que les faisceaux laser. Après je pense qu'il faut faire le point du laser pour avoir la ligne la plus fine possible.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 24 minutes, Basilic a dit :

Après je pense qu'il faut faire le point du laser pour avoir la ligne la plus fine possible.

Cela je m'en étais déjà aperçu lors du calibrage.
Si les faisceaux ne sont pas assez fin... le calibrage échoue.

Donc ce côté là... je pense que je ne peut pas me tromper.
Voilà ce que donne les faisceaux sur une feuille blanche (cela se voit mieux que sur le plateau, recouvert de scotch Bleu) :

IMG_20190205_124932.thumb.jpg.024be59c051e420accd6811150278a72.jpg

Alors... oui... cela se voit à l'oeil nu... l'un des faisceaux est plus "large" que l'autre.
Et... OUI... je l'ai réglé au maximum... il n'est pas possible de le régler plus fin.
Pour régler au plus fin, il faut tourner les lentilles jusqu'à qu'elles soient serrés et bloqués.
Et c'est le cas pour les 2 ici présent. Mais on voit tout même la différence...

Partager ce message


Lien à poster
Partager sur d’autres sites
à l’instant, Basilic a dit :

Ta feuille est horizontal ou vertical la?

A plat à l'horizontal... pourquoi ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, totonor a dit :

Tu n as pas essaye meshroom ?

Non... je ne connaissais même pas.
J'ai Meshlab déjà d'installé.
Mais avant d'utiliser un "logiciel de retouche", il faudrait pas avant avoir un modèle exploitable ? Non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je recommence une nouvelle calibration... en utilisant cette vidéo :

 

Je me suis rendu compte qe les lasers ne sont pas tout à fait correctement régler...
Voir photos ci-dessous :

IMG_20190205_131312.thumb.jpg.c6a1b2ce86b7e6050583b7ed01c7fa13.jpg

J'ai un peu... nettoyé les lentilles... rienq ue cela améliore un peu... mais les lasers sont trop espacés... comparer à la vidéo.
Je vais donc essayer d'affiner cela... un peu plus tard... là je dois m'absenter un moment.
Je m'en occuperai à mon retour...

Edit de 13h27 :

Ouais... un léger mieux... je commencer à cerner mes erreurs :

1902666325_Capturedcran(238).thumb.png.c9887918dedcb091e72b5f5fcda9223f.png

Bon... là je dois vraiment m'en aller... mais il y a déjà un léger mieux (au moins on discerne quelque chose)...

Edit de 17h04 :

Ahahahahahahahah ! Rien ne me résiste !
Bon... cela étant dit... cela a été un chouilla plus long que pour maitriser mon imprimante...

La preuve en image :

1811410381_Capturedcran(239).thumb.png.993b38441e5ded8f5001378c014874e2.png

Forcément... un éléphant... cela trompe énormément... Oh oui... l'humour de @fran6p fini par déteindre...
Non ! Là dans ce cas, l'éléphant en laiton, avec ses surfaces, certaines lisses et brillantes, d'autres sombres... toutent n'arrivent pas à être scanner.
Mais il y a du mieux.

En fait... tout était de ma faute... j'avais de toute évidence, fait que 15% du "Vrai" calibrage !
Quelle nouille suis-je donc... tant que je n'ai pas bu au moins mon 3e café de la journée ?
Cette question restera... un mystère même pour moi !

Et voilà... la preuve que les surface lisses, brillantes et sombres... ne ressortent avec cette autre modèle :

441196859_Capturedcran(240).thumb.png.77e081767cffee315725a25d5bf7a348.png

Le capuchon n'a pas été scanné... et idem pour les bandes noires.
Mais il y a du progrès !

Sinon pour revenir au soucis précédent du "cone"... cela venait de plusieurs facteurs :

1 > Le Scanner avait été de toute évidence mal assemblé (rappel : je l'ai reçu déjà monté)
2> Votre serviteur ici présent... avait démonté certains éléments... et les avaient mal remontés ou pas correctement.

Voilà voilà.
Il me reste plus qu'à améliorer tout cela... et surtout mes connaissances.

Modifié (le) par Bosco2509
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 7 heures, Bosco2509 a dit :

Non... je ne connaissais même pas.
J'ai Meshlab déjà d'installé.
Mais avant d'utiliser un "logiciel de retouche", il faudrait pas avant avoir un modèle exploitable ? Non ?

Hello bosco,

C'est un logiciel open source de photogrammétrie. Un pote a scanné quelques modeles, visibement cela semble pas mal du tout !

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 39 minutes, totonor a dit :

Hello bosco,

C'est un logiciel open source de photogrammétrie. Un pote a scanné quelques modeles, visibement cela semble pas mal du tout !

OK... dans ce cas... je vais aller étudier ce logiciel... et regarder cela de près... merci de l'info !

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×