Aller au contenu

Filament ABS

Metalzoid

Filament runout sensor + LED

Messages recommandés

Salut à tous ! 

Alors voilà. J'ai besoin de votre aide. 

J'ai un capteur de fin de filament, un switch classique comme pour X et Y, et j'aimerais ajouter une LED qui s'allume lorsqu'il y a du filament uniquement. 

Est-ce que vous pouvez m'aider à trouver une solution ? J'ai essayé de cherché mais en vain >< 

Merci tout le monde 😄

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, 

Je verrais bien un truc simple dans ce style.

La LED est allumée quand le filament est présent (switch appuyé)

Je pense que ça doit fonctionner

image.thumb.png.28e643d561a7f4fd93db231176ec8b0d.png

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Va falloir que tu apprennes à lire mes pensées 😂

On met 1N4xxx à la lace de n'importe quelle diode de la série, 1N4001 à 4007 par exemple.

Mais pour cette appli, le mieux c'est une 1N4148 (ou 1N914)

Où alors le luxe, une Schottky 1N5819, BAT48, BAT85, etc...

Tu as le choix

Partager ce message


Lien à poster
Partager sur d’autres sites

hannnn OK ! 😄😄 Merci professeur Géotrouvetout 😛 

Et un PNP ça peux pas marcher?

Modifié (le) par Metalzoid

Partager ce message


Lien à poster
Partager sur d’autres sites

par contre, la diode c'est entre la terre et la led ? 

et une diode zener ça marche ou pas ? 

Modifié (le) par Metalzoid

Partager ce message


Lien à poster
Partager sur d’autres sites

oui pardon, je voulais dire la masse (oui, je suis à la masse! 😄 )

c'est bon, j'ai des diode sous la main (ouf 😌)

donc je résume:

+5v => LED => diode=>GND

Et entre la diode et la led, je mets la résistance, le endstop, et vers la CM.

C'est bien ça ?

Mais faudrait pas mettre une petite résistance avant la LED pour la protéger ? 

Modifié (le) par Metalzoid

Partager ce message


Lien à poster
Partager sur d’autres sites

Re 😃 Il y a blem, cap'tain ! 

Bon, j'ai fait le circuit, tout bien soudé, niquel. 

Problème. Ca éclairé a peine .. Je me suis dis que la résistance était trop forte. J'ai ponté la résistance, effectivement ça marchait mieux. 

J'ai donc enlevé la résistance, tout ressoudé.

Et là, je sais pas ce qu'il se passe. Lorsque je j'appuie, RIEN. Par contre, si je mets mon doigts sur la patte de la LED, c'est mieux. 

Est-ce que j'ai mis la diode à l'envers ? Je l'ai mise avec l'anneau vers l'intérieure, soit vers la LED.

Tu peux m'aider ?? 😢 

Merci 😃 

Partager ce message


Lien à poster
Partager sur d’autres sites

@jmarie3D

Tu as raison, la diode ne sert à rien, c'est un reliquat d'un essai précédent que je n'ai pas enlevée.

Vire cette diode et remets une résistance (si tu as 470 Ohm ou 510 Ohm, essaie ces valeurs)

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut 😃 J'ai essayé de ponter la diode, et le problème c'est que la LED reste allumée en permanence. Je ne pense pas qu'une résistance change ça ^^ 

Tu es sur que un NPN ou PNP ne peux pas fonctionner ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah fait attends ...

Si on fait : +5V => Switch => LED => GND, ça ne peux pas fonctionner ? 

ou alors la puissance ne sera pas assez forte ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...