Aller au contenu

Filament ABS

cartes additionnelles Pause non voulu avec octopi


BenGamin

Messages recommandés

Bonjour a tous,

je rencontre un soucis avec mes prints lancé avec octopi. L'imprimante se met en pause de manière non voulu. Elle attend les instructions de la prochaine commande car Octopi ne capte pas le  "Recv: Ok".

Voir screen :

octopi.thumb.png.423a9ddd26f5ef8d265b224aa43ba5ad.png

Comme on le voit sur le screen le "ok" est collé au infos de température. Ce n'est donc pas prit comme un vrai "Ok", je lui envoi un "Fake Acknowledgement"et ça continu sans problème.

Mais ça m'oblige à tout le temps regarder si ça se passe bien...

Si je passe par un print avec un gcode placé sur la microsd, il n'y a pas de soucis, mais je perds le coté sympa d'octopi car soit je vais chercher la sd pour mettre le gcode en passant par mon PC, soit je transfert en wifi mais c'est super long (première étape PC - Octopi normal, ça prend quelques secondes, mais de octopi - l'imprimante, un pauvre gcode de 10Mo prend dans les 1 heure)

J'ai déjà changé le cable usb, vérifié les connections, ça ne change rien. Qui à une idée pour résoudre le problème ?

Info config :

- Anet A8 modifié en AM8 avec carte mère stock mise sous Marlin 1.1.9 avec Bltouch.

- Raspberry 3B+ avec octopi à jour (sur SSD, sans carte microsd)

Lien vers le commentaire
Partager sur d’autres sites

j'ai  rencontrer  le même  problème, je l'ai résolu en installant un debian sur le DD du RPI +  lancement du script d'installation d'octoprint.

 

je pense qu l'image fournis ne fonctionne vraiment qu'avec un carte  SD et non pour un DD ou SSD.

 

en espérant t'avoir donnée une bonne piste.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 2 heures, palouf34 a dit :

je pense qu l'image fournie ne fonctionne vraiment qu'avec une carte  SD et non pour un DD ou SSD.

Un support de stockage reste un support de stockage qu'il soit une carte SD, un HD, une clé USB ou un SSD.

Ça va faire bientôt quarante ans que je pratique l'informatique (y compris les cartes perforées 😉 ) et je n'ai jamais entendu que certaines distributions ne pouvaient tourner que sur un seul type de stockage de masse 😄 .

Le 16/04/2019 at 14:02, BenGamin a dit :

Raspberry 3B+ avec octopi à jour (sur SSD, sans carte microsd)

Comment as-tu mis à jour Octopi (sudo apt-get update && sudo ap-get dist-upgrade ?)?

Le SSD comment est-il alimenté? Via le PI, une alimentation externe? Comment -est--il connecté sur le PI (via USB)?

Quelle vitesse de communication entre le PC et la carte via le câble USB?

Sur un Pi, la gestion des ports USB est partagée avec le port Ethernet, comment s'effectue la liaison réseau entre le Pi et l'ordinateur (Wifi, Ethernet)?

Quels plug-ins sont installés en plus de ceux inclus dans la distribution?

Ce problème arrive parfois mais sa résolution n'est pas aisée: voir par exemple ce post.

Lien vers le commentaire
Partager sur d’autres sites

il y a 2 minutes, Janpolanton a dit :

t'en poses des questions toi..

J'suis curieux de nature 😉 .

Je trouve que les utilisateurs ne donnent pas suffisamment d'informations (mieux vaut trop que pas assez  (c'est ce que me dit ma petite femme)) 🤪

Lien vers le commentaire
Partager sur d’autres sites

Il y a 6 heures, palouf34 a dit :

j'ai  rencontrer  le même  problème, je l'ai résolu en installant un debian sur le DD du RPI +  lancement du script d'installation d'octoprint.

en espérant t'avoir donnée une bonne piste.

Pour moi c'est l'inverse, trop galère avec une debian + installation octoprint avec script (ce que j'avais fait au début), ralentissement important, etc...

Comme quoi...

Il y a 2 heures, fran6p a dit :

Comment as-tu mis à jour Octopi (sudo apt-get update && sudo ap-get dist-upgrade ?)?

Le SSD comment est-il alimenté? Via le PI, une alimentation externe? Comment -est--il connecté sur le PI (via USB)?

Quelle vitesse de communication entre le PC et la carte via le câble USB?

Sur un Pi, la gestion des ports USB est partagée avec le port Ethernet, comment s'effectue la liaison réseau entre le Pi et l'ordinateur (Wifi, Ethernet)?

Quels plug-ins sont installés en plus de ceux inclus dans la distribution?

Ce problème arrive parfois mais sa résolution n'est pas aisée: voir par exemple ce post.

Octoprint en 1.3.10, direct sans passer par une maj.

Ssd alimenté par le pi, alim 3A. Je ne pense pas que ça vienne de là, j'aurais de gros ralentissement pour les trucs plus gourmand comme la vidéo, non ?

vitesse à 115200 bauds.

Le Pi est en wifi.

plugin

- BLTouch plugin

- Bed visualizer

- CuraEngine (<= 15.04)

- EEPROM Marlin editor

- Fan speed Control

- Marlin Flasher

- Nevbar température plugin

- Octolapse

- Printer stats

- Tab Order

- Touch UI

 

J'ai remplacé par un troisième câble, plus court, ça semble ne plus le faire. A voir avec un print assez gros.

 

Edit : je verrais à faire le ménage dans les plugins aussi si ça ne marche pas

Voir aussi de regarder de ce coté la : https://www.framboise314.fr/le-port-serie-du-raspberry-pi-3-pas-simple/ mais je ne suis pas assez calé pour voir si ça correspond à mon problème. Notamment si la gestion de l'horloge pour le baudrate est la même pour du serial par les GPIO ou serial par USB.

Si quelqu'un peut répondre...

Modifié (le) par BenGamin
Lien vers le commentaire
Partager sur d’autres sites

Salut :)
Lance en mode sans échec pour voir si cela peut venir d'un plugins (mais je ne pense pas).
Je pense que le mieux reste quand même la carte SD. Le rpi doit alimenter le ssd, et avec en plus l'écran pour touchUI, ça commence à faire beaucoup.


Envoyé de mon iPhone en utilisant Tapatalk

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Bon j'ai toujours le problème avec un 3ieme câble plus petit.

Plugin, je ne pense pas non plus. Je vais tout de même tenter en sans échec sans grande conviction. Ou je verrai avec une carte sd toute fraiche comme on dit.

TouchUI c'est juste pour l'interface téléphone, je n'ai pas d'écran tft.

Apparement mon problème est courant et est matériel. Je vais voir avec la modif pour passer le port série en prioritaire par rapport au bluetooth pour que l'horloge du baudrate soit correct (de ce que j'ai compris du lien que j'ai mis avant...).

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...