Aller au contenu

Filament ABS

- autre - TFT35 et GT2560revA+


yopla31

Messages recommandés

J'ai reçu un magnifique MKS TFT35v1.0 Pour installer soit sur ma CR-10s, soit sur ma Ender-5.

Dans les 2 cas, la carte mère est une GEEETECH GT2560 revA+. Le problème, c'est que le TFT présente un connecteur 8 pins amputé de la pin [haut-gauche] détrompeur vers le [haut] :

image.jpg en vert et noté "Motherboard Interface".

Sur la GT2560, j'ai 2 connecteurs 10pins identifiés "LCD" et "SD card" comme ceux de la carte d'origine de la CR-10 :

GT2560A .png

 Sur ma Ender-5, le "LCD" est connecté au CN3 du LCD d'origine, et le "SD card" au CN2 (nécessaire pour la sélection par le bouton). La Ender-5 est alimentée en 24v, alors que la CR-10S est restée en 12v. L'idée, c'est d'avoir une interface sympa, un lecteur SD et USB, et avoir la possibilité de faire évoluer l'imprimante (module Wi-Fi, auto extinction et allumage de l'imprimante, redémarrage d'impression après coupure de courant).

Mon problème est :

     Comment branché mon TFT ?

 Pour info, sur la MKS GEN-L, le TFT se connecte au connecteur "AUX-1" de 8 pins, c'est donc facile mais hors sujet.

Merci d'avance pour votre aide.

Modifié (le) par yopla31
Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, yopla31 a dit :

la carte mère est une GEEETECH GT2560 revA+.

je n'ai pas de solution, mais @cmatec a réussi à brancher un TFT sur une carte emotronic donc peut qu'en s'en inspirant...

 

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Le 22/04/2019 at 23:17, pascal_lb a dit :

je n'ai pas de solution

Merci pour le tuyau. J'ai un peu cherché en m'inspirant des infos de @cmatec. J'ai alimenté le TFT depuis le connecteur de la GT2560. Ça m'a permis de le mettre à jour et découvrir les menus de l'exemple fourni avec le firmware. J'ai donc trouvé la correspondance des contacts du connecteur LCD, SD CARD et le schéma général :

1982720035_LCDPIN.jpg.d8892dc30c86222c50cd32d8b6bec8a0.jpg 2065441494_SDPIN.jpg.36bfb01b0e43cb3f24a980cb899e9ead.jpg Hardware_GT2560_RevA_1.thumb.png.5a8e875e617b081693195cb06da1f9b8.png

J'ai bien tenté de connecter le TXD du TFT35 au RXD1 ou 2 de la GT2560, et RXD du TFT35 au TXD1 ou 2 de la GT2560 avec une vitesse de 250000 Bauds dans le fichier de configuration, mais juste par naïveté... avec mon firmware de GT2560 inchangé ! Evidemment, aucun miracle....

En attendant une intervention divine ou de @cmatec (peut-être est-ce la même chose ??🤔), je me posais quelques questions :

  • Peut-on avoir le LCD d'origine et le TFT35 en même temps, si les signaux utilisés ne sont pas les mêmes ? Il y a bien 2 lignes série sur le connecteur LCD : TXD1/RXD1 et TXD2/RXD2.
  • L'affichage du boot de la GT2560 (boot de Marlin) s'affichera-t-il sur le TFT35 ?
  • Comment trouver les infos de paramétrage des liaisons série (vitesse, etc) du connecteur LCD de la GT2560 ?

@pascal_lb, aurais-tu des réponses à m'apporter ?

Lien vers le commentaire
Partager sur d’autres sites

Il y a 12 heures, yopla31 a dit :

aurais-tu des réponses à m'apporter ?

hélas non 😞 ça dépasse largement mes compétences

Il y a 12 heures, yopla31 a dit :

L'affichage du boot de la GT2560 (boot de Marlin) s'affichera-t-il sur le TFT35 ?

non car le TFT a son propre firmware https://github.com/makerbase-mks/MKS-TFT/tree/master/MKS-TFT3.5

Lien vers le commentaire
Partager sur d’autres sites

Je viens de rebrancher ma MKS GEN-L que j'avais écartée car trop d'instabilité dans la température de buse. J'y ai connecté le TFT35 sur le port AUX1 en laissant le LCD d'origine de la Ender-5. Et effectivement, on a les 2 afficheurs actifs, et le TFT35 envoie bien les commandes à la GEN L. Par contre, j'ai retenté des tests de maintien de chauffe de buse, toujours aussi instables. J'ai bien tenté de faire des PIDs en 8 et 16 itérations, mais je ne retrouve pas les mêmes valeurs sur 2 PIDs en suivant ! Le résultat du premier PID en 8 itérations à 200° m'a donné des valeurs qui me permettent une certaine stabilité de température, mais rien à voir avec la courbe plate de température fournie par la GT2560 !

Je n'y connait pas grand chose, mais quand on voit, ce que je pense être, des mosfets refroidis par des radiateurs alu sur la GEEETECH, et ceux tout rikiki et pas refroidi de la GEN L...

Donc GT2560 ré-installée en urgence. J'ai commandé des 12864 en attendant.

61s%2BMH8D8yL._SL1000_.jpg

Je crains que le TFT35 et la GT2560 ne fasse pas bon ménage.

Modifié (le) par yopla31
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...