Aller au contenu

Filament ABS

Hebign

Ecran MKS TFT35 sur MKS Gen 1.4, Possible ?

Messages recommandés

Bonjour à tous,

image.png

Je viens de recevoir cette écran, pensant pouvoir le brancher sans soucis sur ma MKS Gen 1.4 mais petit soucis, le cable de l'écran ne comporte que 8pins contre 10pins sur la MKS Gen 1.4...

Ok je l'avoue, j'ai pas pensé à regarder ce détail... Du coup, est-ce que c'est mort pour le brancher ou y a t'il une combine ?

Merci d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 13 minutes, Hebign a dit :

Du coup, est-ce que c'est mort pour le brancher ou y a t'il une combine ?

Je crains que oui (c'est dead 😉 ).

Des plus pointus que moi pourraient éventuellement expliquer comment utiliser des pins "libres" pour les réaffecter mais ça, je ne sais pas faire.

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Salut ,

Quel est le souci , quand je fais une recherche sur la MKS Gen1.4 , j'obtiens ça :

71vlwdX4btL._SL1000_.jpg

 

Or il y a bien une connexion TFT 8 pins dessus .

Modifié (le) par sha

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 9 minutes, sha a dit :

Salut ,

Quel est le souci , quand je fais une recherche sur la MKS Gen1.4 , j'obtiens ça :

71vlwdX4btL._SL1000_.jpg

 

Or il y a bien une connexion TFT 8 pins dessus .

Ok, pas faux, je l'avais pas remarqué celle là ! Bien vu ! Si c'est bon tu me sauves la mise là !

En revanche, pour le sens de l'ergot de la prise, comment savoir ?

Et une autre question pour laquelle j'ai pas trouvé de réponse, sur le site d'achat, c'est marqué qu'il y a rien a faire au niveau firmware (marlin), mais actuellement je suis déclaré comme utilisant l'écran d'origine de la melzi, donc que dois-je mettre maintenant pour ce tft ?

J'ai rien trouvé dans la liste de Marlin qui correspond, je suis sous la version Marlin bugfix 2.0.x

Modifié (le) par Hebign

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors là ? , sur ce que j'ai pu voir  sur ce type de carte , l'ergot est vers l'extérieur de la carte , seulement les pins ne sont pas affectées à l'identique , sur la MKS base 1.6  (et d'autres) il y a un +5v et un ground , et 5 pins certainement Data . Or sur la Gen 1.4 , il y a 2 x +5v ,2 x ground  et 4 pins Data .

Je ne suis pas assez calé en transfert de Data d'affichage pour t'orienter sur comment faire correspondre tout ça et le câbler. ☺️

 

Edit:

pour le TFT32 , il y a un firmware à mettre sur carte SD et à insérer dans le lecteur lors de l'allumage afin que la mise à jour se fasse automatiquement, Je crois qu'il n'y a rien à modifier sur le Marlin , ça se fait tout seul ...il y a de fortes chances que cela soit pareil pour le TFT35 .

Modifié (le) par sha
complément de requète

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 22 minutes, Hebign a dit :

J'ai rien trouvé dans la liste de Marlin qui correspond, je suis sous la version Marlin bugfix 2.0.x

Tu n'as rien à ajouter / modifier dans Marlin.

Cet écran possède son propre firmware. Il faut juste déclarer dans son fichier de configuration que tu utilises Marlin et la vitesse de connexion entre cet écran et la carte.

Sur la sérigraphie de la carte, il n'est pas écrit TFT mais AUX1.

MksGenV14-Pinout.png.e837165c3a85b7a817152963b8fcd84a.png

Je n'ai pas trouvé de schéma équivalent pour l'écran (rien de disponible sur le Github de MKS) 😞 pour connaître l'implantation du câblage.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok, c'est déjà un très bon début, tu m'as remis le sourire ! 😉

Je vais me pencher là dessus on va voir. Mais si j'ai bien compris, faut que je télécharge le firmware de l'écran pour pouvoir le modifier vu que la modif ce fait par sd-card...

Partager ce message


Lien à poster
Partager sur d’autres sites

En revanche, faut bien que je commente cette ligne, elle a plus lieu d'être non ? :

// Factory display for Creality CR-10
// https://www.aliexpress.com/item/Universal-LCD-12864-3D-Printer-Display-Screen-With-Encoder-For-CR-10-CR-7-Model/32833148327.html
//
// This is RAMPS-compatible using a single 10-pin connector.
// (For CR-10 owners who want to replace the Melzi Creality board but retain the display)
//
#define CR10_STOCKDISPLAY

//

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, j'ai débranché mon écran d'origine, branché le mks tft35, ergot vers l'extérieur de la carte, ça a fonctionné du premier coup............ Content !

Merci de votre aide !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bien joué ! par contre , tu ne précises pas si tu as fais cette modif sur le #Define_STOCKDISPLAY ...au cas où d'autres s'interrogeraient .

Modifié (le) par sha

Partager ce message


Lien à poster
Partager sur d’autres sites

On peut normalement utiliser concomitamment les deux écrans branchés sur la carte.

Par contre, je crois me souvenir avoir lu quelque part (mais où?) que brancher en plus la carte via Octoprint en USB pouvait poser des problèmes quand on utilisait cette configuration biécran (à confirmer / infirmer).

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pas encore commenté #define CR10_STOCKDISPLAY, en faite si, mais j'ai pas encore téléversé la modif...

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors je viens d'essayer de téléverser, mais je rencontre un problème que j'attendais pas... ADVANCED PAUSE FEATURE !!! Qui me réclame un écran pour pouvoir fonctionner !

Est-c'qu'il y a une alternative ou cela va t'il m'obliger à laissé décommenté  #define CR10_STOCKDISPLAY ????!!!

 

Sans titre.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu veux passer en Marlin 2.0 aussi ?

Pourquoi ne pas d'abord faire évoluer ton firmware vers Marlin 2.0 en version stock (donc écran LCD) , puis par la suite installer le TFT via la SD .

Là ,si la machine ne s'attend pas à trouver un TFT , elle risque de râler^^ , alors qu'une fois le Marlin  2.0 installé , le firm du TFT se chargera de lui expliquer que maintenant c'est lui qui commande .

Modifié (le) par sha
déconcentré par ma pissaladière :(

Partager ce message


Lien à poster
Partager sur d’autres sites

T'as surement raison, surtout que l'écran gère l'option de pause...

Pour le moment j'ai téléversé en laissant l'écran d'origine décommenté... on verra une fois que j'aurais pris en main les options de mise à jour du firmware de l'écran, j'ai un peu tout survolé mais pas le temps de m'y plonger complètement tout de suite...

Et j'aimerais bien savoir s'il est possible de rajouter des menus, comme par exemple celui pour le touchmi, le décalage du Z pour l'offset, le babysteping, les réglages de jerk, accélération et vélocité etc...

Et du coup, la prise usb de l'écran sert à quoi ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai jamais testé l'USB , mais je crois qu'il a le même rôle que le slot SD card , y mettre éventuellement ses fichiers Gcode pour les imprimer .

Partager ce message


Lien à poster
Partager sur d’autres sites

@Hebign

Pourrais-tu éventuellement compléter ton profil afin que ton imprimante y apparaisse: c'est plus facile pour t'aider sans avoir à relire tout le post.

Concernant l'ajout de "menus" sur le TFT, c'est réalisable mais ce seront des boutons (pas des menus) et il faudra mettre les mains dans le cambouis 😉  .

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, fran6p a dit :

@Hebign

Pourrais-tu éventuellement compléter ton profil afin que ton imprimante y apparaisse: c'est plus facile pour t'aider sans avoir à relire tout le post.

Concernant l'ajout de "menus" sur le TFT, c'est réalisable mais ce seront des boutons (pas des menus) et il faudra mettre les mains dans le cambouis 😉  .

J'ai une CR10 complètement modifié, bed 220v/750w avec bed mirroir, direct drive AIO EVO, Titan Trianglelabs, Touch-MI, SFU1204, guidage linéaire XYZ, MKS Gen 1.4 avec 3 TMC2208 XYZ et un LV8729 pour le E et frame de renfort complète.
Le montage des rails est récent et perfectible, tout n'est pas encore bien réglé, notamment le Y et les SFU1204.

Je vais essayer de mettre une photo dès que je pourrais.

Prochaine modif, passage à une board 32bit plus module permettant d'éteindre l'imprimante en fin de print et voir module wifi également.

Actuellement je test le linear advance avec marlin bugfix 2.0.x, mais je rencontre des soucis avec le kfactor test pattern, tous mes déplacements ce font par saccade et je comprend pas pourquoi......

Pour la modification du MKS TFT35, je vais attendre d'avoir du temps à disposition pour m'y pencher sérieusement car là c'est pas le cas...

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut tout le monde,

Je rencontre un petit problème pour configurer deux boutons supplémentaire pour mon touch-mi, je m'explique.

Voici la partie du fichier config concernée originale :

#set number of  "More" button
>moreitem_pic_cnt:0

#edit command for 1~7 "More" button,each command must be separated by semicolon ";"
>moreitem_button1_cmd:G28 X0;

>moreitem_button2_cmd:G28 X0;

>moreitem_button3_cmd:G28 Y0;

>moreitem_button4_cmd:G28 Y0;

>moreitem_button5_cmd:G28 Z0;

>moreitem_button6_cmd:G28 Z0;

>moreitem_button7_cmd:G28;

#how many "More" button display on screen interface
>morefunc_cnt:0

#command setting on button1~7
>morefunc1_cmd:G28;
>morefunc2_cmd:G28;
>morefunc3_cmd:G28;
>morefunc4_cmd:G28;
>morefunc5_cmd:G28;
>morefunc6_cmd:G28;

 

Et voici ma version :

#set number of  "More" button
>moreitem_pic_cnt:3

#edit command for 1~7 "More" button,each command must be separated by semicolon ";"
>moreitem_button1_cmd:M851 Z0; G28; M500; G1 Z0 F200; M211 S0;

>moreitem_button2_cmd:M211 S1; M500; G28;

>moreitem_button3_cmd:G28 Y0;

>moreitem_button4_cmd:G28 Y0;

>moreitem_button5_cmd:G28 Z0;

>moreitem_button6_cmd:G28 Z0;

>moreitem_button7_cmd:G28;

#how many "More" button display on screen interface
>morefunc_cnt:0

#command setting on button1~7
>morefunc1_cmd:G28;
>morefunc2_cmd:G28;
>morefunc3_cmd:G28;
>morefunc4_cmd:G28;
>morefunc5_cmd:G28;
>morefunc6_cmd:G28;
>morefunc7_cmd:G28;

 

Je ne comprend pas pourquoi lorsque je met 2 à :

#set number of  "More" button
>moreitem_pic_cnt:3

Le deuxième bouton que j'upload apparait mais avec 3 points à l'intérieur au lieu de ce que j'ai dessiné.

Et si je met 3, j'ai bien mes deux boutons qui apparaissent normalement, mais avec en plus le bouton avec les 3 points... Ce qui je crois, j'ai pas encore vraiment eu le temps de tester, mais ça me décale mes commandes, car le bouton avec les 3 points vient se placer avant mes 2 boutons, du coup il prend les commandes de mon premier bouton et décale du coup les commandes de mon dernier bouton, qui si je le teste, normalement devrait avoir aucun action du coup !

Quelqu'un a-t'il déjà eu ce problème ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...