Aller au contenu

Filament ABS

Pierrot

Utiliser la sortie extruder2 pour remplacer celle d'un moteur deffectueuse

Recommended Posts

Bonjour à tous,

j'ai acheté un kit kossel mini il y a quelques mois et j'ai un "petit" soucis. J'étais à la phase de tests sur la qualité des impressions quand le moteur des X m'a lâché (donc à un moment, tout marchait bien)... enfin, j'ai cru car après quelques tests et échanges, j'ai réalisé que le moteur est bon. Après donc avoir changé le stepper driver (A4988) et le moteur, le problème persiste. J'en ai conclus que le soucis vient de plus haut dans la chaîne: Arduino 2460 ou RAMP 1.4 Mais plutôt que de changer ces deux parties, je voulais savoir s'il est possible d'utiliser la sortie de l'extruder2 (qui n'est pas utilisé dans mon modèle d'imprimante) pour remplacer celle qui ne répond plus.

J'ai bien vue des choses dans les fichiers de configuration Marlin... mais je suis quand même bien dans le brouillard.

La config correspondant à mon imprimante dans Configuration.h:

MOTHERBOARD 33

La configuration correspondant à la sortie qui ne répond plus (dans pins.h)

#define X_STEP_PIN          2
#define X_DIR_PIN           3
#define X_ENABLE_PIN        -1
#define X_STOP_PIN          16

... et celle de l'extruder qui ne me sert pas (toujours dans pins.h)

#define E1_STEP_PIN        36
#define E1_DIR_PIN         34
#define E1_ENABLE_PIN      30

Est-ce que vous savez si ce genre de manip est possible?... Et si oui, quelle configuration je dois mettre?

Merci d'avance pour vos lumières. :)

Pierrot

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Fourmi,

je l'ai mis en pièce jointe... mais en fait, on a trouvé la solution. Je ne sais pas si c'est bien orthodoxe mais en tout cas ça fonctionne nickel.

Si tu as mieux à proposer je suis quand même preneur pour ma culture personnelle ;)

 

À+

pins.h

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est juste quand j'ai vu tes pins du X,j'me suis dit la y a un soucis car ce ne sont pas les bons mais vu que tu les as remplacé dans le fichier fourni .

Par contre je vois que tu as commenter :

    //#define X_STEP_PIN         54
    //#define X_DIR_PIN          55
    //#define X_ENABLE_PIN       38


cela ne marcher pas ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est justement pour ça que je voulais utiliser la sortie du deuxième extruder. La sortie de ce moteur a grillé et plutôt que de changer la ramp et l'arduino, je voulais utiliser la sortie de libre. Et ça marche nickel.

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme donc je suis un "3D Newbie" sur ce forum :D... est-ce qu'il y a quelque part un flag pour indiqué que le problème est résolu?

(zavé vu comme je suis carré?! ^_^)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×