Aller au contenu

Filament ABS

rmlc460

Disco en USB

Messages recommandés

Salut à tous

Bon, je sais, je suis une bille, mais je n'ai que des problèmes. à commencer par mon inaptitude à piloter ma disco en USB. C'est-à-dire pour lui envoyer un code en direct.

J'ai paramétré W10 à priori correctement, puisque lorsque je la mets sous tension, l'ordi me signale bien l'arrivée de l'USB Serial Converter. La découverte d'un nouveau périphérique inconnu se fait donc normalement, avec un port USB en COM10.

Mais à partir de là, que j'utilise Pronterface ou Repetier, je ne peux pas connecter quoi que ce soit.

Zut, zut et rezut.! Suis énervé...

Modifié (le) par rmlc460

Partager ce message


Lien à poster
Partager sur d’autres sites
Guest flykiller

tu dois pas avoir de périphérique inconnu, installe les driver que tu trouveras dans la section tuto du site de dagoma

Partager ce message


Lien à poster
Partager sur d’autres sites

peut-être un  problème de vitesse de com.

Dans repetier "configuration" =>"réglage imprimante"=>"port=auto" et en dessous du port t'as la vitesse faut voir celle de l'imprimante et mettre la même ou alors tu essaie avec toutes les vitesses jusqu'à avoir la bonne.

Partager ce message


Lien à poster
Partager sur d’autres sites

A priori, c'est ce que j'ai fait. D'ailleurs, je n'ai pas d'erreur dans le gestionnaire de programme: dès la connexion apparaît un nouveau périphérique dans la rubrique Contrôleur de bus USB: USB Serial Converter. Et dans la rubrique Ports (COM et LPT), apparaît bien le USB Serial Port (en COM10), avec le bon pilote de chez FTDI

Après, dans le Panneau de Configuration/Tous les panneaux de configuration/Périphériques et Imprimantes, c'est là que ça ne sait pas ou placer le périphérique, et que ça ne lui trouve pas de fonction particulière.Cela pourrait-il provenir de W10?

En tous cas, même en disant à PronterFace de se connecter sur ce fameux COM10, il n'y a pas de réponse. Mais donc, je le répète, aucune erreur dans Windows.

Pour la vitesse, je suis calé à 115200 bauds

Tel que je suis parti, je ne suis pas prêt de brancher Titine sur mon serveur réseau...Si vous avez une idée...

Modifié (le) par rmlc460

Partager ce message


Lien à poster
Partager sur d’autres sites

En fait, le gestionnaire ne m'indique pas un périphérique inconnu, mais il m'indique FT232R USB UART dans une rubrique "Non spécifié".

Et je viens de redémarrer, pas mieux sous Pronterface: même en ayant passé la vitesse à 9600 Bauds des deux côtés

Partager ce message


Lien à poster
Partager sur d’autres sites

salut,

Tu télécharges http://www.usb-drivers.org/wp-content/uploads/2014/12/CDM-2.08.28-WHQL-Certified1.zip

Tu dezip dans un coin.

Dans le gestionnaire de périphériques, clic droit sur FT232R USB UART et choisi mettre le pilote à jour

Choisi rechercher un pilote sur mon ordinateur

Clic sur le bouton parcourir et choisi le chemin du coin ou tu as dezzipé les drivers et coche la case pour inclure les sous-dossiers

Redemarrer le pc une fois terminé

 

++

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon sang mais c'est bien sur!!!

Merci, @flykiller. Et pour être complet, ça fonctionne très bien, que ce soit dans Pronterface ou Repetier.

Ceci dit, ce n'est pas une option dans les paramètres du pilote: là, on est limité à 115200 bauds. Mais ça fait rien, ça marche très bien.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, rmlc460 a dit :

avec Cura, je n'ai pas trouvé comment envoyer un fichier directement sur l'imprimante (sans passer par la carte μSD).

"Comment envoyer un fichier sur l'imprimante" tu parles bien d'imprimer? Et si c'est sans la carte microSD, tu parles bien d'imprimer en USB? 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Guest flykiller

clique droit sur l'icone du milieu ( le lot de trois icones en haut), et après tu selectionnes ton mode

 

edit: celui en forme de disquette et oublie pas de configurer ton cura comme ton pronter, COM, bauds ..

Modifié (le) par flykiller

Partager ce message


Lien à poster
Partager sur d’autres sites

@Freedam: Oui, je souhaiterais envoyer le fichier directement par USB. Sans passer par la manip de carte.

Et @flykiller J'utilise la version By Dagoma, et là, seulement 2 icônes en haut Donc pas de disquette. Et pas d'option dans le menu fichier...

Partager ce message


Lien à poster
Partager sur d’autres sites

donc la question n'étais pas :

avec Cura, je n'ai pas trouvé comment envoyer un fichier directement sur l'imprimante (sans passer par la carte μSD).

mais :

avec Cura by Dagoma, je n'ai pas trouvé comment envoyer un fichier directement sur l'imprimante (sans passer par la carte μSD).

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah c'est tout de suite plus clair! Parce qu'il me semble bien qu'il suffit d'aller dans fichier puis imprimer. Dés que je peux je vérifie ça! 

Partager ce message


Lien à poster
Partager sur d’autres sites
Guest flykiller

bah vire le by dagoma, prend la version normale en réalité c'est moins compliqué de prendre la version normale que la dagoma qui te bride,te bloque et bug 

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de vos réponses. Va falloir que je me mette à Cura "nature", en effet. D'autant que soit j'ai pas de bol, soit je suis très incompétent. Je pense qu'à vrai dire, c'est un peu des 2.

Parce que j'ai aussi chargé Repetier et Pronterface, et dans les 2 cas, impossible de charger un stl et de le balancer.

Sous Pronterface, la ligne d'état m'annonce en permanence le chargement, mais ça ne s'affiche jamais sur le plateau. J'ai essayé de le réinstaller, mais pas mieux. Pourtant, je peux me connecter à l'imprimante et actionner les moteurs et l'extrudeur en manuel.

Pour Repetier, je ne me suis pas encore vraiment coltiné les réglages... C'est déjà assez compliqué comme ça, je verrai un peu plus tard! Mais j'ai noté qu'en manuel, il ne prend pas en compte le palpeur: par défaut, le Z0 est la position des moteurs au démarrage. Je peux monter, mais pas descendre.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, rmlc460 a dit :

 

Pour Repetier, je ne me suis pas encore vraiment coltiné les réglages... C'est déjà assez compliqué comme ça, je verrai un peu plus tard! Mais j'ai noté qu'en manuel, il ne prend pas en compte le palpeur: par défaut, le Z0 est la position des moteurs au démarrage. Je peux monter, mais pas descendre.

ca c'est normal. Au démarrage, Marlin défini les zéros à la position actuel. Il y une protection pour ne pas descendre sous zéro.

pour avoir les bons zéros,tu doit donc lancer les commandes

G28 X

G28 Y

G28 Z (ou G29)

Attention si tu as un offset à rentrer  il y a 2-3 trucs  à faire en plus. Attention aussi au si ton offset est pile poile à zéro, 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×