Aller au contenu

Filament ABS

Legeantbleu

[Tuto] Installer un "3d Touch" sur U30 Pro ou LK4 Pro.

Messages recommandés

Sorry, i don't speak french. But it appears that this printer is quite popular among my french friends across the pond.

 

I've compiled and modified the stock Longer LK4 Pro/Alfawise U30 Pro Marlin firmware to be compatible with BLtouch V3.1 (newest revision). Simply use the mount linked in the post, compile, and upload to your machine! NOTE: All probe offsets hard coded in the firmware were measured with that mount. If you use a different mount your offset settings will likely change! Always measure if you are unsure! You will then need to set your M851 Z offset in Arduino Serial monitor (See Page 5 of this PDF: https://locxess.de/3d/BLTouch_Anleitung_englisch.pdf). Make sure to do an M500 to save all settings including G29 if you'd like to use M420 S1 in your start GCode.

 

I've cut out most of the settings for the U20 Pro to save some on board storage space. 5 X 5 grid is default but can be changed if you want higher resolution. That's the beauty of Marlin!

 

Download (Original post): https://www.reddit.com/r/Longer3d/comments/f1t0b1/lk4_pro_alfawise_u30_pro_bltouch_enabled_marlin/ 

 

I hope this helps some of you to streamline your BLTouch installation and WOW what an upgrade to print quality!!!! 

 

If you haven't calibrated your extruder steps for this machine you really should as well. This in combination with the BLTouch will give you AMAZING prints.

 

Good luck and HAPPY PRINTING!!

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 1/31/2020 at 1:10 PM, knarf125 a dit :

Hola! Tell me, I followed this tutorial, everything was going well ... except that after the upload, well the screen of my U30pro does not light up anymore, and obviously she is screwed up ...
I'm scared there, plugged into USB on my octoprint, it does not happen to connect to it, and on Pronter I have error messages in shambles. 
Have you already had a precedent?

 

here is what i have on pronterface: 
Connecting ...
start
Printer is now online.
echo: Marlin 1.1.9
echo: Last Updated: 2018-08-01 | Author: (none, default config)
echo: Compiled: Jan 31 2020
echo: Free Memory: 1357 PlannerBufferBytes: 1232
echo: EEPROM mismatch version (EEPROM =? Marlin = V55)
echo: Hardcoded Default Settings Loaded
[ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed
 

You need to First send command M502 to clear EEPROM and reset to factory settings, then Make sure to save those changes with M500. once reset you will be able to flash the firmware. Remember to measure your Z offset, run a G29, then SAVE all those values with M500 again so they persist in the EEPROM. Hope this helps.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai installé le BLtouch une première fois avec  les système de refroidissement d'origine et tout à fonctionné … 


Maintenant je viens d'installer le fang de demontrack, j'ai donc refais l'installation du BLtouch, modifié dans marlin les paramètres de distance par rapport à la buse et recommencé les manip de ce tuto, mais quand je fais un G28 la buse essaie de traverser mon plateau … que faut il régler ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans mon cas avec une LK4 pro également j'ai eu le même soucis. Il ne faut pas visser directement le BL-touch sur le support car dans ce cas il est trop haut et ne "déclenche" pas avant que la tète ne touche le plateau. Il faut donc intercaler des rondelles ou les ressorts fournis (très serrés, il ne faut pas que ça bouge).

Ensuite il faudra régler le Z-offset pour indiquer la distance entre le palpeur et la tête sur cet axe. Il y a plusieurs tuto sur le forum qu parlent de ça.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 9 minutes, Thierry94 a dit :

Effectivement j'ai le même problème la buse touche avant que le BLtouch ne puisse se déclencher …. je vais ajouter des rondelles
Merci Fonzy pour le tuyau

Pour ma part, j'ai récupéré les entretroises en plastique blanc qui servaient à l'installation des ventilo sur le fang d'origine. C'est parfait pour mettre le BLtouch à la bonne hauteur (car je me suis aussi fait avoir quand j'ai monté le mien et il serait peut etre intéressant d'ajouter dans le tuto la distance mini-maxi entre la pointe du bltouch et la buse).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonne idée mais trop tard j'ai mis des rondelles … je garde l'idée des entretoises pour le prochain démontage.
Une fois le BLtouch mis à hauteur ça marche beaucoup mieux 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello j'ai voulu essayer avec le geetech 3D touch, en faisant attention à bien cabler les fils gnd 5v d7.

Lors de l allumage le 3dtouch geetech sort 2 fois la pin et la rentre. J'envoie la commande g28. Axe X et Y OK, mais axe Z au lieu de descendre, il monte légèrement et plantage de l imprimante...

La je ne sais pas ce qu'il faut modifier pour rendre compatible...

Partager ce message


Lien à poster
Partager sur d’autres sites

Si le 3Dtouch sort et rentre sa sonde, c'est qu'il fonctionne.

Tu as certainement un problème logiciel ( as tu bien flashé ton imprimante pour activer le 3DTouch ? ) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai un petit soucis, j'ai bien installer mon bl touch, tout fonctionne, il prends en compte la mesures mais ne compense pas pendant l'impression .... j'ai bien rajouté un G29 dans mon gcode de démarrage mais rien n'y fait ... 

Avez vous une idée du problème ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, Vilab a dit :

Si le 3Dtouch sort et rentre sa sonde, c'est qu'il fonctionne.

Tu as certainement un problème logiciel ( as tu bien flashé ton imprimante pour activer le 3DTouch ? ) 

oui j'ai flash avec le code fournis en première page, j'ai meme par rapport au site de geetech 

3Dtouch Geetech

decommente la ligne 
"#define NUM_SERVOS 3" et mis #define NUM_SERVOS 1

le reste je n'ai pas trouvé, c'est deprecated si je rajoute...

et les commande fournis pour tester sa sonde 

"M280 P0 S10 ; pushes the pin down" n'ont aucun effet sur la mienne.

Du coup je ne sais pas quoi faire avec le 3DTouch pour le rendre fonctionnel 😢

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Créer...