Aller au contenu

Filament ABS

Questions sur le réglage du Z offset sur imprimante avec autolevel.


Messages recommandés

Bonjour,

Je me pose des questions sur le réglage du Z offset sur mon imprimante avec autolevel.

Ma compréhension est que l'on indique le décalage entre le 0 du nozzle et le 0 du capteur, pour permettre un "palpage" correct.

Ce que je ne comprend pas, c'est les diverses méthodes de réglage.

Pour la plupart, on fait descendre manuellement la buse jusqu'à 0.1mm du bed (epaisseur d'une feuille de papier), puis l'on remonte l'axe Z jusqu'à ce que le capteur s'eteigne et on regarde la valeur en Z à ce moment.

La plupart des tutos font déduire de cette valeur 0.1, correspondant à l'epaisseur de la feuille. SI je prends un exemple:

buse à 0.1mm, Z affiché à 0. On remonte, le capteur s'eteint à 2mm, on fait programmer en Z offset 1.9mm.

Dans la logique, celà signifie que la machine va calculer un Z0 à 1.9mm du declenchement du capteur. Mais physiquement, la buse sera à 0.2mm au dessus du bed.

J'aurais intuitivement rajouté l'epaisseur du papier, pourque le décalage corresponde à une buse effleurant le bed.

Ma question principale est comment est calculée l'épaisseur de la premiere couche: j'ai 0.3mm dans Cura. Si la machine se positionne à Z0+0.3mm, celà va positionner la buse à 0.5mm du bed...

Par contre, si la buse se positionne à Z0 pour la première couche, celà va me donner une couche réelle de 0.2mm...

Mais il me semble que la machine se positionne bien à 0.3 pour la première couche (si j'en crois l'afficheur)

J'ai du mal à comprendre la logique de ce positionnement. Si quelqu'un à une explication simple, je suis preneur!

Lien vers le commentaire
Partager sur d’autres sites

  • 9 months later...

Bonjour,

Je suis tout-à-fait d'accord avec toi et moi aussi je suis preneur pour une explication simple et précise du pourquoi du comment. :)

Citation

 

Modifié (le) par Lubudik
Lien vers le commentaire
Partager sur d’autres sites

je viens de le faire avec un capteur 3D touch.

mais je pense que c'est la même chose avec des capteur capacitif ou inductifs!

 

1/ pour commencer on branche l'imprimante sur le PC et on ouvre votre pilote d'imprimante repetier ou autre!

2/ on faut un G28

les 3 axes sont à leur positions d'origine.

3/ on fait remonter le plateau ou on descend le nozzle (suivant l'imprimante) jusqu'a ce que l'écart entre le nozzle et le plateau soit à 0.1MM (feuille de papier)

on regarde la valeur indiqué en Z sur l'écran.

exemple -1.3MM donc votre offset Z est faut de 1.3MM

4/ on tape M851 Z-1.3.

ce qui va corriger l'offset Z de 1.3MM

5/ une fois fait, on tape M500 pour l'enregistrer dans le firmware.

et on refais un essais.

à vous d'essayer.

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...

Bonjour 

je viens de monter mon 3D touch  il fonctionne trés bien mais il est impossible de calibrer l'offset z de cette façon

dans la mesure ou ont fait un g28 le capteur fait son palpage et défini le point zéro du z mini donc ensuite il est impossible de descendre l'axe z en dessous de zéro

si c'est possible svp expliquez moi comment car j'ai tout essayé et j'arrive pas a réduire l’écart entre le nozzle et le bed mémé en configurant le " define z_probe_offset_from_extruder en 1.9 dans marlin

 

cordialement   

 

Lien vers le commentaire
Partager sur d’autres sites

pour dépasser le 0, il faut dans le marlin

#define Z_MIN_ENDSTOP_INVERTING false

ensuite, pour régler l'offset du Z,il faut une fois le G28 fait, mettre le nozzle à 0.1MM du plateau comme avant le nivellement automatique et regarder la valeur.

et la rajouter à l'offset Z puis valider à l'aide de l'écran.

 

par contre, ce que je n'arrive pas à faire c'est modifier le nombre de points que le nivellement automatique fait.

il m'en fait 3, mais j'aimerais qu"il en fasse 4, les 4 coins du plateau.

une idée?

Lien vers le commentaire
Partager sur d’autres sites

merci

pour le monbre de point il me semble que c'est 

// set the number of grid points per dimension
     // I wouldn't see a reason to go above 3 (=9 probing points on the bed)
    #define AUTO_BED_LEVELING_GRID_POINTS 2

 

moi il est a 2 et il me fait  les 4 angles 

Modifié (le) par Prospector34
Lien vers le commentaire
Partager sur d’autres sites

regarde de ce côté la pour dépasser le 0.

 

#if DISABLED(ENDSTOPPULLUPS)
 // fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined
 #define ENDSTOPPULLUP_XMAX
 #define ENDSTOPPULLUP_YMAX
 #define ENDSTOPPULLUP_ZMAX
 #define ENDSTOPPULLUP_XMIN
 #define ENDSTOPPULLUP_YMIN
  //#define ENDSTOPPULLUP_ZMIN
  //#define ENDSTOPPULLUP_ZMIN_PROBE

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

Ma technique qui à prioris fonctionne pas trop mal ...

Avec pronterface

1) je fais un m851 z-10

2) un G28

3) je descend la buse jusqu a ce que ma feuille de papier soit legerement coincée.

4) un M114 pour connaitre la position de l axe Z

5) je fais (la position du z -10 = le decalage)

Ex: m114 retourne z=9,4 donc 9,4-10=-0,6

Apres eventuellement quelques ajustements et ca roule ...

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 1 year later...

Je m'insère sur cet ancien sujet pour exposer un problème que je n'ai jamais réussi à resoudre

Je fait tout le protocole avec la buse et le plateau à température de travail
   - G28 (Home all)
   - Je fais descendre la buse jusqu'au moment où la feuille de papier accroche
Ensuite tout le reste
   - M851 Z0 (met le décalage à 0)
   - M500 (inscrit en mémoire)
   - M851 Zx ( x= valeur lu sur l'écran de l'imprimante au moment où la feuille a accroché)
  - M500 (inscrit en mémoire)

Or en situation de travail la buse est plus haute, le filament coule et n'adhère pas. Je suis obligé d’augmenter la valeur du décalage de -0,2mm

Modifié (le) par Rioma
Lien vers le commentaire
Partager sur d’autres sites

Salut @Rioma,

 

La réponse que tu cherche est dans ton texte.

 

il y a 24 minutes, Rioma a dit :

Je suis obligé d’augmenter la valeur du décalage de -0,2mm

Quelle épaisseur fait ta feuille de papier ? 

0.2 mm ?

 

🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 4 minutes, Zarrt a dit :

Bonjour

@Rioma

As tu fais un M501 après ton M500 ? cela recharge les paramètres.

Ta question me fait penser qu'il faut recharger les paramètres en mémoire de travail. Je ne l'ai jamais fait.
Et revanche je vérifie toujours sur l'interface de l'imprimante "Controler - Mouvement - decalage si ça correspond à ce que j'ai paramétré

Lien vers le commentaire
Partager sur d’autres sites

Salut .. je déterre le sujet car je viens de changer mon plateau et je n'ai pas fait cette procedure depuis un moment !!

j'ai un z-offset corrigé de -2.4 .. ok lu avec M851

M500 enregistré

mais quelle commande G-code faut-il utiliser pour verifier ce offset ?

car quand je fais un G0 Z0 il y a toujours un décalage !! la feuille reste libre

toujours un decalage de 0.4 !!

je ne comprends pas ..

un peu d'aide please

Lien vers le commentaire
Partager sur d’autres sites

bon en fait je me répond a moi même

j'ai trouvé mon erreur

après ma modification du Z-offset avec M851 Z-xxx

M500

il faut refaire un G28 avant de faire le G0 Z0 pour verifier 😉

ce que je ne faisais pas ..

 

A+

TAnguy

Modifié (le) par Tanguy
Lien vers le commentaire
Partager sur d’autres sites

  • 1 year later...
Il y a 23 heures, Stonehenge a dit :

Est il utile de faire ce réglage du Z Offset lorsque l'on a pas de capteur et que donc le réglage du plateau est manuel ?.

Si oui est-ce possible avec S3D et comment ?

Non, c'est pour indiquer à l'imprimante que lorsque le capteur (end stop) renvoie l'info, il faut ajouter la distance (z offset) pour savoir où se trouve la buse.
Si tu n'as pas de capteur, il n'y a pas de décalage entre la buse et le capteur (end stop)

Lien vers le commentaire
Partager sur d’autres sites

Le 09/03/2017 at 17:09, Prospector34 a dit :

Bonjour 

je viens de monter mon 3D touch  il fonctionne trés bien mais il est impossible de calibrer l'offset z de cette façon

dans la mesure ou ont fait un g28 le capteur fait son palpage et défini le point zéro du z mini donc ensuite il est impossible de descendre l'axe z en dessous de zéro

si c'est possible svp expliquez moi comment car j'ai tout essayé et j'arrive pas a réduire l’écart entre le nozzle et le bed mémé en configurant le " define z_probe_offset_from_extruder en 1.9 dans marlin

 

cordialement   

 

Un petit déterrage de topic mais qui pourra servir à ceux qui se posent la question aujourd'hui

M851 Z0 ; remise à zéro du Z-offset
G28 ; auto home

On déactive les end stops

M121 ; Disable endstop detection

Après cette commande, on peut descendre sous le 0 (sur tous les axes, attention). 
On descend jusqu'à ce que la buse touche le plateau, ou une feuille mais il faudra retrancher l'épaisseur de celle-ci.

On remplace la valeur du Z offset sur l'écran par la valeur affichée sur l'axe Z (négatif) et on sauvegarde, ou via 

M851 Zx.xx ; affectation du Z-offset (M851 Z-x.xx en fait, puisque c'est négatif)
M500 ; sauvegarde des paramètres
M501 ; application des paramètres
M503 ; afficher les paramètres appliqués

Puis on ré active les end stops

M120 ; Enable endstop detection
Modifié (le) par NeoSlugman
Correction M851
Lien vers le commentaire
Partager sur d’autres sites

il y a 30 minutes, NeoSlugman a dit :

Un petit déterrage de topic mais qui pourra servir à ceux qui se posent la question aujourd'hui

Après un G28 :

On déactive les end stops


M121 ; Disable endstop detection

Après cette commande, on peut descendre sous le 0 (sur tous les axes, attention). 
On descend jusqu'à ce que la buse touche le plateau, ou une feuille mais il faudra retrancher l'épaisseur de celle-ci.

On remplace la valeur du Z offset sur l'écran par la valeur affichée sur l'axe Z (négatif) et on sauvegarde, ou via 


M851 Zx.xx ; affectation du Z-offset (M851 Z-x.xx en fait, puisque c'est négatif)
M500 ; sauvegarde des paramètres
M501 ; application des paramètres
M503 ; afficher les paramètres appliqués

Puis on ré active les end stops


M120 ; Enable endstop detection

il te manque un M851 Z0 avant le G28 pour initialiser l'offset a 0

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

J'ai donné il y a peu la suite de commandes à effectuer pour réaliser cette manipulation (suite à un visionnement d'une vidéo par un toitubeur de langue anglo-saxonne qui ne maîtrise pas totalement les mathématiques 😉) :

Révélation

Instructions de réglage du décalage Z:
1. Effectuer la mise à l'origine des axes de l'imprimante via G28
2. M851 Z0 - Initialiser le décalage en Z à 0
3. M500 - Stocker ce réglage en EEPROM
4. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
5. M503 - Afficher les paramètres en cours
6. G28 Z - Mettre à l'origine l'axe Z
7. G1 F60 Z0 - Déplacer la buse au 0 Z
8. M211 S0 - Désactiver les contacteurs de fin de course
9. Descendre doucement (pas de 0,01mm) l'axe Z jusqu'à frotter  la feuille de papier (ou la cale utilisée)
10. Noter la valeur affichée de la position du Z sur l'écran du boitier (additionner la valeur absolue affichée à l'épaisseur de la cale utilisée)
11. M851 Z-X.XX (X.XX étant le décalage en Z calculé au point 10, ne pas oublier le signe négatif )
12. M211 S1 - Réactiver les limites des contacteurs de fin de course
13. M500 - Sauvegarder ce réglages en EEPROM
14. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
15. M503 -Vérifier une dernière fois que tout a bien été pris en compte

🙂

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 7 heures, fran6p a dit :

J'ai donné il y a peu la suite de commandes à effectuer pour réaliser cette manipulation (suite à un visionnement d'une vidéo par un toitubeur de langue anglo-saxonne qui ne maîtrise pas totalement les mathématiques 😉) :

  Masquer le contenu

Instructions de réglage du décalage Z:
1. Effectuer la mise à l'origine des axes de l'imprimante via G28
2. M851 Z0 - Initialiser le décalage en Z à 0
3. M500 - Stocker ce réglage en EEPROM
4. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
5. M503 - Afficher les paramètres en cours
6. G28 Z - Mettre à l'origine l'axe Z
7. G1 F60 Z0 - Déplacer la buse au 0 Z
8. M211 S0 - Désactiver les contacteurs de fin de course
9. Descendre doucement (pas de 0,01mm) l'axe Z jusqu'à frotter  la feuille de papier (ou la cale utilisée)
10. Noter la valeur affichée de la position du Z sur l'écran du boitier (additionner la valeur absolue affichée à l'épaisseur de la cale utilisée)
11. M851 Z-X.XX (X.XX étant le décalage en Z calculé au point 10, ne pas oublier le signe négatif )
12. M211 S1 - Réactiver les limites des contacteurs de fin de course
13. M500 - Sauvegarder ce réglages en EEPROM
14. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
15. M503 -Vérifier une dernière fois que tout a bien été pris en compte

🙂

Wii, je me souviens l'avoir vu passer.
Par contre, le M211 est indiqué comme non supporté dans Marlin ici

Il y a 8 heures, hidius a dit :

il te manque un M851 Z0 avant le G28 pour initialiser l'offset a 0

Merci. En effet, je corrige 😉 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 10 heures, NeoSlugman a dit :

Par contre, le M211 est indiqué comme non supporté dans Marlin ici

Pour une version à jour, utilise plutôt ce lien (le site du Marlin d'autre part est plus intéressant: les directives de compilation nécessaire sont clairement indiquées 😉  ).

🙂

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...