Aller au contenu

Filament ABS

Problème camera IP avec octoprint sur Ender 3 Pro


maevalexandre

Messages recommandés

Bonjour à tous,

J'ai acheté il y a quelques semaines un raspberry PI4B pour le connecter à mon imprimante. Pas de problème, installation parfaite avec octoprint, j(y ai ajouté une petiite caméra PI qui fonctionnait parfaitement bien et puis patatra un jour je me connecte de nouveau sur mon pc pour lancer une impression par octoprint et je me retrouve avec un beau message "webcam stream loading..." et .... rien ! le reste fonctionne parfaitement hormis la caméra

Bon je me dis que ça doit être la nappe mais non. Ok je change de caméra, toujours rien ...  réinstallation plusieurs fois de octoprint, toujours rien . Donc à ce jour j'ai absolument TOUT changé même le raspberry pour un PI4b V1.2 et toujours le même souci. J'ai fait toutes les mises à jour possibles et bien sûr vérifié si la caméra était bien sur Enable . C'est à s'arracher les derniers cheveux que j'ai ! 😄

quand je fais http://octopi.local:8080/ ça me donne

Snapshot

Refresh the page to refresh the snapshot

Snapshot

Stream

et ça continue de tourner .... 

un petit coup de main? merci 

 

2020-07-11.jpg

Modifié (le) par maevalexandre
Lien vers le commentaire
Partager sur d’autres sites

Salut
C’est le démon de la caméra qui plante j’ai aussi ce phénomène sur le mien ... il faut killer le process et il se recrée tout seul après
Mjpeg_streamer de mémoire
C’est soûlant mais j’ai pas encore trouvé la solution ...
j’ai une caméra anker 1080p


Envoyé de mon iPhone en utilisant Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

@maevalexandre

Ta caméra Pi, quel modèle est-ce?

Les premiers modèles de la 5M étaient sensibles à l’électricité statique.

Pour plus d'aide, il va falloir accéder à la framboise via ssh et utiliser les formules cabalistiques / magiques (ps …, service webcmad status, etc.).

Le forum d'Octoprint possède quelques utilisateurs rencontrant des difficultés avec les caméras Pi ( 😞 ).

🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 8 minutes, fran6p a dit :

@maevalexandre

Ta caméra Pi, quel modèle est-ce?

Les premiers modèles de la 5M étaient sensibles à l’électricité statique.

Pour plus d'aide, il va falloir accéder à la framboise via ssh et utiliser les formules cabalistiques / magiques (ps …, service webcmad status, etc.).

Le forum d'Octoprint possède quelques utilisateurs rencontrant des difficultés avec les caméras Pi ( 😞 ).

🙂

j'ai deux modèles :

celui là qui fonctionnait et puis un jour le fameux message :

https://www.amazon.fr/gp/product/B07TS89SZL/ref=ppx_yo_dt_b_asin_title_o08_s00?ie=UTF8&psc=1

 

et celui là qui me donne aussi ce message "webcam stream loading"

https://www.amazon.fr/gp/product/B07RQ3Y668/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1

ça ne serait vraiment pas de bol si les deux avaient un problème . J'ai tenté tous les upgrades possibles d'octoprint, j'essaie en ce moment une ancienne version 

Lien vers le commentaire
Partager sur d’autres sites

La distribution (Rasbian comme base) est à jour  (sudo apt update && sudo apt upgrade -y ) ?

Je n'ai pas de Pi4 mais des 3B+, les seules fois où j'ai eu un problème avec une des caméras Pi c'était une mauvaise introduction de la nappe (étiquette bleue du mauvais côté) et une autre fois où mon modèle 5M a pris un coup de statique sans vraiment l'apprécier 😞 .

Depuis, pour Octoprint je n'utilise plus de PiCam mais une bête Logitech C270 ( je viens pourtant de commander une Arducam auto-focus motorisé pour le «fun» et les tests 😄).

🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 3 minutes, fran6p a dit :

La distribution (Rasbian comme base) est à jour  (sudo apt update && sudo apt upgrade -y ) ?

Je n'ai pas de Pi4 mais des 3B+, les seules fois où j'ai eu un problème avec une des caméras Pi c'était une mauvaise introduction de la nappe (étiquette bleue du mauvais côté) et une autre fois où mon modèle 5M a pris un coup de statique sans vraiment l'apprécier 😞 .

Depuis, pour Octoprint je n'utilise plus de PiCam mais une bête Logitech C270 ( je viens pourtant de commander une Arducam auto-focus motorisé pour le «fun» et les tests 😄).

🙂

oui mais les picam sont beaucoup beaucoup plus petites, c'est ça l'avantage 🙂 oui le côté bleu est toujours visible quand on insert la nappe en regardant le petit rectangle blanc de la caméra donc c'est le bon côté , en plus les leds infrarouges s'allument donc c'est bon de ce côté. je regarde mais je crois déjà avoir fait l'upgrade . tu peux faire des timelapse vec la c270?

Lien vers le commentaire
Partager sur d’autres sites

il y a 3 minutes, maevalexandre a dit :

tu peux faire des timelapse avec la c270?

Pourquoi ne le pourrait-elle pas 😄 ? Même du «Octolapse» (avec toutefois quelques artefacts sur les pièces imprimées à cause du déplacement de la tête sur sa position «fixe» lors de la prise du cliché).

Le timelapse est fonctionnel à partir du moment où la caméra (Pi ou USB) est capable de prendre une photo. Ce n'est qu'à la fin de l'impression que ces photos sont agrégées pour former une vidéo. La C270 est capable aussi d'enregistrer une vidéo en continu.

🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 46 minutes, fran6p a dit :

Pourquoi ne le pourrait-elle pas 😄 ? Même du «Octolapse» (avec toutefois quelques artefacts sur les pièces imprimées à cause du déplacement de la tête sur sa position «fixe» lors de la prise du cliché).

Le timelapse est fonctionnel à partir du moment où la caméra (Pi ou USB) est capable de prendre une photo. Ce n'est qu'à la fin de l'impression que ces photos sont agrégées pour former une vidéo. La C270 est capable aussi d'enregistrer une vidéo en continu.

🙂

ok mais si je prends une caméra usb, est ce que ça ne va pas me faire pareil... franchement incompréhensible 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 16 heures, maevalexandre a dit :

ok mais si je prends une caméra usb, est ce que ça ne va pas me faire pareil...

Aucune idée 😉

Octopi (la distribution incluant Octoprint) fonctionne sur de nombreuses machines: c'est rarement lui à mettre en cause (sauf si tu t'amuses à bidouiller ses entrailles, par exemple en root après saisie d'un : sudo rm -rf /* (à ne pas faire évidemment) ).

A partir du moment où la Webcam (USB) est reconnue par l'OS (Linux), que les paramètres pour cette Webcam sont correctement renseignés, hormis une défaillance matérielle (possible en vertu de Murphy qui rôde toujours prêt à intervenir), ça fait le job.

🙂

Lien vers le commentaire
Partager sur d’autres sites

Il y a 11 heures, fran6p a dit :

Aucune idée 😉

Octopi (la distribution incluant Octoprint) fonctionne sur de nombreuses machines: c'est rarement lui à mettre en cause (sauf si tu t'amuses à bidouiller ses entrailles, par exemple en root après saisie d'un : sudo rm -rf /* (à ne pas faire évidemment) ).

A partir du moment où la Webcam (USB) est reconnue par l'OS (Linux), que les paramètres pour cette Webcam sont correctement renseignés, hormis une défaillance matérielle (possible en vertu de Murphy qui rôde toujours prêt à intervenir), ça fait le job.

🙂

bon j'ai commandé la même webcam que toi 😄 elle a l'air réputée chez les imprimeurs 3D 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...