Aller au contenu

Filament ABS

Messages recommandés

Bonjour

Je possède une lk4 pro depuis janvier et me suis dit je vais voir mon PID pour ajuster.

Déjà pas de ligne concernant le plateau mais juste la buse. J'ai donc lancé l'autotune PID et les résultats sont quasi 50% plus bas...normal ou faut laisser les valeurs originales ?

Lien à poster
Partager sur d’autres sites

Le PID se fait à température d'impression, donc, à chaque fois que tu change de température (de matériaux), il faut le refaire 😉

Pour le PID bed, il faut l'activer dans le FW...

Lien à poster
Partager sur d’autres sites

Salut,

Petit rappel: le réglage de PID consiste à faire varier 3 coefficients afin d'obtenir rapidement puis de garantir de manière constante la température de consigne.

@PLFmoto Je doute que la différence entre une température de 200°C et 230°C soit très significative. De mémoire, la répétabilité de l'autotune n'est pas non plus exceptionnelle.

Pour le valider, le test serait intéressant (autotune à différentes températures). Si tu as une isolation du corps de chauffe ("chaussette"), tu auras encore moins d'influence (c'est plus facile à réguler).

Pour les valeurs de 50%, d'après mes souvenirs, j'étais également étonné d'avoir des résultats nettement différents, mais j'avais isolé le corps de chauffe.

Lien à poster
Partager sur d’autres sites

Oui, de toute façon, tu vas vite être fixé. Si la température de buse est mal régulée, elle va avoir du mal à rester stable lors de l'impression.

Il n'y a donc pas de grands risques à essayer.

Lien à poster
Partager sur d’autres sites
Le 24/08/2020 at 19:41, remibora a dit :

Salut,

Petit rappel: le réglage de PID consiste à faire varier 3 coefficients afin d'obtenir rapidement puis de garantir de manière constante la température de consigne.

@PLFmoto Je doute que la différence entre une température de 200°C et 230°C soit très significative. De mémoire, la répétabilité de l'autotune n'est pas non plus exceptionnelle.

Pour le valider, le test serait intéressant (autotune à différentes températures). Si tu as une isolation du corps de chauffe ("chaussette"), tu auras encore moins d'influence (c'est plus facile à réguler).

Pour les valeurs de 50%, d'après mes souvenirs, j'étais également étonné d'avoir des résultats nettement différents, mais j'avais isolé le corps de chauffe.

Et bien fais le test, tu verras bien le résultat...

Je sais que sur ces daube de Longer, si le PID n'est pas réglé à la température d'impression, elle ont même du mal a atteindre la température demandée 👎

Après, chacun vois midi à sa porte. Mais il ne faut pas venir dire que ça ne fonctionne pas si on ne fait pas ce qu'il faut pour... 🙄

C'est comme pour les température d'extrusion, suivant les filaments, il y a des différences, même une bobine différente d'un même filament (même marque, type, couleur) put avoir des variantes, donc, on fait une tours de temp.

Après, si tu veux faire de l'a-peu-près, vas-y...

Lien à poster
Partager sur d’autres sites
il y a 8 minutes, PLFmoto a dit :

Et bien fais le test, tu verras bien le résultat...

Je sais que sur ces daube de Longer, si le PID n'est pas réglé à la température d'impression, elle ont même du mal a atteindre la température demandée 👎

Après, chacun vois midi à sa porte. Mais il ne faut pas venir dire que ça ne fonctionne pas si on ne fait pas ce qu'il faut pour... 🙄

C'est comme pour les température d'extrusion, suivant les filaments, il y a des différences, même une bobine différente d'un même filament (même marque, type, couleur) put avoir des variantes, donc, on fait une tours de temp.

Après, si tu veux faire de l'a-peu-près, vas-y...

Wah quand même.... Ou peut être que tu es tombé sur une thermistance défectueuse ou une CM défectueuse, mais bon Longer sur le nombre de machine vendu sous leur marque et alfawise, si c'était de la "daube" ça ce serrait ...

Et pour en revenir sur le sujet de base, un PID ça prend 10 minutes et ça coûte rien, autant le faire 👍

Par contre de la à en refaire un a chaque changement de température, autant resserrer toutes les vis de la machine après chaque impressions  👼

Lien à poster
Partager sur d’autres sites
il y a 18 minutes, Tormak a dit :

Par contre de la à en refaire un a chaque changement de température, autant resserrer toutes les vis de la machine après chaque impressions

Ben, désolé de te dire ça, mais on fait de l'à-peu-près...😪

Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Tormak a dit :

Wah quand même.... Ou peut être que tu es tombé sur une thermistance défectueuse ou une CM défectueuse, mais bon Longer sur le nombre de machine vendu sous leur marque et alfawise, si c'était de la "daube" ça ce serrait ...

Et pour en revenir sur le sujet de base, un PID ça prend 10 minutes et ça coûte rien, autant le faire 👍

Par contre de la à en refaire un a chaque changement de température, autant resserrer toutes les vis de la machine après chaque impressions  👼

Ben si, désolé, mais c'est de la daube, maintenant, si tu n'as connu que ces 2 marques, je comprend que tu puisse avoir un jugement faussé... (j'ai eu 2 LK4pro et 2 Créality Ender3, ben, y a pas photo !!!)

Et pour en revenir au PID, c'est donc au ratio qui est calculé pour une température donnée donc, si j'imprime du PLA à 195° et qu'ensuite, j'utilise du PETG à 230°, sans refaire le PID, autant dire que ça va être très compliqué... Mais bon, encore une fois, chacun fait ce qu'il veut !

Modifié (le) par PLFmoto
  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 16 heures, PLFmoto a dit :

Ben si, désolé, mais c'est de la daube, maintenant, si tu n'as connu que ces 2 marques, je comprend que tu puisse avoir un jugement faussé... (j'ai eu 2 LK4pro et 2 Créality Ender3, ben, y a pas photo !!!)

Et pour en revenir au PID, c'est donc au ratio qui est calculé pour une température donnée donc, si j'imprime du PLA à 195° et qu'ensuite, j'utilise du PETG à 230°, sans refaire le PID, autant dire que ça va être très compliqué... Mais bon, encore une fois, chacun fait ce qu'il veut !

Oula Boby, calme toi, je pense que j'ai connu plus de marque que toi 😉 Sur une Prusa, une Raise ou une ultimaker, on ne change jamais le PID, et pourtant c'est des machines sur lequel on passe bien plus de sorte de filament que sur ta Ender 👼

Pour info je préfère largement ma LK4 Pro à ta Ender 3, mais les goûts et couleurs sont propres à chacun 😉.

Enfin bref, je te laisse voir ou est le jugement faussé, chacun voit midi à sa porte.

  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 22 heures, Tormak a dit :

Wah quand même.... Ou peut être que tu es tombé sur une thermistance défectueuse ou une CM défectueuse, mais bon Longer sur le nombre de machine vendu sous leur marque et alfawise, si c'était de la "daube" ça ce serrait ...

Et pour en revenir sur le sujet de base, un PID ça prend 10 minutes et ça coûte rien, autant le faire 👍

Par contre de la à en refaire un a chaque changement de température, autant resserrer toutes les vis de la machine après chaque impressions  👼

Bah, normal, c'est comme quand tu prend ta voiture, tu vérifie les niveaux, tu regarde sur la courroie de distri est bien en place, la pression des pneus, tu vérifie aussi avec la clé dynano si les écrou sont bien serrer, tu purge le liquide de freins, et quand tu mets de l'essence, bah tu fais attention, tu recalibre ta conso au 100km, pareil quand tu mets la clim, ça consomme plus donc faut que tu joue avec l'ordinateur de bord pour régler l'injection ou le carbu si t'a une veille voiture sinon forcément, tu fait pas les choses correctement 😉 après si t'a connus que 2 marques de voitures ... 

  • Haha 2
Lien à poster
Partager sur d’autres sites

Euhhhh

Au départ je voulais juste un avis sur le PID diminué de quasiment 50% rapport aux valeurs d'origine et pourquoi le plateau n'apparaît pas pour ajuster. Je pensais pas que ça allait partir en guerre de marques ...

  • Haha 1
Lien à poster
Partager sur d’autres sites
Il y a 6 heures, Tormak a dit :

Oula Boby, calme toi, je pense que j'ai connu plus de marque que toi 😉 Sur une Prusa, une Raise ou une ultimaker, on ne change jamais le PID, et pourtant c'est des machines sur lequel on passe bien plus de sorte de filament que sur ta Ender 👼

Pour info je préfère largement ma LK4 Pro à ta Ender 3, mais les goûts et couleurs sont propres à chacun 😉.

Enfin bref, je te laisse voir ou est le jugement faussé, chacun voit midi à sa porte.

Perso, je m'en fou, maintenant, je suis en BTT sur toutes mes machines, enfin, à châssis Créality puisque le châssis Longer est à la poubelle complètement faussé depuis le début (de trop bonne qualité apparemment... CQFD)

Je travail principalement le PETG et l'ASA (puisque l'Ender3 d'origine chauffe plus que la Longer...) et très peu de PLA et TPU... Alors, je ne vois pas trop ce que tu peux passer de plus dans une Longer...

 

Mais bon, je vais arrêter là puisque qu'on est complètement HS...

Modifié (le) par PLFmoto
Lien à poster
Partager sur d’autres sites

Salut @Laurent57,

perso je trouve ça enorme un ecart de 50% entre les valeurs d' origine et ton resultat si tu n' à rien changé à ta becanne.

Je pourrait l' expliquer par un changement de materiau/format du corp de chauffe, sinon je ne vois pas.. ( est ce que ta thermistance est bien inserée ? )

Combien de cycles demande tu pour l' autotune ? plus tu en fait, plus ton resultat sera " exact " ( si tu ne precise pas, il en fait 5 )

Actuellement sur LK4 avec un bloc chauffant format standard, en alu, isolé par une chaussette silicone, je suis avec `Kp: 23.52 Ki: 1.42 Kd: 97.30` contre `Kp:22.2 Ki:1.08 Kd:114` d' origine.

La vrai question serait " est ce que ta temperature est stable ? "

Si oui je ne vois pas vraiment l' interet de le modifier, si non, fait le ^^

( apres rien ne t' empeche de faire des test 😉 )

_______________________

Ce qui pourrai m' inciter à le regler, autre qu' une envie de calibration generale, serai :

- Une temperature instable

- le changement de mon corp de chauffe ( volcano, en acier, cuivre, etc.. )

- (éventuellement ) de thermistance (cf temp instable )

____________________

La temperature visé par ton autotune ne modifiera que (tres) legerement le resultat

J' imagine que PLFmoto regle le voltage de ses moteurs aussi en fonction de ce qui reste de filament sur la bobine ? bah oui, c' est plus ou moins facile à derouler.. 🤭

Puis faut arreter la mauvaise foi à un moment, les deux becannes qu' il compare ont les memes hotends, la limitation de chauffe viens du ptfe identique ( et par le firmware, 275° par default pour Marlin, donc pour la lk4, mais à cette temperature, 'tention au ptfe 😄.

Le chassi de LK4 est juste plus rigide, et si tes enders sont si bien, tu ne te sentirai pas obligé de n' en garder que le cadre.

Modifié (le) par 3Dim
Lien à poster
Partager sur d’autres sites

salut @3Dim

Pour le matériel, j'ai buse d'origine et tout, jamais changé. J'ai fait l'autotune avec 8 cycles. J'ai juste mis une chaussette silicone

Avant l'autotune, mes valeurs étaient : M301 P22.20 I1.08 D114.00

Après : M301 P12.54 I0.54 D72.66.

J'ai tenté de remettre les valeurs d'origine et relancer....échec, température trop élévée

Lien à poster
Partager sur d’autres sites

Salut,

Pour info, sur ma machine j'ai, après réglage, M301 P20.12 I1.19 D85.09. Le corps de chauffe est en acier.

C'est vrai que ton proportionnel est assez faible. Lorsque tu surveilles la température de buse lors d'une impression, as-tu des variations?

Quel firmware utilises-tu (marlin ou Longer3D) ?

Lien à poster
Partager sur d’autres sites
Il y a 9 heures, remibora a dit :

Salut,

Pour info, sur ma machine j'ai, après réglage, M301 P20.12 I1.19 D85.09. Le corps de chauffe est en acier.

C'est vrai que ton proportionnel est assez faible. Lorsque tu surveilles la température de buse lors d'une impression, as-tu des variations?

Quel firmware utilises-tu (marlin ou Longer3D) ?

Salut

Pas de variation de température, j'utilise marlin d'origine 1.1.9

Lien à poster
Partager sur d’autres sites

Si quand tu demande une temperature, elle y arrive sans trop depasser et se stabilise correctement, je dirait " te prend pas la tete, c' est bien comme ça " ^^

(surtout si en plusieurs autotune tu tombe sur des valeurs similaire )

Lien à poster
Partager sur d’autres sites
  • 2 weeks later...
il y a une heure, Thierry94 a dit :

La LK4 Pro est en 24 volts ... avec un Sunon 12 volts il va tourner beaucoup moins vite et faire moins de bruit ... mais il va aussi moins refroidir !

C'est le ventilateur que j'avais pour le PID, donc possible la raison des résultats aussi bas

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...