Aller au contenu

Filament ABS

  • 0

CR10 v3 Retraction bruyante


Question

Bonjour,

Comme dit dans mon titre, quand j'imprime je met une retraction du fil au dessus de la piece imprimée de 0.2mm.

A chaque retraction, mon extrudeur fait un bruit bien degueulasse.

Un ami ayant acheté la meme imprimante a le meme soucis.

J'en conclu que c'est soit l'extrudeur titan qui est de mauvaise qualité, soit la carte creality 2.5.2 n'a pas de tmc2208 sur l'extrudeur.

Si c'est l'extrudeur, je le changerai par un bmg, mais si c'est le manque de tmc2208 sur la carte mere, que puis-je faire?

J'ai entendu parler de tl smoother, est ce que cela remplace un tmc?

ou y a t'il moyen d'ajouter un tmc sur le moteur d'extrudeur sans changer la carte mere?

 

Merci d'avance

Lien à poster
Partager sur d’autres sites

20 réponses à cette question

Messages recommandés

  • 0

Salut...

Hypothèse "par expérience" :

Le bruit... si tu pouvais filmer cela se serait un plus... si il ressemble à un "grincement" est peut être simplement dû à une valeur des accélérations du moteur qui sont trop élevés, dans le profil du Slicer.

Rappel :

Citation

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
M203 X300.00 Y300.00 Z5.00 E25.00 ;Setup machine max feedrate
M204 P500.00 R1000.00 T1000.00 ;Setup Print/Retract/Travel acceleration
M205 X10.00 Y10.00 Z0.40 E5.00 ;Setup Jerk
M220 S100 ;Reset Feedrate
M221 S100 ;Reset Flowrate
M500 ;Save Settings

Ce que j'ai mis en rouge... c'est les accelerations de ton extrudeur.
Au de là de E5000... c'est trop.
5000... c'est le max du max.

La valeur par défaut, conseillé par le fabricant "Creality", c'est : 1000

Enfin... quand tu en seras à mon niveau... à chercher à optimiser ton imprimante... et selon le filament... tu apprendras que parfois "2000" c'est mieux... et que également "5000" devient indispensable certaines fois.

Enfin bref... je le sais par expérience : Si le moteur grince dans les rétractations, c'est qu'une valeur n'est pas bonne.
Et généralement, c'est la rétractation ou l'acceleration.
Et que... soit ton moteur patine... soit il est à la peine...

Donc conseil : Met les valeurs d'accelération à 5000, et la rétractation à 1000.

Et... tiens moi au courant...

Lien à poster
Partager sur d’autres sites
crack amazon music ulimited gratuit
  • 0

si je comprends bien ce que tu me dit, car effectivement j'utilise le slicer cura et j'ai exactement les memes données que toi,

je dois a la 1ere ligne mettre x:5000 y:5000 z:5000 et E:1000

c'est bien cela?

Lien à poster
Partager sur d’autres sites
  • 0
il y a 5 minutes, Stef67 a dit :

je dois a la 1ere ligne mettre x:5000 y:5000 z:5000 et E:1000

c'est bien cela?

Oui ! C'est bien cela !

Tu peut même mettre :

X500 Y500 Z5000 E1000

Modifié (le) par Bosco2509
Lien à poster
Partager sur d’autres sites
  • 0

merci bcp pour ton aide, je pense que cela peut etre le probleme.

Malheureusement, je pars maintenant en deplacement, je ferai donc les test en rentrant vendredi soir et je ne manquerai pas de te tenir au jus 🙂

Lien à poster
Partager sur d’autres sites
  • 0

Salut,

Question bête: à quoi ça sert de mettre une accélération de 5000 sur l'axe Z sachant qu'il ne fait que des "sauts de puce". A part réduire sa durée de vie puisqu'il va prendre plus de courant, je ne vois pas l'intérêt...

Lien à poster
Partager sur d’autres sites
  • 0
il y a 11 minutes, Stef67 a dit :

merci bcp pour ton aide, je pense que cela peut etre le probleme.

Malheureusement, je pars maintenant en deplacement, je ferai donc les test en rentrant vendredi soir et je ne manquerai pas de te tenir au jus 🙂

Et au passage... vérifie la 3e ligne :

M204 P500.00 R1000.00 T1000.00 ;Setup Print/Retract/Travel acceleration

La vitesse max de rétractation est normalement à R1000.
Si elle est plus élevé, met à 1000.

à l’instant, remibora a dit :

Question bête: à quoi ça sert de mettre une accélération de 5000 sur l'axe Z sachant qu'il ne fait que des "sauts de puce". A part réduire sa durée de vie puisqu'il va prendre plus de courant, je ne vois pas l'intérêt...

A vrai dire : Cela dépend du poids de l'axe.

Sur une cartésienne classique, comme la Ender 3, CR-10, etc... c'est l'axe X  qui monte et descend.
Et l'axe X, en comptant toute la mécanique... cela représente du poids... qui doit pouvoir monter et descendre à une accélération relativement importante.

Enfin bref... fait le test toi même en mettant à Z500... tu vas voir ce qu'il se passera.
D'avance, je te préviens en te disant : Bonjour les boudins !

Lien à poster
Partager sur d’autres sites
  • 0

Je pense que le bruit vient du jeu d'inversion du Z  quand il demande 0.2. Je pense plutôt à un réglage mécanique du Z ( alignement moteur noix guide  , vérification du serrage des coupleur et réglage des excentriques ) 

Lien à poster
Partager sur d’autres sites
  • 0
il y a 12 minutes, Bosco2509 a dit :

Sur une cartésienne classique, comme la Ender 3, CR-10, etc... c'est l'axe X  qui monte et descend.

@Bosco2509 Dans l'hémisphère sud peut-être, et encore, j'en doute... ou alors on m'aurait menti?

il y a 36 minutes, Bosco2509 a dit :

Enfin bref... fait le test toi même en mettant à Z500... tu vas voir ce qu'il se passera.

Depuis des mois, j'ai laissé les valeurs par défaut dans Marlin 2.0.5.3, à savoir acc Z max = 100mm/s², vitesse 5mm/s (comme toi).

Pour un déplacement de 0.25mm sur l'axe vertical (pour moi Z), avec une acc de 5000mm/s², le temps de déplacement est de 50ms contre 100ms à 100mm/s².

il y a 40 minutes, Bosco2509 a dit :

D'avance, je te préviens en te disant : Bonjour les boudins !

Si tu parles de ma femme, je ne vois pas le rapport, et en plus c'est pas très gentil 😄.

Plus sérieusement, à priori, les "boudins" se formeraient à cause d'un déplacement trop long (en temps). Or les 50ms d'écart sont, pour moi, négligeables (dans le monde de l'impression 3D), non? En tout cas, je ne vois pas de boudins sur mes impressions. Si tu as des photos qui corroborent tes dires, je suis intéressé.

Lien à poster
Partager sur d’autres sites
  • 0

J'ai eu le temps de tester avant mon départ et malheureusement, mettre E1000 a la place de E5000 n'a pas corrigé le problème.

L'hypothèse d'un mauvais montage ma aussi traversé l'esprit, mais mon ami qui a acheté la même imprimante a le même soucis que moi.

J'essaierai quand même un démontage remontage en rentrant le weekend prochain mais sans trop de convictions.

J'essaierai aussi avec un autre slicer comme simplify3d.

Je n'ai pas précisé mais mes réglages dans cura étaient de 5mm de rétraction a 45mm/s je ne sais pas si ça peut influer sur quelque chose.

Lien à poster
Partager sur d’autres sites
  • 0

@Stef67

Bonjour,

Il serait bien que tu complètes ton profil 😉: actuellement tu indique posséder une Ender3Pro or le début de ton post parle d'une CR10 V3 qui possède une extrudeur de type direct-drive.

Le Titan normalement est un orignal de chez E3D (l'hologramme) qui pour fonctionner correctement doit être monté suivant les recommandations de E3D 😉 (je le sais car j'ai (pas encore monté) le kit prévu pour la CR10 V2) autre documentation https://e3d-online.dozuki.com/Document/1FtAQ23FKVm3Onpt/Titan-Assembly-Supplementary.pdf

La rétraction avec ce type d'extrudeur est plutôt inférieure à 2 mm (sauf vouloir créer un colmatage de la tête à brève échéance 😞 ).

@remibora, @Bosco2509 a parfaitement raison 😉 : l'axe X est bien supporté par l'axe Z pour monter / descendre, son poids n'est pas négligeable (d'autant plus si un direct-drive est ajouté sur l'axe X (poids du moteur + extrudeur).

Voilà les paramètres utilisés dans mon Marlin pour ma CR10V2 :

Citation

/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2...]]
 */
#define DEFAULT_MAX_FEEDRATE          { 750, 750, 15, 75 }

//#define LIMITED_MAX_FR_EDITING        // Limit edit via M203 or LCD to DEFAULT_MAX_FEEDRATE * 2
#if ENABLED(LIMITED_MAX_FR_EDITING)
  #define MAX_FEEDRATE_EDIT_VALUES    { 600, 600, 10, 50 } // ...or, set your own edit limits
#endif

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2...]]
 */
#define DEFAULT_MAX_ACCELERATION      { 2000, 2000, 100, 5000 }

//#define LIMITED_MAX_ACCEL_EDITING     // Limit edit via M201 or LCD to DEFAULT_MAX_ACCELERATION * 2
#if ENABLED(LIMITED_MAX_ACCEL_EDITING)
  #define MAX_ACCEL_EDIT_VALUES       { 6000, 6000, 200, 20000 } // ...or, set your own edit limits
#endif

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION           800    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  1000    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION    800    // X, Y, Z acceleration for travel (non printing) moves

 

Et dernière chose, la carte v2.5.2 possède quatre (4) pilotes TMC2208 donc l'extrudeur en utilise un. Par contre, avec cette carte, il ne faut pas activer le Linear Advance sinon l'extrudeur va cesser d'extruder au bout d'un temps plus ou moins long (pour les plus anciens, c'est comme le refroidissement du fût d'un canon 😄 )

Mon sujet sur mon Marlin pour la CR10V2 (utilisable aussi pour la CR10V3 en modifiant le pas de l'extrudeur et son sens de rotation) :

 

🙂

Lien à poster
Partager sur d’autres sites
  • 0
il y a 7 minutes, fran6p a dit :

l'axe X est bien supporté par l'axe Z pour monter / descendre

Effectivement, toutes mes excuses à @Bosco2509 sur ce point.

Pour mon information, quand on indique:

#define DEFAULT_MAX_ACCELERATION      { 2000, 2000, 100, 5000 }

suivi de:

#define DEFAULT_ACCELERATION           800    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_TRAVEL_ACCELERATION    800    // X, Y, Z acceleration for travel (non printing) moves

Au final, on a bien une accélération max en Z de 100mm/s², qui ne sera jamais dépassée?

Lien à poster
Partager sur d’autres sites
  • 0

Profil a jour 😁

Merci pour les infos. 

Lextrudeur sur la v3 était déjà monté donc je n'ai pas vérifié si il l'était correctement et je n'ai pas reçu de documentation avec pour le faire.

Je regarderais ça en rentrant.

En attendant je descendrais ma rétraction a 2mm, je verrai bien si ça règle le probleme.

J'avais déjà vu ton sujet sur le marlin et j'aurais certainement encore beaucoup de questions a propos de celui ci.

Actuellement je suis sur celui d'origine avec bltouch et direct Drive.

 

Mais chaque chose en son temps 😁

 

Merci encore pour les réponses.

Lien à poster
Partager sur d’autres sites
  • 0
il y a 3 minutes, Stef67 a dit :

J'avais déjà vu ton sujet sur le marlin et j'aurais certainement encore beaucoup de questions a propos de celui ci.

Pas de problème, si j'ai la réponse je l'apporterai. Mais depuis déjà quelques temps, j'utilise surtout Klipper comme firmware même si je mets à jour mon dépôt Github pour ma version Marlin CR10-V2 et vérifie les compilations (actuellement, il est basé sur la dernière version stable de Marlin : 2.0.6.1).

🙂

Lien à poster
Partager sur d’autres sites
  • 0

Hello, 

 

Ayant une CR10 V3 depuis un petit mois, je ne pense pas un problème de paramétrage mais plus de montage, car je n'ai pas de bruit étrange pour le coup. Après je suis débutant, donc peut être rien remarqué. 

Lien à poster
Partager sur d’autres sites
  • 0

Mon collègue ayant la même que moi il a fait quelques test et le bruit est le même quelle que soit l'extrusion. Voici une vidéo ou il était en 0.5mm en vitesse 45mms.

Ceci après avoir démonté pour vérifier le bon assemblage.

 

 

Lien à poster
Partager sur d’autres sites
  • 0
il y a 6 minutes, Stef67 a dit :

Mon collègue ayant la même que moi il a fait quelques test et le bruit est le même quelle que soit l'extrusion.

Là je te comprend pas... 🤨
Quel que soit l'extrusion ?... tu veut dire quoi par là... merci d'être plus clair.
Tu parle de longueur de rétractation ou de vitesse d'extrusion.

il y a 7 minutes, Stef67 a dit :

Voici une vidéo ou il était en 0.5mm en vitesse 45mms.

C'est clairement pas un soucis de drivers ou d'électronique... au vu du bruit.

Pour moi : le bruit viens du moteur qui patine.

A comparaison, on dirait une voiture qui "burn"(fait crisser ses pneus) au démarrage.

0.5mm de rétractation ? pas d'erreur ?
C'est peu je trouve... trop peu même.

Après quelques règles de mathématiques et de "bon sens" de base :

0,5mm  de rétractation à une vitesse  de 45mm/s...  le pauvre moteur doit rétracter 0,5mm en un peu plus de 0,01 secondes.

En comparaison, en bowden, sur une CR10 ou Ender 3, la rétractation est de 6,0mm sur une vitesse de 25mm/s, cela fait du 6,0mm rétracter sur 0,24 secondes.

Après... ce n'est que mon avis... mais cela ne sert à rien de vouloir allez vite dans les rétractations, c'est un bon rapport "longueur & vitesse" qui est important dans la rétractation.

Après... petit rappel :

Regarder que le câble qui est branché au moteur d'extrusion est correctement enfiché.
Ce ne serait pas une première qu'un câble branché  à 50% entraine un comportement ou un bruit bizarre.

Lien à poster
Partager sur d’autres sites
  • 0

Je parle  de distance de rétraction pour les 0.5 mm

Pas d'erreur puisque plus haut fran6p me dit que cet extrudeuse conseil 2mm maximum.

Quand je dis quelle que soit la rétraction je parle de la distance comprise entre 0 et 2mm et je te raconte pas quand j'étais a 5mm avant...

 

Bref j'ai pas testé de réduire la vitesse, c'est vrai que j'ai vu 45mms maximum et je n'ai pas pensé a tester en baissant cette vitesse.

 

Avec ma ender 3 assorti d'un bmg je mettais l'extrusion a 7mm avec une vitesse de 100mms et ça fonctionnais impeccablement.

J'avais vu ce réglage sur une vidéo du guéro loco.

Modifié (le) par Stef67
Lien à poster
Partager sur d’autres sites
  • 0
il y a 2 minutes, Stef67 a dit :

Pas d'erreur puisque plus haut fran6p me dit que cet extrudeuse conseil 2mm maximum.

Je confirme 😉 . La CR10 V3 est en direct-drive, le tube PTFE est tout «riquiqui» (moins de 7 cm de long) mais il va tout de même jusqu'à la buse.

Pour trouver la valeur de rétraction «idéale» avec le filament utilisé, le mieux est d'utiliser le site de test de TeachingTech, l'australien. Bien qu'en anglais, cela reste utilisable 😄 (j'essaie d'en faire une traduction mais c'est long 😞 ).

🙂

Lien à poster
Partager sur d’autres sites
  • 0

Bon, problème réglé en modifiant la vitesse de rétraction.

En fait je suis a 45mms depuis le début et la a 25mms plus de bruit.

 

Par contre fran6p, tu me fais remarquer que la tête a un petg de moins de 7cm, je pensais que c'était une tête full métal...

Du moins sur le site c'est ce que je pensais avoir compris.

Screenshot_20200909-175633__01.jpg

Modifié (le) par Stef67
Lien à poster
Partager sur d’autres sites
  • 0

Non la tête n'est pas une «full metal jacket». J'avais disséqué cette tête dans un sujet :

 

Ce que tu as encadré sur la publicité concerne l'extrudeur qui lui est en métal (aluminium) contrairement aux modèles anciens en plastique dont le levier de rappel a tendance à se casser.

La confusion peut venir du terme «extrudeur» 😉 pour certains c'est juste le «feeder» (moteur Nema + système d'entrainement du filament (normal, BMG sans réduction, BMG 3:1, Titan, Hemera, …)  pour d'autres c'est l'ensemble Tête + entrainement du filament.

🙂

Modifié (le) par fran6p
Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à cette question…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...