Aller au contenu

Filament ABS

[U30] Problème température qui monte sans arret - mosfet HS sur carte mère ?


Messages recommandés

Bonjour à tous,

J'aurais besoin d'un conseil d'expert pour un problème sur ma U30, achetée en Sep 2019 sur Gearbest.

Pendant le nettoyage de on bloc chauffant à cause d'un énorme blob, j'ai touché par erreur les 2 fils de la cartouche chauffante. Le résultat vous pouvez l'imaginer : petite étincelle et court circuit. 

Depuis ce moment, la température de la buse monte sans arrêt comme si la sonde de température ne marchait plus. Le bloc continue à chauffer, de la fumée commence à sortir et donc obligé de tout eteindre pour éviter de mettre le feu à l'imprimante et la maison 🙂

J'ai remplacé la cartouche et la thermistance avec des nouvelles pièces mais le problème est toujours là, ce qui me fait penser que le problème est sur la carte mère.

En fait il s'agit du même symptôme décrit dans ce vieux post

Si je ne me trompe pas, ma carte mère est une V08G - voir photo en pj. Voici mes questions :

1. Les mosfets sur la V08G sont bien les 2 dans le cercle orange dans ma photo? Si oui, quelle est celui pour la cartouche chauffante ?

2. Il me semble que sur ces mosfet il n'y a pas de micro soudures : sont-ils donc remplaçables pour tenter de réparer la carte mère ?

3. Si le point 2 est positif, avez- vous de references de mosfet à me conseiller ? est-il possbile de faire un bypass du mosfet cramé et rajouter un mosfet externe pour le remplacer?

Bref, je souhaite comprendre si la réparation est possible et évaluer le coût de remplacer le mosfet, par rapport à commander direct une nouvelle carte mère.

Si vous avez d'autres conseils pour des autres possibles solutions à mon problème, je suis bien preneur.

Merci d'avance pour votre aide.

Cordialement.

 

 

 

 

 

U30_MB-mosfet.jpg

Lien à poster
Partager sur d’autres sites
crack amazon music ulimited gratuit

Salut,

Voici les schémas de la carte de l'U20 qui semble être identique à la tienne.

Pour répondre à tes questions:

1- oui, celui de gauche pilote le ventilateur de la buse et celui de droite le bloc de chauffe de la tête

2- je ne sais pas ce que tu veux dire par micro-soudure: ce ne sont pas des versions CMS (composant de surface), ils sont donc relativement faciles à remplacer

3- les références des mosfets sont spécifiés dans les fichiers joints.

D'après ce que tu indiques, le problème se situerait plutôt sur la mesure de la température vu que le bloc de chauffe monte en température (au mieux, c'est le condo et la résistance qui ont dégusté,  au pire, c'est l'entrée analogique du micro-controleur qui est HS, et là, c'est le drame...)

correction Mainboard_detail U20_A.pdf Mainboard_detail.pdf mainboard_SCH-2.pdf

Lien à poster
Partager sur d’autres sites

Merci bcp pour ta reponse @remibora et pour tes documents. Super utiles!!! Exactement ce que je cherchais!

Donc c'est bien le mosfet Q4 que je doit remplacer et sa référence est STP55NF06. Je vais regarder les caractéristiques et voir si je peux trouver aussi des mosfet canal-N équivalents.

Avec micro-soudure je voulais bien dire composants CMS, pardon pour mon imprécision lexicale 🙂

Je suspect que le mosfet Q4 reste ON tout le temps et donc la cartouche continue à chauffer sans arrêt. Donc le 1er tentative est de le remplacer vu le cout ridicule d'un mosfet, à voir ce que ça donne. Je croise les doigts!

Juste pour ma curiosité, l'autre mosfet à 5 broches juste à coté de la prise USB ça sert à quoi ?

Encore un gros merci!

Cordialement.

Lien à poster
Partager sur d’autres sites

Si tu parles de U5 (sérigraphie sur la carte), c'est un régulateur (abaisseur) de tension (LM2596T)
En ce qui concerne le mosfet Q4, avant de le remplacer, tu peux le tester avec 2 résistances et 1 led. Il se peut que ce soit la sortie du micro-controleur qui soit HS 😬.

A propos des schémas, il faut plutôt remercier @CacaoTor qui est allé à la pêche aux infos au près du constructeur.

Lien à poster
Partager sur d’autres sites

Salut @remibora,

Good news! Après avoir remplacé le mosfet Q4 avec un nouveau avec la même référence, le problème est résolu, mais partiellement.

En fait, maintenant la température s’arrête de monter, mais par contre chaque fois elle monte 15°C plus que le target, après elle redescende 2°C au dessous et enfin elle s’arrête  à la bonne température - voir video en pj.

Je pense qu'il faudrait faire un PID tuning, mais il n'y a pas d'options dans le FW original de la U30.

Etant un FW propriétaire sur la U30, est-il en fait possible de faire un PID tuning ? ou il faudrait absolument passer sur un FW marlin ?

Si tu as des conseils ou des tutos pour faire le PID tuning sur la U30, je suis bien preneur.

Merci d'avance.

Cordialement.

 

 

 

Lien à poster
Partager sur d’autres sites

Salut @SiameseDream,

Content que tu ais réussi la réparation.

En ce qui concerne le réglage de PID, je te conseillerai effectivement de passer sous Marlin. Dans ce commentaire, j'explique comment récupérer une version compilée. Le firmware est basé sur une version récente de Marlin, pas la dernière. Sinon, tu peux compiler avec VStudio + platformio.

Tu trouveras ici la commande à utiliser pour le réglage de PID de la buse. Pour le lit, il faut écrire M303 E-1 ... au lieu de M303 E0...

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...