Aller au contenu

Filament ABS

Messages recommandés

Bonjour, à tous

J'ai une Alfawise U20 customisée, avec une carte MKS GEN L V01+ ecran TFT 32 MKS + Bl touch+ TMC 2208.
C'est surtout pour adjoindre le bl touch que mon fils me l'a laissé.
 Et depuis il a acheté une imprimante résine, et l'alfawise est resté à la maison, j'imprime peu.
Mais tout fonctionnait bien. J'ai eu besoin d'imprimer une pièce asymétrique que j'ai dessiné avec Solidworks.
La coque d'un casque d'écoute de chez Steelseries. (Pièce introuvable pour un casque à 250€).
Et là impossible d'obtenir la pièce dans le bon sens, bien qu'en l'inversant dans Cura, ou Simplify.
Mon dessin étant dans le bon sens apparaissait inversé dans le trancheur, puis remis dans le bon sens. J'obtenais toujours une impression miroir.
En consultant divers sites je vois qu'il s'agit peut être bien d'un souci d'inversion d'axes. (quoi que j'en doute).
Donc intervention sur le firmware Marlin 2.00.
Allez savoir pourquoi, je me dis que serai bien de faire une sauvegarde de mon firmware que j'avais eu bien du mal à mettre enplace. Je vois que Avrude peu faire ce genre de travail. Je lance Avrude et aprés plusieurs essais j'obtiens comme prevu un fichier en .hex, que d’après le tuto je pouvais réimplanter au cas ou.

C'est sans doute là que quelque chose c'est mal passé, j'ai peut être débranché le câble trop tôt, pensant que sa ne marchait pas.
Et là catastrophe, l'imprimante ne répond plus avec l'écran tactile,rien ne bouge, panique je démonte la carte.
Je recharge Marlin, gros souci pour y arriver, (problème de compilation) avec Arduino IDE 1.8.8, je passe en 1.8.13 et la sa marche.
J'avais essayé aussi avec Vscode et Platform IO sans succés. Sans doute par ma faute, mauvaise compréhension du logiciel.
Téléversement OK les leds clignotent .
Mais toujours pas de mouvement avec l'écran tactile, connection avec Pronterface j'arrive à bouger les axes, et aussi à faire chaufferla tête mais pas à la température demandée, et pas le lit. Impossible de faire un home.
J'obtiens dans la console pronterface ça "echo:Unknown command: "V/M105" qui se répete à intervalle régulier.
Puis ceci :[ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed
Exception in thread Thread-15:
Traceback (most recent call last):
  File "threading.pyc", line 808, in __bootstrap_inner
  File "threading.pyc", line 761, in run
  File "printrun\printcore.pyc", line 357, in _sender
  File "printrun\printcore.pyc", line 623, in _send
  File "encodings\utf_8.pyc", line 16, in decode
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe8 in position 31: invalid continuation byte.

D’où je conclu que c'est un problème de communication du port usb.

Question : Peut on remettre la carte à zéro ? j'ai essayé avec un arduino en ICSP pour remettre le bootloader, sa ne marche pas.
Bien sur que la bonne solution rapide c'est d'en commander une autre, mais sa ne se fait plus, je crois à la place c'est une MKS V2. et je ne sais pas si ce sera compatible avec l'écran etc.
Merci de votre aide.

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...